summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-10-16 17:32:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-10-16 17:32:55 +0000
commitb99d0765a7236143b4c020a65679ac4ba695d076 (patch)
tree2731374376c48ed1ab4db4df6d07fec7838b127d
parentb1c4e8a7248271c701746224ebbcc6b8817c2db3 (diff)
downloadfreebsd-ports-b99d0765a7236143b4c020a65679ac4ba695d076.zip
devel/google-gdata: Unbreak [1]
- Update MASTER_SITES to use GITHUB instead of GOOGLE CODE [1] - Mark NO_ARCH - Make patches makepatch compatible PR: 213465 [1] Submitted by: lacey.leanne@gmail.com [1]
-rw-r--r--devel/google-gdata/Makefile12
-rw-r--r--devel/google-gdata/distinfo5
-rw-r--r--devel/google-gdata/files/patch-Makefile10
3 files changed, 15 insertions, 12 deletions
diff --git a/devel/google-gdata/Makefile b/devel/google-gdata/Makefile
index 96889c4d35b6..ec61fe6e4214 100644
--- a/devel/google-gdata/Makefile
+++ b/devel/google-gdata/Makefile
@@ -3,22 +3,24 @@
PORTNAME= google-gdata
PORTVERSION= 2.2.0.0
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= libgoogle-data-mono-${PORTVERSION}
MAINTAINER= bofh@FreeBSD.org
COMMENT= DOT NET library for the Google Data API
LICENSE= APACHE20
-BROKEN= Unfetchable (google code has gone away)
-
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/Newtonsoft.Json.pc:devel/newtonsoft-json
+USE_GITHUB= yes
+GH_TUPLE= google:google-gdata:edcd096379
+
USES= dos2unix gmake mono
-DOS2UNIX_FILES= Makefile misc/gdata-sharp-core.pc.in
+WRKSRC_SUBDIR= clients/cs
+DOS2UNIX_FILES= ${WRKSRC}/Makefile ${WRKSRC}/misc/gdata-sharp-core.pc.in
MAKE_ARGS= CSC=${LOCALBASE}/bin/mcs
+NO_ARCH= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Makefile
diff --git a/devel/google-gdata/distinfo b/devel/google-gdata/distinfo
index e1326083dbcf..b697058bee2f 100644
--- a/devel/google-gdata/distinfo
+++ b/devel/google-gdata/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libgoogle-data-mono-2.2.0.0.tar.gz) = 08fa1b9ea5288d03370e3cf257f0549e9b34a1ed87f3ef7ca045c9992618435c
-SIZE (libgoogle-data-mono-2.2.0.0.tar.gz) = 55582011
+TIMESTAMP = 1476625926
+SHA256 (google-google-gdata-2.2.0.0-edcd096379_GH0.tar.gz) = 5af2a99345601e175bd14a275bfa00b23cadfee98bfff0f0d966f189a89056d7
+SIZE (google-google-gdata-2.2.0.0-edcd096379_GH0.tar.gz) = 56738927
diff --git a/devel/google-gdata/files/patch-Makefile b/devel/google-gdata/files/patch-Makefile
index 57997bd48125..0e6b2f9fb50b 100644
--- a/devel/google-gdata/files/patch-Makefile
+++ b/devel/google-gdata/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2014-10-03 03:48:04.991079598 +0600
-+++ Makefile 2014-10-03 03:48:20.722118155 +0600
-@@ -5,7 +5,7 @@
+--- Makefile.orig 2016-10-16 13:47:41 UTC
++++ Makefile
+@@ -5,7 +5,7 @@ DEFINES=/d:TRACE
VERSION=$(shell egrep AssemblyVersion version/AssemblyVersion.cs | egrep -o \([[:digit:]]\.\)+[[:digit:]]+)
PREFIX=/usr/local
@@ -9,7 +9,7 @@
CORELIBS= \
Google.GData.Client.dll \
-@@ -33,7 +33,7 @@
+@@ -33,7 +33,7 @@ ALLLIBS = \
UNINSTALLLIBS = $(basename $(ALLLIBS))
@@ -18,7 +18,7 @@
PKGCONFIG_FILES = $(patsubst %.pc.in,%.pc,$(wildcard misc/*.pc.in))
-@@ -112,7 +112,7 @@
+@@ -112,7 +112,7 @@ clean:
install: all
for i in $(ALLLIBS); do gacutil -i $$i -package GData-Sharp -root "$(DESTDIR)$(PREFIX)/lib"; done
install -d "$(DESTDIR)$(PKGCONFIGDIR)"