summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-31 00:01:02 +0300
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 12:13:01 -0400
commitb8d28925a9b68ed98a7bbd5b659b86505b0d143a (patch)
tree55f8409da4d0ccf09d6b0caf0aa19fe2e0f76cdd
parent2043de1ccc788dae5a870aac0d57fce1c7521f06 (diff)
downloadfreebsd-ports-b8d28925a9b68ed98a7bbd5b659b86505b0d143a.zip
www/angie-module-rtmp: Angie RTMP dynamic module
Module provides HLS and MPEG-DASH live streaming capabilities for those who want a lightweight solution based on the HTTP protocol. The stream is published in the MPEG-TS format over HTTP. MPEG-TS is a widely adopted, well known and well documented streaming format. PR: 273462
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-rtmp/Makefile22
-rw-r--r--www/angie-module-rtmp/files/pkg-message.in15
-rw-r--r--www/angie-module-rtmp/pkg-descr4
-rw-r--r--www/angie-module-rtmp/pkg-plist3
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1dab0aa27334..263e3a5a2449 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -44,6 +44,7 @@
SUBDIR += angie-module-perl
SUBDIR += angie-module-postgres
SUBDIR += angie-module-redis2
+ SUBDIR += angie-module-rtmp
SUBDIR += angie-module-xslt
SUBDIR += anyremote2html
SUBDIR += apache-mode.el
diff --git a/www/angie-module-rtmp/Makefile b/www/angie-module-rtmp/Makefile
new file mode 100644
index 000000000000..1baca0453d21
--- /dev/null
+++ b/www/angie-module-rtmp/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= angie-module-rtmp
+GH_TUPLE= arut:nginx-rtmp-module:v1.2.2:module
+
+COMMENT= Angie RTMP dynamic module
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_rtmp_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_rtmp_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_rtmp_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-rtmp/files/pkg-message.in b/www/angie-module-rtmp/files/pkg-message.in
new file mode 100644
index 000000000000..48595d217317
--- /dev/null
+++ b/www/angie-module-rtmp/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The RTMP dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_rtmp_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/arut/nginx-rtmp-module
+EOM
+}
+]
diff --git a/www/angie-module-rtmp/pkg-descr b/www/angie-module-rtmp/pkg-descr
new file mode 100644
index 000000000000..e15a75721799
--- /dev/null
+++ b/www/angie-module-rtmp/pkg-descr
@@ -0,0 +1,4 @@
+Module provides HLS and MPEG-DASH live streaming capabilities for those who
+want a lightweight solution based on the HTTP protocol.
+The stream is published in the MPEG-TS format over HTTP.
+MPEG-TS is a widely adopted, well known and well documented streaming format.
diff --git a/www/angie-module-rtmp/pkg-plist b/www/angie-module-rtmp/pkg-plist
new file mode 100644
index 000000000000..80f7d5779607
--- /dev/null
+++ b/www/angie-module-rtmp/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.md
+%%MODDIR%%/ngx_rtmp_module.so
+%%DEBUG%%%%MODDIR%%/ngx_rtmp_module-debug.so