summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-13 20:19:11 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-13 20:19:11 +0000
commitb899264b8be1407ffa45daa1fb6b5e7220be27c1 (patch)
tree5131233bd4668f93abd5552f1fbf750c6c2ea5a7
parentcae37f0016f52aa23244b0ec659d8ca59566d2e0 (diff)
downloadfreebsd-ports-b899264b8be1407ffa45daa1fb6b5e7220be27c1.zip
Udpate PyQt5 to 5.6.2
Update PyQt from 5.5.1 to 5.6.2 to match the Qt updates that have already landed in the ports tree. PR: 214355 Submitted by: Adriaan de Groot <groot@kde.org> Reviewed by: rakuco, tcberner Approved by: rakuco (mentor) Exp-Run by: antoine Differential Revision: https://reviews.freebsd.org/D8408
-rw-r--r--Mk/Uses/pyqt.mk6
-rw-r--r--devel/py-qt5-core/files/patch-configure.py45
-rw-r--r--devel/py-qt5-core/pkg-plist1
-rw-r--r--devel/py-qt5/distinfo5
-rw-r--r--devel/py-sip/distinfo5
-rw-r--r--devel/py-sip/pkg-plist1
-rw-r--r--misc/py-qt5-demo/pkg-plist1
-rw-r--r--misc/py-qt5-doc/pkg-plist16
-rw-r--r--x11-toolkits/py-qt5-gui/pkg-plist1
9 files changed, 58 insertions, 23 deletions
diff --git a/Mk/Uses/pyqt.mk b/Mk/Uses/pyqt.mk
index 953ed284c3b0..5d6003cc712c 100644
--- a/Mk/Uses/pyqt.mk
+++ b/Mk/Uses/pyqt.mk
@@ -61,15 +61,15 @@ MASTER_SITES_PYQT5= SF/pyqt/PyQt5/PyQt-${PORTVERSION} \
MASTER_SITES_QSCI2= SF/pyqt/QScintilla2/QScintilla-${PORTVERSION} \
GENTOO
-SIP_VERSION= 4.17
+SIP_VERSION= 4.18
QSCI2_VERSION= 2.9.1
PYQT4_VERSION= 4.11.4
-PYQT5_VERSION= 5.5.1
+PYQT5_VERSION= 5.6
SIP_DISTNAME= sip-${SIP_VERSION}
PYQT4_DISTNAME= PyQt-x11-gpl-${PYQT4_VERSION}
PYQT4_DISTINFO_FILE= ${.CURDIR}/../../devel/${PYQT_RELNAME}/distinfo
-PYQT5_DISTNAME= PyQt-gpl-${PYQT5_VERSION}
+PYQT5_DISTNAME= PyQt5_gpl-${PYQT5_VERSION}
PYQT5_DISTINFO_FILE= ${.CURDIR}/../../devel/py-qt5/distinfo
QSCI2_DISTNAME= QScintilla-gpl-${QSCI2_VERSION}
diff --git a/devel/py-qt5-core/files/patch-configure.py b/devel/py-qt5-core/files/patch-configure.py
index 87e909eb3ffb..27350ce3b841 100644
--- a/devel/py-qt5-core/files/patch-configure.py
+++ b/devel/py-qt5-core/files/patch-configure.py
@@ -3,9 +3,13 @@ This patch is necessary for us to split PyQt5 up into several different ports.
It works by conditionally building and installing some tools (such as
pylupdate5 and pyrcc5), replacing the all-encompassing PyQt5.api file that
depends on different modules with module-specific .api files.
---- configure.py.orig 2015-10-25 11:42:16 UTC
-+++ configure.py
-@@ -1458,13 +1458,13 @@ def generate_makefiles(target_config, ve
+
+Also fixes a bug where dbus support drops multiple -I flags produced
+by pkg-config --cflags dbus-1 .
+
+--- configure.py.orig 2016-04-24 10:55:08.000000000 +0000
++++ configure.py 2016-10-30 22:16:19.159104000 +0000
+@@ -1482,13 +1482,13 @@
generate_sip_module_code(target_config, verbose, no_timestamp, parts,
tracing, 'Qt', sip_flags)
@@ -24,7 +28,7 @@ depends on different modules with module-specific .api files.
# Generate the pyuic5 wrapper.
pyuic_wrapper = generate_pyuic5_wrapper(target_config)
-@@ -1483,22 +1483,6 @@ def generate_makefiles(target_config, ve
+@@ -1507,22 +1507,6 @@
source_path('examples', 'quick', 'tutorials', 'extending',
'chapter6-plugins'))
@@ -47,28 +51,28 @@ depends on different modules with module-specific .api files.
# Generate the Python dbus module.
if target_config.pydbus_module_dir != '':
mname = 'dbus'
-@@ -1526,21 +1510,24 @@ def generate_makefiles(target_config, ve
+@@ -1548,21 +1532,24 @@
out_f.write('''TEMPLATE = subdirs
CONFIG += ordered nostrip
SUBDIRS = %s
-+''' % (' '.join(subdirs)))
++''' % ' '.join(subdirs))
+ if "QtCore" in target_config.pyqt_modules:
+ out_f.write('''
init_py.files = %s
- init_py.path = %s/PyQt5
+ init_py.path = %s
INSTALLS += init_py
--''' % (' '.join(subdirs), source_path('__init__.py'), target_config.pyqt_module_dir))
-+''' % (source_path('__init__.py'), target_config.pyqt_module_dir))
+-''' % (' '.join(subdirs), source_path('__init__.py'), qmake_quote(target_config.pyqt_module_dir + '/PyQt5')))
++''' % (source_path('__init__.py'), qmake_quote(target_config.pyqt_module_dir + '/PyQt5')))
- # Install the uic module and the pyuic5 wrapper.
- out_f.write('''
+ # Install the uic module and the pyuic5 wrapper.
+ out_f.write('''
uic_package.files = %s
- uic_package.path = %s/PyQt5
+ uic_package.path = %s
INSTALLS += uic_package
- ''' % (source_path('pyuic', 'uic'), target_config.pyqt_module_dir))
+ ''' % (source_path('pyuic', 'uic'), qmake_quote(target_config.pyqt_module_dir + '/PyQt5')))
- if not target_config.no_tools:
- out_f.write('''
@@ -77,7 +81,7 @@ depends on different modules with module-specific .api files.
pyuic5.files = %s
pyuic5.path = %s
INSTALLS += pyuic5
-@@ -1548,11 +1535,12 @@ INSTALLS += pyuic5
+@@ -1579,11 +1566,12 @@
# Install the QScintilla .api file.
if target_config.qsci_api:
@@ -85,10 +89,21 @@ depends on different modules with module-specific .api files.
out_f.write('''
-qscintilla_api.files = PyQt5.api
+qscintilla_api.files = %s
- qscintilla_api.path = %s/api/python
+ qscintilla_api.path = %s
INSTALLS += qscintilla_api
--''' % target_config.qsci_api_dir)
-+''' % (api_list, target_config.qsci_api_dir))
+-''' % qmake_quote(target_config.qsci_api_dir + '/api/python'))
++''' % (api_list, qmake_quote(target_config.qsci_api_dir + '/api/python')))
out_f.close()
+@@ -2140,7 +2128,9 @@
+ else:
+ dlist = target_config.dbus_inc_dirs
+
+- target_config.dbus_inc_dirs = []
++ # Don't reset dbus_inc_dirs, because it will forget the flags
++ # found for dbus, above (which might require multiple -I flags).
++ # target_config.dbus_inc_dirs = []
+
+ for d in dlist:
+ if os.access(os.path.join(d, 'dbus', 'dbus-python.h'), os.F_OK):
diff --git a/devel/py-qt5-core/pkg-plist b/devel/py-qt5-core/pkg-plist
index 433ef5d6b609..28950ed04e4e 100644
--- a/devel/py-qt5-core/pkg-plist
+++ b/devel/py-qt5-core/pkg-plist
@@ -213,6 +213,7 @@ bin/pyuic5
%%PYQT_SIPDIR%%/QtCore/quuid.sip
%%PYQT_SIPDIR%%/QtCore/qvariant.sip
%%PYQT_SIPDIR%%/QtCore/qvariantanimation.sip
+%%PYQT_SIPDIR%%/QtCore/qversionnumber.sip
%%PYQT_SIPDIR%%/QtCore/qwaitcondition.sip
%%PYQT_SIPDIR%%/QtCore/qwineventnotifier.sip
%%PYQT_SIPDIR%%/QtCore/qxmlstream.sip
diff --git a/devel/py-qt5/distinfo b/devel/py-qt5/distinfo
index 0dc55e6f9f49..c79dd9c9ce16 100644
--- a/devel/py-qt5/distinfo
+++ b/devel/py-qt5/distinfo
@@ -1,2 +1,3 @@
-SHA256 (PyQt-gpl-5.5.1.tar.gz) = 0a70ef94fbffcf674b0dde024aae2a2a7a3f5a8c42806109ff7df2c941bd8386
-SIZE (PyQt-gpl-5.5.1.tar.gz) = 3705749
+TIMESTAMP = 1477759251
+SHA256 (PyQt5_gpl-5.6.tar.gz) = 2e481a6c4c41b96ed3b33449e5f9599987c63a5c8db93313bd57a6acbf20f0e1
+SIZE (PyQt5_gpl-5.6.tar.gz) = 3720782
diff --git a/devel/py-sip/distinfo b/devel/py-sip/distinfo
index 068a695edc90..4191b9e0956c 100644
--- a/devel/py-sip/distinfo
+++ b/devel/py-sip/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sip-4.17.tar.gz) = 603026822adf8673fca6e0ea20b02c3c4a2dccb309647656f7269adc8de89060
-SIZE (sip-4.17.tar.gz) = 959835
+TIMESTAMP = 1473848835
+SHA256 (sip-4.18.tar.gz) = f1dc5c81c07a9ad97edcd4a0af964a41e420024ba7ca165afd2b351efd249cb6
+SIZE (sip-4.18.tar.gz) = 991980
diff --git a/devel/py-sip/pkg-plist b/devel/py-sip/pkg-plist
index 0a560907a499..6722afa4f48b 100644
--- a/devel/py-sip/pkg-plist
+++ b/devel/py-sip/pkg-plist
@@ -1,6 +1,7 @@
bin/sip
%%PYTHON_INCLUDEDIR%%/sip.h
%%PYTHON_SITELIBDIR%%/sip.so
+%%PYTHON_SITELIBDIR%%/sip.pyi
%%PYTHON_SITELIBDIR%%/sipconfig.py
%%PYTHON_SITELIBDIR%%/sipconfig.pyc
%%PYTHON_SITELIBDIR%%/sipconfig.pyo
diff --git a/misc/py-qt5-demo/pkg-plist b/misc/py-qt5-demo/pkg-plist
index 432fd8647304..630a3a1400fb 100644
--- a/misc/py-qt5-demo/pkg-plist
+++ b/misc/py-qt5-demo/pkg-plist
@@ -1068,7 +1068,6 @@
%%EXAMPLESDIR%%/webkit/domtraversal/ui_window.pyc
%%EXAMPLESDIR%%/webkit/domtraversal/ui_window.pyo
%%EXAMPLESDIR%%/webkit/domtraversal/window.ui
-%%EXAMPLESDIR%%/webkit/fancybrowser/__pycache__/jquery_rc.cpython-34.pyc
%%EXAMPLESDIR%%/webkit/fancybrowser/fancybrowser.py
%%EXAMPLESDIR%%/webkit/fancybrowser/fancybrowser.pyc
%%EXAMPLESDIR%%/webkit/fancybrowser/fancybrowser.pyo
diff --git a/misc/py-qt5-doc/pkg-plist b/misc/py-qt5-doc/pkg-plist
index 0a5aec6d5dc2..0d16a11cdb34 100644
--- a/misc/py-qt5-doc/pkg-plist
+++ b/misc/py-qt5-doc/pkg-plist
@@ -610,8 +610,10 @@
%%DOCSDIR%%/html/_sources/api/qqmlpropertyvaluesource.txt
%%DOCSDIR%%/html/_sources/api/qqmlscriptstring.txt
%%DOCSDIR%%/html/_sources/api/qquaternion.txt
+%%DOCSDIR%%/html/_sources/api/qquickasyncimageprovider.txt
%%DOCSDIR%%/html/_sources/api/qquickframebufferobject.txt
%%DOCSDIR%%/html/_sources/api/qquickimageprovider.txt
+%%DOCSDIR%%/html/_sources/api/qquickimageresponse.txt
%%DOCSDIR%%/html/_sources/api/qquickitem.txt
%%DOCSDIR%%/html/_sources/api/qquickitemgrabresult.txt
%%DOCSDIR%%/html/_sources/api/qquickpainteditem.txt
@@ -640,6 +642,7 @@
%%DOCSDIR%%/html/_sources/api/qregularexpressionvalidator.txt
%%DOCSDIR%%/html/_sources/api/qresizeevent.txt
%%DOCSDIR%%/html/_sources/api/qresource.txt
+%%DOCSDIR%%/html/_sources/api/qrgba64.txt
%%DOCSDIR%%/html/_sources/api/qrotationfilter.txt
%%DOCSDIR%%/html/_sources/api/qrotationreading.txt
%%DOCSDIR%%/html/_sources/api/qrotationsensor.txt
@@ -889,6 +892,7 @@
%%DOCSDIR%%/html/_sources/api/qwebelement.txt
%%DOCSDIR%%/html/_sources/api/qwebelementcollection.txt
%%DOCSDIR%%/html/_sources/api/qwebenginecertificateerror.txt
+%%DOCSDIR%%/html/_sources/api/qwebenginecookiestore.txt
%%DOCSDIR%%/html/_sources/api/qwebenginedownloaditem.txt
%%DOCSDIR%%/html/_sources/api/qwebenginehistory.txt
%%DOCSDIR%%/html/_sources/api/qwebenginehistoryitem.txt
@@ -897,6 +901,10 @@
%%DOCSDIR%%/html/_sources/api/qwebenginescript.txt
%%DOCSDIR%%/html/_sources/api/qwebenginescriptcollection.txt
%%DOCSDIR%%/html/_sources/api/qwebenginesettings.txt
+%%DOCSDIR%%/html/_sources/api/qwebengineurlrequestinfo.txt
+%%DOCSDIR%%/html/_sources/api/qwebengineurlrequestinterceptor.txt
+%%DOCSDIR%%/html/_sources/api/qwebengineurlrequestjob.txt
+%%DOCSDIR%%/html/_sources/api/qwebengineurlschemehandler.txt
%%DOCSDIR%%/html/_sources/api/qwebengineview.txt
%%DOCSDIR%%/html/_sources/api/qwebframe.txt
%%DOCSDIR%%/html/_sources/api/qwebhistory.txt
@@ -1623,8 +1631,10 @@
%%DOCSDIR%%/html/api/qqmlpropertyvaluesource.html
%%DOCSDIR%%/html/api/qqmlscriptstring.html
%%DOCSDIR%%/html/api/qquaternion.html
+%%DOCSDIR%%/html/api/qquickasyncimageprovider.html
%%DOCSDIR%%/html/api/qquickframebufferobject.html
%%DOCSDIR%%/html/api/qquickimageprovider.html
+%%DOCSDIR%%/html/api/qquickimageresponse.html
%%DOCSDIR%%/html/api/qquickitem.html
%%DOCSDIR%%/html/api/qquickitemgrabresult.html
%%DOCSDIR%%/html/api/qquickpainteditem.html
@@ -1653,6 +1663,7 @@
%%DOCSDIR%%/html/api/qregularexpressionvalidator.html
%%DOCSDIR%%/html/api/qresizeevent.html
%%DOCSDIR%%/html/api/qresource.html
+%%DOCSDIR%%/html/api/qrgba64.html
%%DOCSDIR%%/html/api/qrotationfilter.html
%%DOCSDIR%%/html/api/qrotationreading.html
%%DOCSDIR%%/html/api/qrotationsensor.html
@@ -1902,6 +1913,7 @@
%%DOCSDIR%%/html/api/qwebelement.html
%%DOCSDIR%%/html/api/qwebelementcollection.html
%%DOCSDIR%%/html/api/qwebenginecertificateerror.html
+%%DOCSDIR%%/html/api/qwebenginecookiestore.html
%%DOCSDIR%%/html/api/qwebenginedownloaditem.html
%%DOCSDIR%%/html/api/qwebenginehistory.html
%%DOCSDIR%%/html/api/qwebenginehistoryitem.html
@@ -1910,6 +1922,10 @@
%%DOCSDIR%%/html/api/qwebenginescript.html
%%DOCSDIR%%/html/api/qwebenginescriptcollection.html
%%DOCSDIR%%/html/api/qwebenginesettings.html
+%%DOCSDIR%%/html/api/qwebengineurlrequestinfo.html
+%%DOCSDIR%%/html/api/qwebengineurlrequestinterceptor.html
+%%DOCSDIR%%/html/api/qwebengineurlrequestjob.html
+%%DOCSDIR%%/html/api/qwebengineurlschemehandler.html
%%DOCSDIR%%/html/api/qwebengineview.html
%%DOCSDIR%%/html/api/qwebframe.html
%%DOCSDIR%%/html/api/qwebhistory.html
diff --git a/x11-toolkits/py-qt5-gui/pkg-plist b/x11-toolkits/py-qt5-gui/pkg-plist
index 16429f281e9e..e9986cef37f9 100644
--- a/x11-toolkits/py-qt5-gui/pkg-plist
+++ b/x11-toolkits/py-qt5-gui/pkg-plist
@@ -65,6 +65,7 @@
%%PYQT_SIPDIR%%/QtGui/qrawfont.sip
%%PYQT_SIPDIR%%/QtGui/qregion.sip
%%PYQT_SIPDIR%%/QtGui/qrgb.sip
+%%PYQT_SIPDIR%%/QtGui/qrgba64.sip
%%PYQT_SIPDIR%%/QtGui/qscreen.sip
%%PYQT_SIPDIR%%/QtGui/qsessionmanager.sip
%%PYQT_SIPDIR%%/QtGui/qstandarditemmodel.sip