summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-20 20:13:45 +0300
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-21 13:58:40 +0300
commitb18f62915afacc17a458602975faddc466650ea0 (patch)
treeb7ce418c18bb49b18432ad86c21c184622089097
parent930867e807d0e7c292363a10662eaa03728ac2d1 (diff)
downloadfreebsd-ports-b18f62915afacc17a458602975faddc466650ea0.zip
databases/py-pgcli: fix tests
Switch to USES=pytest, add missing test depend, and document one failing test Approved by: portmgr blanket
-rw-r--r--databases/py-pgcli/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/databases/py-pgcli/Makefile b/databases/py-pgcli/Makefile
index 819a8fda9855..ee2cdefdf2b4 100644
--- a/databases/py-pgcli/Makefile
+++ b/databases/py-pgcli/Makefile
@@ -24,10 +24,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cli-helpers>=2.1.1:devel/py-cli-helpers@${PY
${PYTHON_PKGNAMEPREFIX}sqlparse>=0.3.0<0.5:databases/py-sqlparse@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=2.7.0,1:devel/py-pytest@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pytest>=2.7.0,1:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sshtunnel>=0:net/py-sshtunnel@${PY_FLAVOR}
-USES= pgsql python:3.6+
+USES= pgsql python:3.6+ pytest
USE_PYTHON= autoplist concurrent distutils
+PYTEST_BROKEN_TESTS= test_obfuscate_process_password
NO_ARCH= yes
@@ -36,7 +38,4 @@ KEYRING_DESC= keyring support
KEYRING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyring>=12.2.0,1:security/py-keyring@${PY_FLAVOR}
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
-
.include <bsd.port.mk>