summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-11 08:25:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-11 08:25:47 +0000
commitaed5d3d49cbe3699ed4e76231fb40a346b47259f (patch)
tree2af3c72013929f5be6c8a33886031c6b9c3e6dd4
parent0f97803bfe98de07073e829a518ea69d741b66f1 (diff)
downloadfreebsd-ports-aed5d3d49cbe3699ed4e76231fb40a346b47259f.zip
print/tex-xetex, print/tex-luatex: prepare for poppler upgrade
There are many api changes inside poppler, and our TeX distribution is ancient. For now, switch these to use their bundled version of poppler. PR: 233452
-rw-r--r--print/tex-luatex/Makefile8
-rw-r--r--print/tex-xetex/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/print/tex-luatex/Makefile b/print/tex-luatex/Makefile
index 2677670ac443..1638dc68df2c 100644
--- a/print/tex-luatex/Makefile
+++ b/print/tex-luatex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= luatex
PORTVERSION= 0.80.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
PKGNAMEPREFIX= tex-
@@ -16,7 +16,6 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= Extended version of pdfTeX using Lua
LIB_DEPENDS= libpng.so:graphics/png \
- libpoppler.so:graphics/poppler \
libmpfr.so:math/mpfr \
libzzip.so:devel/zziplib
@@ -31,6 +30,7 @@ EXTRACT_FILES= build-aux \
libs/xpdf \
libs/lua52 \
libs/luajit \
+ libs/poppler \
texk/web2c
EXTRACT_AFTER_ARGS_TEXMF=| ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
@@ -66,7 +66,7 @@ EXCLUDE_ENGINES=aleph etex pdftex mf mf-nowin \
CONFIGURE_ARGS= ${EXCLUDE_ENGINES:S/^/--disable-/} \
--enable-luatex \
--enable-luajittex \
- --with-system-poppler \
+ --without-system-poppler \
--with-system-zlib \
--with-system-zziplib
.for L in cairo gmp kpathsea libpng mpfr pixman ptexenc
@@ -84,7 +84,7 @@ post-extract:
${LN} -s -f ${LOCALBASE}/${TEXMFDISTDIR}/web2c kpathsea
pre-configure:
- for D in libs/xpdf; do \
+ for D in libs/xpdf libs/poppler; do \
cd ${WRKDIR}/${DISTNAME}/$$D && \
${SETENV} ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} \
${CONFIGURE_ARGS}; \
diff --git a/print/tex-xetex/Makefile b/print/tex-xetex/Makefile
index 12dec8f4d7a1..c206452e89d5 100644
--- a/print/tex-xetex/Makefile
+++ b/print/tex-xetex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xetex
PORTVERSION= 0.99992
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
PKGNAMEPREFIX= tex-
@@ -21,7 +21,6 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz \
libharfbuzz-icu.so:print/harfbuzz-icu \
libpng.so:graphics/png \
- libpoppler.so:graphics/poppler \
libTECkit.so:textproc/teckit
USES= compiler:c++11-lib pkgconfig tar:xz
@@ -32,6 +31,7 @@ USE_GNOME= cairo
TEXHASHDIRS= ${TEXMFDISTDIR} ${TEXMFVARDIR}
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= build-aux \
+ libs/poppler \
libs/xpdf \
texk/web2c
EXTRACT_AFTER_ARGS_TEXMF= \
@@ -66,7 +66,7 @@ CONFIGURE_ARGS= ${EXCLUDE_ENGINES:S/^/--disable-/} \
--with-graphite2-includes=${LOCALBASE}/include/graphite2 \
--with-graphite2-libdir=${LOCALBASE}/lib \
--with-system-harfbuzz \
- --with-system-poppler \
+ --without-system-poppler \
--with-system-teckit \
--with-teckit-includes=${LOCALBASE}/include/teckit \
--with-teckit-libdir=${LOCALBASE}/lib \
@@ -82,7 +82,7 @@ MAKE_JOBS_UNSAFE= yes
TEX_FORMATS= xetex
pre-configure:
- for D in libs/xpdf; do \
+ for D in libs/xpdf libs/poppler; do \
cd ${WRKDIR}/${DISTNAME}/$$D && \
${SETENV} ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} \
${CONFIGURE_ARGS}; \