summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-25 11:00:15 +0200
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-25 11:42:18 +0200
commitadc957c9785a00106960778484116ef3e39cea48 (patch)
treeb3725a3d12d921e86e50a555341e46b0fa69b0e3
parent28223e1aff3e81e2420dd8cbe3cf0af81d08adab (diff)
downloadfreebsd-ports-adc957c9785a00106960778484116ef3e39cea48.zip
games/nethack34: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--games/nethack34/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 0dc34198b160..a2cf4a77951a 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -17,6 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${TRUEPORTNAME}-${PORTVERSION}
USES= alias gmake ncurses tar:tgz
+
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
@@ -80,6 +81,10 @@ PLIST_SUB+= HACKLINK=""
PLIST_SUB+= HACKLINK="@comment "
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
pre-everything::
@if [ "${PKGBASE}" != "nethack" ]; then \
${ECHO_MSG} "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" ; \