summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-27 00:51:33 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-27 00:51:33 +0000
commitad7d492f2bcf7a3b23b13d088b48aab0a54036a8 (patch)
tree05e34293fcb492c996f41f964e4c533be628bc27
parentb306894ebcb0ef1d315413015df5eaaa6e334efd (diff)
downloadfreebsd-ports-ad7d492f2bcf7a3b23b13d088b48aab0a54036a8.zip
textproc/ocaml-tyxml: Upgrade 2.0.1 -> 2.2.0 and support stage
The implements the referenced PR and then stage support was added. The latter largely came from the pkgsrc version of this port which has the same maintainer. The modified LGPL license (with an OpenSSL exception) was annotated as well. PR: ports/176065 Submitted by: maintainer (Jaap Boender) Stage support: Taken from pkgsrc
-rw-r--r--textproc/ocaml-tyxml/Makefile29
-rw-r--r--textproc/ocaml-tyxml/distinfo4
-rw-r--r--textproc/ocaml-tyxml/files/patch-Makefile28
-rw-r--r--textproc/ocaml-tyxml/files/patch-Makefile.config11
-rw-r--r--textproc/ocaml-tyxml/files/patch-lib_Makefile13
5 files changed, 54 insertions, 31 deletions
diff --git a/textproc/ocaml-tyxml/Makefile b/textproc/ocaml-tyxml/Makefile
index b4f7d4169f64..90712777b0bb 100644
--- a/textproc/ocaml-tyxml/Makefile
+++ b/textproc/ocaml-tyxml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tyxml
-PORTVERSION= 2.0.1
+PORTVERSION= 2.2.0
CATEGORIES= textproc
MASTER_SITES= http://ocsigen.org/download/
PKGNAMEPREFIX= ocaml-
@@ -10,28 +10,21 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= jaapb@kerguelen.org
COMMENT= OCaml XML typing library
-USE_GMAKE= yes
+LICENSE= LGPL21_SSLEX
+LICENSE_NAME= Lesser GPL 2.1 with a special OpenSSL exception clause
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BUILD_DEPENDS= ${SA_DIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
+RUN_DEPENDS= ${SA_DIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
+
+USES= gmake
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAMLFIND_PLIST= yes
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+MAKE_ENV+= INSTALLDIR="${STAGEDIR}${SA_DIR}"
-BUILD_DEPENDS+= ${SA_DIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
-RUN_DEPENDS+= ${SA_DIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-post-extract:
-# For nonstandard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
-.endif
-.if !exists(${OCAMLFIND_LDCONF})
- ${TOUCH} ${OCAMLFIND_LDCONF}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ocaml-tyxml/distinfo b/textproc/ocaml-tyxml/distinfo
index 326060c6b086..60e3baa5d9f0 100644
--- a/textproc/ocaml-tyxml/distinfo
+++ b/textproc/ocaml-tyxml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tyxml-2.0.1.tar.gz) = ad6bc8751d87f414d5c12962e8b94f064e3ccfb5af18367a031eabf540ceffb4
-SIZE (tyxml-2.0.1.tar.gz) = 104721
+SHA256 (tyxml-2.2.0.tar.gz) = 8eab54f5fd7e9f5df3ac894123bd5abb124d741411a0ad5333e5058e44325f84
+SIZE (tyxml-2.2.0.tar.gz) = 105748
diff --git a/textproc/ocaml-tyxml/files/patch-Makefile b/textproc/ocaml-tyxml/files/patch-Makefile
new file mode 100644
index 000000000000..4c1d8045c00c
--- /dev/null
+++ b/textproc/ocaml-tyxml/files/patch-Makefile
@@ -0,0 +1,28 @@
+$NetBSD: patch-Makefile,v 1.2 2013/06/11 14:52:40 jaapb Exp $
+
+--- Makefile.orig 2012-12-07 15:15:22.000000000 +0000
++++ Makefile
+@@ -52,19 +52,20 @@ files/META.tyxml: files/META.in Makefile
+ $< > $@
+
+ install:
++ mkdir -p ${INSTALLDIR}
+ $(OCAMLFIND) install ${PACKAGENAME} \
+- -patch-version ${VERSION} \
++ -patch-version ${VERSION} -destdir ${INSTALLDIR} \
+ files/META ${INTF} ${IMPL} ${NATIMPL} \
+ ${MLI_TO_INSTALL}
+
+ install-byte:
+ $(OCAMLFIND) install ${PACKAGENAME} \
+- -patch-version ${VERSION} \
++ -patch-version ${VERSION} -destdir ${INSTALLDIR} \
+ files/META ${INTF} ${IMPL} ${MLI_TO_INSTALL}
+
+ install-opt:
+ $(OCAMLFIND) install ${PACKAGENAME} \
+- -patch-version ${VERSION} \
++ -patch-version ${VERSION} -destdir ${INSTALLDIR} \
+ files/META ${INTF} ${NATIMPL} ${MLI_TO_INSTALL}
+
+ uninstall:
diff --git a/textproc/ocaml-tyxml/files/patch-Makefile.config b/textproc/ocaml-tyxml/files/patch-Makefile.config
deleted file mode 100644
index 432521b86988..000000000000
--- a/textproc/ocaml-tyxml/files/patch-Makefile.config
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.config.orig 2011-12-14 13:19:51.645986499 +0100
-+++ Makefile.config 2011-12-14 13:19:57.053913205 +0100
-@@ -11,7 +11,7 @@
-
- ## Build options
-
--OCAMLDUCE :=YES
-+#OCAMLDUCE :=YES
- NATDYNLINK :=YES
-
- # DBG := -g
diff --git a/textproc/ocaml-tyxml/files/patch-lib_Makefile b/textproc/ocaml-tyxml/files/patch-lib_Makefile
new file mode 100644
index 000000000000..10efb10e7601
--- /dev/null
+++ b/textproc/ocaml-tyxml/files/patch-lib_Makefile
@@ -0,0 +1,13 @@
+$NetBSD: patch-lib_Makefile,v 1.1 2013/06/11 14:52:40 jaapb Exp $
+
+--- lib/Makefile.orig 2012-12-07 15:15:22.000000000 +0000
++++ lib/Makefile
+@@ -13,7 +13,7 @@ DUCE_INTF := xml_sigs_duce.mli xhtml_ty
+
+ DUCE_FILES := xml_print_duce.ml xhtml_duce.ml
+
+-LIBS := -package netstring
++LIBS := -package netstring,netstring-pcre
+
+ # SYNTAX := -ppopt ../syntax/pa_include.cmo -package camlp4 -syntax camlp4o
+