summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-03-16 06:52:11 +0100
committerKai Knoblich <kai@FreeBSD.org>2023-03-16 06:52:11 +0100
commitaa25e5ba5bf91013218c8e5e3168e44b4050b609 (patch)
tree52eba84a06ad0089df67f508aa6a407b0a00bb58
parent13681d540b540fb1b42723a23240bb5cb510e92e (diff)
downloadfreebsd-ports-aa25e5ba5bf91013218c8e5e3168e44b4050b609.zip
textproc/py-mkdocs-material-extensions: Switch to PEP517
* Remove no longer required setuptools workaround. * Bump PORTREVISION due package change.
-rw-r--r--textproc/py-mkdocs-material-extensions/Makefile12
-rw-r--r--textproc/py-mkdocs-material-extensions/files/patch-setup.py39
2 files changed, 4 insertions, 47 deletions
diff --git a/textproc/py-mkdocs-material-extensions/Makefile b/textproc/py-mkdocs-material-extensions/Makefile
index 05887444fddd..be335ae786a8 100644
--- a/textproc/py-mkdocs-material-extensions/Makefile
+++ b/textproc/py-mkdocs-material-extensions/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mkdocs-material-extensions
DISTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,16 +13,11 @@ WWW= https://github.com/facelessuser/mkdocs-material-extensions
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.1:devel/py-hatchling@${PY_FLAVOR}
+
USES= python:3.7+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
NO_ARCH= yes
-# Avoid that pyproject.toml is read during setup otherwise build fails
-post-extract:
- @${MV} ${WRKSRC}/pyproject.toml ${WRKSRC}/pyproject.toml.dist
-
-post-patch:
- @${REINPLACE_CMD} -e 's/%%DISTVERSION%%/${DISTVERSION}/' ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/textproc/py-mkdocs-material-extensions/files/patch-setup.py b/textproc/py-mkdocs-material-extensions/files/patch-setup.py
deleted file mode 100644
index 5e5f58b78ef7..000000000000
--- a/textproc/py-mkdocs-material-extensions/files/patch-setup.py
+++ /dev/null
@@ -1,39 +0,0 @@
-Generated via adding
-
-[tool.hatch.build.targets.sdist]
-support-legacy = true
-
-to setup.py and then run "hatchling build".
-
---- setup.py.orig 2022-12-20 11:05:40 UTC
-+++ setup.py
-@@ -0,0 +1,29 @@
-+# -*- coding: utf-8 -*-
-+from setuptools import setup
-+
-+setup(
-+ name='mkdocs-material-extensions',
-+ version='%%DISTVERSION%%',
-+ description='Extension pack for Python Markdown and MkDocs Material.',
-+ long_description="",
-+ author_email='Isaac Muse <Isaac.Muse@gmail.com>',
-+ classifiers=[
-+ 'Development Status :: 5 - Production/Stable',
-+ 'Environment :: Console',
-+ 'Intended Audience :: Developers',
-+ 'License :: OSI Approved :: MIT License',
-+ 'Operating System :: OS Independent',
-+ 'Programming Language :: Python :: 3',
-+ 'Programming Language :: Python :: 3.7',
-+ 'Programming Language :: Python :: 3.8',
-+ 'Programming Language :: Python :: 3.9',
-+ 'Programming Language :: Python :: 3.10',
-+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
-+ 'Topic :: Software Development :: Libraries :: Python Modules',
-+ 'Topic :: Text Processing :: Filters',
-+ 'Topic :: Text Processing :: Markup :: HTML',
-+ ],
-+ packages=[
-+ 'materialx',
-+ ],
-+)