summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-07-22 10:15:30 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-07-22 10:15:30 +0000
commit9f307bc6e46cccde72b329525602276a60284155 (patch)
tree0329d993d2c8571031ac35481b9a346bdcc32f80
parentb25b5a01c79ea1cc4b902f439995e6530c255141 (diff)
downloadfreebsd-ports-9f307bc6e46cccde72b329525602276a60284155.zip
graphics/opencollada: update to 1.6.63
Bump PORTREVISION for dependent ports Reported by: portscout Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D16353
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--graphics/blender/Makefile2
-rw-r--r--graphics/opencollada/Makefile10
-rw-r--r--graphics/opencollada/distinfo6
-rw-r--r--graphics/opencollada/files/patch-2d6694340
5 files changed, 8 insertions, 52 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 229e8cbe09da..f592b06a2416 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -2,7 +2,7 @@
.include "${.CURDIR}/Makefile.common"
-PORTREVISION= 1
+PORTREVISION= 2
MASTER_SITES= https://download.documentfoundation.org/libreoffice/src/${PORTVERSION}/ \
https://dev-www.libreoffice.org/src/:src \
https://dev-www.libreoffice.org/extern/:ext
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index ec6aa9a7321f..7b9e1cb87c70 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blender
PORTVERSION= 2.79b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics games
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
diff --git a/graphics/opencollada/Makefile b/graphics/opencollada/Makefile
index 14e10db3f66b..898bb5f56990 100644
--- a/graphics/opencollada/Makefile
+++ b/graphics/opencollada/Makefile
@@ -2,8 +2,7 @@
PORTNAME= opencollada
DISTVERSIONPREFIX= v
-DISTVERSION= 1.6.47
-PORTREVISION= 2
+DISTVERSION= 1.6.63
CATEGORIES= graphics devel
MAINTAINER= ports@FreeBSD.org
@@ -24,11 +23,8 @@ GH_PROJECT= OpenCOLLADA
USE_GNOME= libxml2
USE_LDCONFIG= ${PREFIX}/lib/opencollada
CFLAGS+= -I/${LOCALBASE}/include -Wno-narrowing
-CMAKE_ARGS+= -DUSE_SHARED:BOOL=ON -DUSE_STATIC:BOOL=OFF
-
-# for files/patch-2d66943
-DOS2UNIX_FILES= COLLADABaseUtils/include/COLLADABUPcreCompiledPattern.h \
- COLLADABaseUtils/src/COLLADABUURI.cpp
+CMAKE_ON= USE_SHARED
+CMAKE_OFF= USE_STATIC
post-patch:
@${REINPLACE_CMD} -e 's|$${OPENCOLLADA_INST_LIBRARY}/cmake|${PREFIX}/share/cmake/Modules|' \
diff --git a/graphics/opencollada/distinfo b/graphics/opencollada/distinfo
index eeac399023a8..b94828562b9d 100644
--- a/graphics/opencollada/distinfo
+++ b/graphics/opencollada/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494445478
-SHA256 (KhronosGroup-OpenCOLLADA-v1.6.47_GH0.tar.gz) = cba45eb0894e4eb8351f98cf699e51174817a2fdfb95e73b5f0942833e68f46c
-SIZE (KhronosGroup-OpenCOLLADA-v1.6.47_GH0.tar.gz) = 11947753
+TIMESTAMP = 1532007964
+SHA256 (KhronosGroup-OpenCOLLADA-v1.6.63_GH0.tar.gz) = 3a0e25f38262d872c393bbf14ff0ce2ef6a7d66bb0d57e080cfd9e37be7ee076
+SIZE (KhronosGroup-OpenCOLLADA-v1.6.63_GH0.tar.gz) = 12094044
diff --git a/graphics/opencollada/files/patch-2d66943 b/graphics/opencollada/files/patch-2d66943
deleted file mode 100644
index 7a650a2fc23c..000000000000
--- a/graphics/opencollada/files/patch-2d66943
+++ /dev/null
@@ -1,40 +0,0 @@
-From 2d66943f7ce1ba92b3cc39ad11b5c82e6d3a538f Mon Sep 17 00:00:00 2001
-From: Jonathan Scruggs <j.scruggs@gmail.com>
-Date: Wed, 10 Jan 2018 14:06:48 +0000
-Subject: [PATCH] Add signed char keyword
-
-On PowerPC and PowerPC64 systems, 'char' is unsigned by default.
-Can be reproduced by using the -funsigned-char flag for gcc.
-Adding the signed keyword adds compatibility on these systems.
-
-Signed-off by: Jonathan Scruggs <j.scruggs@gmail.com>
----
- COLLADABaseUtils/src/COLLADABUURI.cpp | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/COLLADABaseUtils/src/COLLADABUURI.cpp b/COLLADABaseUtils/src/COLLADABUURI.cpp
-index 1d03561a..ae403d8a 100644
---- COLLADABaseUtils/src/COLLADABUURI.cpp.orig 2018-02-05 10:56:11 UTC
-+++ COLLADABaseUtils/src/COLLADABUURI.cpp
-@@ -32,7 +32,7 @@ namespace COLLADABU
-
-
-
-- const char HEX2DEC[256] =
-+ const signed char HEX2DEC[256] =
- {
- /* 0 1 2 3 4 5 6 7 8 9 A B C D E F */
- /* 0 */ -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1,
-@@ -107,9 +107,9 @@ namespace COLLADABU
- {
- if (*pSrc == '%')
- {
-- char dec1, dec2;
-- if ( (char)(-1) != (dec1 = HEX2DEC[*(pSrc + 1)])
-- && (char)(-1) != (dec2 = HEX2DEC[*(pSrc + 2)]))
-+ signed char dec1, dec2;
-+ if ( (signed char)(-1) != (dec1 = HEX2DEC[*(pSrc + 1)])
-+ && (signed char)(-1) != (dec2 = HEX2DEC[*(pSrc + 2)]))
- {
- *pEnd++ = (dec1 << 4) + dec2;
- pSrc += 3;