summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-15 04:44:16 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-15 04:44:16 +0000
commit981ef01053190eec6770b3bb2c30a5302893c544 (patch)
tree4a7165ca54ab63b73ce06bfb1e58ad8b37bc1227
parent2b8acb7b5c5b3df255514488230f4df0d0bc33cd (diff)
downloadfreebsd-ports-981ef01053190eec6770b3bb2c30a5302893c544.zip
- Fix run-time linker errors due to missing -I, -L flags for.
Reported by: Dmitry Banschikov <d.banschikov@peterhost.ru> (maintainer)
-rw-r--r--www/mod_tsa/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/mod_tsa/Makefile b/www/mod_tsa/Makefile
index a9ffe98b81e0..6b20f3f579f8 100644
--- a/www/mod_tsa/Makefile
+++ b/www/mod_tsa/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_tsa
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://am.nesiac.org/static/ \
http://ubique.spb.ru/src/
@@ -36,6 +36,8 @@ AP_EXTRAS+= -DMOD_TSA_VERSION=\\\"mod_tsa/${PORTVERSION}\\\"
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= mod_tsa.c tsa_util.c
+AP_INC= ${LOCALBASE}/include
+AP_LIB= ${LOCALBASE}/lib
PORTEXAMPLES= *.sql tsa.conf
@@ -45,18 +47,22 @@ PORTEXAMPLES= *.sql tsa.conf
USE_MYSQL= yes
CONFIGURE_ARGS+= --enable-mysql=yes
SRC_FILE+= db_mysql.c
+AP_INC+= -I${LOCALBASE}/include/mysql
+AP_LIB+= -L${LOCALBASE}/lib/mysql -lmysqlclient
.endif
.if defined(WITH_PGSQL)
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-pgsql=yes
SRC_FILE+= db_postgresql.c
+AP_LIB+= -lpq
.endif
.if defined(WITH_FIREBIRD)
USE_FIREBIRD= yes
CONFIGURE_ARGS+= --enable-firebird=yes
SRC_FILE+= db_firebird.c
+AP_LIB+= -lgds
.endif
.if defined(WITH_DEBUG)