summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2023-01-02 06:26:47 +0900
committerHiroki Sato <hrs@FreeBSD.org>2023-01-02 06:28:14 +0900
commit972c8dc86b988d1d4a098b87fc891d2949978990 (patch)
tree3e60f80cf7592a54b72b6a6b6056e04b4db7bd42
parent8dfb91e5aa0b45edc511c9a42c32c31085179d9d (diff)
downloadfreebsd-ports-972c8dc86b988d1d4a098b87fc891d2949978990.zip
editors/texworks: update to 0.6.7.
-rw-r--r--editors/texworks/Makefile21
-rw-r--r--editors/texworks/distinfo6
-rw-r--r--editors/texworks/files/patch-modules_QtPDF_src_PDFBackend.cpp10
3 files changed, 13 insertions, 24 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index af8406f271e3..947a4d4a6960 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -1,7 +1,6 @@
PORTNAME= texworks
DISTVERSIONPREFIX= release-
-DISTVERSION= 0.6.2
-PORTREVISION= 47
+DISTVERSION= 0.6.7
CATEGORIES= editors
MAINTAINER= hrs@FreeBSD.org
@@ -16,14 +15,14 @@ LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5
-USES= compiler:c++11-lang cmake desktop-file-utils pkgconfig \
+USES= compiler:c++11-lang cmake desktop-file-utils gl pkgconfig \
qt:5 tex
USE_GITHUB= yes
GH_ACCOUNT= TeXworks
USE_QT= buildtools:build designer:build qmake:build \
- core concurrent dbus gui linguisttools script \
- scripttools uitools widgets xml
-
+ core concurrent dbus declarative gui linguisttools \
+ network script scripttools testlib uitools widgets xml
+USE_GL= gl
USE_TEX= synctex
USE_LDCONFIG= yes
@@ -35,9 +34,12 @@ CMAKE_ARGS= -DTeXworks_DIC_DIR:PATH=${LOCALBASE}/share/hunspell \
PORTDOCS= *
PLIST_FILES= bin/texworks \
man/man1/texworks.1.gz \
- share/appdata/texworks.appdata.xml \
share/applications/texworks.desktop \
- share/pixmaps/TeXworks.png
+ share/icons/hicolor/128x128/apps/TeXworks.png \
+ share/icons/hicolor/48x48/apps/TeXworks.png \
+ share/icons/hicolor/512x512/apps/TeXworks.png \
+ share/icons/hicolor/64x64/apps/TeXworks.png \
+ share/metainfo/texworks.appdata.xml
OPTIONS_DEFINE= DOCS LUA PYTHON
@@ -49,7 +51,4 @@ PYTHON_USES= python:3.4+
PYTHON_CMAKE_BOOL= WITH_PYTHON
PYTHON_PLIST_FILES= lib/texworks/libTWPythonPlugin.so
-post-patch:
- @${FIND} ${WRKSRC}/src -type f | ${XARGS} ${REINPLACE_CMD} 's|synctex_next_result|synctex_scanner_next_result|g'
-
.include <bsd.port.mk>
diff --git a/editors/texworks/distinfo b/editors/texworks/distinfo
index 61bf36964673..acb2045064ac 100644
--- a/editors/texworks/distinfo
+++ b/editors/texworks/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536894823
-SHA256 (TeXworks-texworks-release-0.6.2_GH0.tar.gz) = 22885c11d92654b0cba1f4808fc9aa3c2fdd3e5435fd89dff9aa1e67658a6339
-SIZE (TeXworks-texworks-release-0.6.2_GH0.tar.gz) = 11508277
+TIMESTAMP = 1672607138
+SHA256 (TeXworks-texworks-release-0.6.7_GH0.tar.gz) = dd55fc6aee5a4c93c4f2c304c234943428e3710aca7b180143f5be747e4f06cd
+SIZE (TeXworks-texworks-release-0.6.7_GH0.tar.gz) = 12394465
diff --git a/editors/texworks/files/patch-modules_QtPDF_src_PDFBackend.cpp b/editors/texworks/files/patch-modules_QtPDF_src_PDFBackend.cpp
deleted file mode 100644
index 634a4663bc38..000000000000
--- a/editors/texworks/files/patch-modules_QtPDF_src_PDFBackend.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- modules/QtPDF/src/PDFBackend.cpp.orig 2020-05-18 16:06:39 UTC
-+++ modules/QtPDF/src/PDFBackend.cpp
-@@ -14,6 +14,7 @@
-
- #include <PDFBackend.h>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QApplication>
-
- namespace QtPDF {