summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-28 01:32:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-28 01:32:40 +0000
commit96b447c1cf0a4f4854f745cfb2861f5725ed6e39 (patch)
tree269cb19b7e91b968453a75f66b90232089aeede0
parentac1cee1eddd316b1e18f8d2c24755600606133d8 (diff)
downloadfreebsd-ports-96b447c1cf0a4f4854f745cfb2861f5725ed6e39.zip
- Update to 0.8.6
Feature safe: yes
-rw-r--r--graphics/gnash/Makefile44
-rw-r--r--graphics/gnash/distinfo6
-rw-r--r--graphics/gnash/pkg-plist256
3 files changed, 282 insertions, 24 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 33499f68a1b0..d22647022619 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 0.8.5
-PORTREVISION= 3
+PORTVERSION= 0.8.6
CATEGORIES= graphics
# getgnash.org is slow
MASTER_SITES= ${MASTER_SITE_GNU} \
@@ -40,16 +39,19 @@ MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-boost-lib="${LOCALBASE}/lib" \
--disable-testsuite \
- --with-plugins-install=system
+ --with-plugins-install=system \
+ --sysconfdir="${WRKDIR}/etc" \
+ --disable-jemalloc # leads to infinite recursion on FreeBSD
GNASHVER= ${PORTVERSION}
+CONFIG_FILES= gnashpluginrc gnashrc
WRKSRC= ${WRKDIR}/${PORTNAME}-${GNASHVER}
PLIST_SUB+= GNASHVER="${GNASHVER}"
USE_LDCONFIG= ${PREFIX}/lib/gnash
-MAN1= cygnal.1 dumpshm.1 flvdumper.1 gnash.1 gprocessor.1 soldumper.1
+MAN1= cygnal.1 dumpshm.1 flvdumper.1 gnash.1 gprocessor.1 soldumper.1 rtmpget.1
OPTIONS= PLUGIN "Enable browser plugin" on \
CYGNAL "Enable Cygnal media server" off \
@@ -69,6 +71,7 @@ OPTIONS= PLUGIN "Enable browser plugin" on \
.if defined(WITH_CYGNAL)
PLIST_SUB+= CYGNAL=""
CONFIGURE_ARGS+= --enable-cygnal
+CONFIG_FILES+= cygnalrc
.else
PLIST_SUB+= CYGNAL="@comment "
CONFIGURE_ARGS+= --disable-cygnal
@@ -200,6 +203,12 @@ CONFIGURE_ARGS+= --enable-media=none
IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer)
.endif
+.if defined(WITH_GSTREAMER)
+PLIST_SUB+= GSTREAMER=""
+.else
+PLIST_SUB+= GSTREAMER="@comment "
+.endif
+
#
# Other options
#
@@ -212,11 +221,11 @@ CONFIGURE_ARGS+= --disable-speex
.include <bsd.port.pre.mk>
-pre-everything::
-.if defined(WITH_OPENGL)
- @${ECHO_CMD} "OpenGL support is currently broken (Gnash hangs using 100% CPU). Use at your own risk"
- @sleep 3
-.endif
+#pre-everything::
+#.if defined(WITH_OPENGL)
+# @${ECHO_CMD} "OpenGL support is currently broken (Gnash hangs using 100% CPU). Use at your own risk"
+# @sleep 3
+#.endif
post-patch:
@${REINPLACE_CMD} -e '/^PTHREAD_[LC][IF]*=/ d; s|-lpthread|${PTHREAD_LIBS}|' \
@@ -225,20 +234,19 @@ post-patch:
s|/lib64|/lib|g; \
s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure \
${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
- @${REINPLACE_CMD} -e '/sysconfDATA_INSTALL/ s|/$$$$f|&.dist|' \
- ${WRKSRC}/libbase/Makefile.in
@${REINPLACE_CMD} -e '/KDE4_APPSDATADIR=/ s|share/kde4|share|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|libdir)|exec_prefix)/libdata|' \
+ ${WRKSRC}/Makefile.in
post-install:
- if [ ! -f ${PREFIX}/etc/gnashrc ]; then \
- ${INSTALL_DATA} ${PREFIX}/etc/gnashrc.dist \
- ${PREFIX}/etc/gnashrc; \
- fi
- if [ ! -f ${PREFIX}/etc/gnashpluginrc ]; then \
- ${INSTALL_DATA} ${PREFIX}/etc/gnashpluginrc.dist \
- ${PREFIX}/etc/gnashpluginrc; \
+.for conf in ${CONFIG_FILES}
+ @${INSTALL_DATA} ${WRKDIR}/etc/${conf} ${PREFIX}/etc/${conf}.dist
+ if [ ! -f ${PREFIX}/etc/${conf} ]; then \
+ ${INSTALL_DATA} ${PREFIX}/etc/${conf}.dist \
+ ${PREFIX}/etc/${conf}; \
fi
+.endfor
.if !defined(WITHOUT_PLUGIN)
.if !defined(WITHOUT_GTK)
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index ea31033a2ca3..2063168c9fa8 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.8.5.tar.bz2) = 366f703c2eb1747e4109602b75439ff4
-SHA256 (gnash-0.8.5.tar.bz2) = 16f272214eed2ab50bcd9507d6299b82ed7d20e7e8eb253ab160e594eeb210b3
-SIZE (gnash-0.8.5.tar.bz2) = 3335797
+MD5 (gnash-0.8.6.tar.bz2) = 913bcbffd37c9603b84486227c65dce7
+SHA256 (gnash-0.8.6.tar.bz2) = 05f4b75eb2a5bc543fcd743641825147ce5e1b0bf675896e01401556a85332ea
+SIZE (gnash-0.8.6.tar.bz2) = 3571055
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index ffd045a8b1a1..f0e497245f35 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -1,4 +1,6 @@
bin/dumpshm
+%%GSTREAMER%%bin/findmicrophones
+%%GSTREAMER%%bin/findwebcams
bin/flvdumper
bin/gnash
bin/gprocessor
@@ -9,10 +11,249 @@ bin/soldumper
%%CYGNAL%%bin/cygnal
%%NPAPI%%%%WEBPLUGINS_DIR%%/libgnashplugin.so
@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
-%%KDE%%share/apps/klash/pluginsinfo
+%%KPARTS%%share/apps/klash/pluginsinfo
%%KPARTS%%share/apps/klash/klashpartui.rc
@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
-%%KDE%%share/services/klash_part.desktop
+%%KPARTS%%share/services/klash_part.desktop
+include/gnash/AVM1Movie_as.h
+include/gnash/AccessibilityProperties_as.h
+include/gnash/Accessibility_as.h
+include/gnash/ActionScriptVersion_as.h
+include/gnash/ActivityEvent_as.h
+include/gnash/AntiAliasType_as.h
+include/gnash/ApplicationDomain_as.h
+include/gnash/Array_as.h
+include/gnash/AsyncErrorEvent_as.h
+include/gnash/BevelFilter_as.h
+include/gnash/BitmapDataChannel_as.h
+include/gnash/BitmapFilterQuality_as.h
+include/gnash/BitmapFilterType_as.h
+include/gnash/BitmapFilter_as.h
+include/gnash/BitmapInfo.h
+include/gnash/Bitmap_as.h
+include/gnash/BlendMode_as.h
+include/gnash/BlurFilter_as.h
+include/gnash/ByteArray_as.h
+include/gnash/CSMSettings_as.h
+include/gnash/CallStack.h
+include/gnash/Camera_as.h
+include/gnash/Capabilities_as.h
+include/gnash/CapsStyle_as.h
+include/gnash/CharacterProxy.h
+include/gnash/ClipboardFormats_as.h
+include/gnash/ClipboardTransferMode_as.h
+include/gnash/Clipboard_as.h
+include/gnash/ColorMatrixFilter_as.h
+include/gnash/ColorTransform_as.h
+include/gnash/ContextMenuBuiltInItems_as.h
+include/gnash/ContextMenuEvent_as.h
+include/gnash/ContextMenuItem_as.h
+include/gnash/ContextMenu_as.h
+include/gnash/ControlTag.h
+include/gnash/ConvolutionFilter_as.h
+include/gnash/DataEvent_as.h
+include/gnash/DefinitionTag.h
+include/gnash/DeleteObjectSample_as.h
+include/gnash/Dictionary_as.h
+include/gnash/DisplacementMapFilterMode_as.h
+include/gnash/DisplacementMapFilter_as.h
+include/gnash/DisplayList.h
+include/gnash/DisplayObject.h
+include/gnash/DisplayObjectContainer.h
+include/gnash/DisplayObjectContainer_as.h
+include/gnash/DisplayObject_as.h
+include/gnash/DropShadowFilter_as.h
+include/gnash/DynamicShape.h
+include/gnash/EOFError_as.h
+include/gnash/Endian_as.h
+include/gnash/ErrorEvent_as.h
+include/gnash/EventDispatcher_as.h
+include/gnash/EventPhase_as.h
+include/gnash/Event_as.h
+include/gnash/ExportableResource.h
+include/gnash/ExternalInterface_as.h
+include/gnash/FileFilter_as.h
+include/gnash/FocusEvent_as.h
+include/gnash/FontStyle_as.h
+include/gnash/FontType_as.h
+include/gnash/Font_as.h
+include/gnash/FrameLabel_as.h
+include/gnash/FullScreenEvent_as.h
+include/gnash/GC.h
+include/gnash/Geometry.h
+include/gnash/GlowFilter_as.h
+include/gnash/GnashException.h
+include/gnash/GnashImage.h
+include/gnash/GnashImageJpeg.h
+include/gnash/GnashKey.h
+include/gnash/GradientBevelFilter_as.h
+include/gnash/GradientGlowFilter_as.h
+include/gnash/GradientType_as.h
+include/gnash/Graphics_as.h
+include/gnash/GridFitType_as.h
+include/gnash/HTTPStatusEvent_as.h
+include/gnash/IBitmapDrawable_as.h
+include/gnash/ID3Info_as.h
+include/gnash/IDataInput_as.h
+include/gnash/IDataOutput_as.h
+include/gnash/IDynamicPropertyOutput_as.h
+include/gnash/IDynamicPropertyWriter_as.h
+include/gnash/IEventDispatcher_as.h
+include/gnash/IExternalizable_as.h
+include/gnash/IMEConversionMode_as.h
+include/gnash/IMEEvent_as.h
+include/gnash/IME_as.h
+include/gnash/IOErrorEvent_as.h
+include/gnash/IOError_as.h
+include/gnash/IllegalOperationError_as.h
+include/gnash/InteractiveObject.h
+include/gnash/InteractiveObject_as.h
+include/gnash/InterpolationMethod_as.h
+include/gnash/InvalidSWFError_as.h
+include/gnash/JointStyle_as.h
+include/gnash/KeyLocation_as.h
+include/gnash/KeyboardEvent_as.h
+include/gnash/Keyboard_as.h
+include/gnash/LineScaleMode_as.h
+include/gnash/LoaderContext_as.h
+include/gnash/LoaderInfo_as.h
+include/gnash/Loader_as.h
+include/gnash/LocalConnection_as.h
+include/gnash/Machine.h
+include/gnash/Matrix_as.h
+include/gnash/MemoryError_as.h
+include/gnash/Microphone_as.h
+include/gnash/MorphShape_as.h
+include/gnash/MouseButtonState.h
+include/gnash/MouseEvent_as.h
+include/gnash/Mouse_as.h
+include/gnash/Movie.h
+include/gnash/MovieClip.h
+include/gnash/MovieClip_as.h
+include/gnash/MovieFactory.h
+include/gnash/NamingPolicy.h
+include/gnash/NativeFunction.h
+include/gnash/NetConnection_as.h
+include/gnash/NetStatusEvent_as.h
+include/gnash/NetStream_as.h
+include/gnash/NetworkAdapter.h
+include/gnash/NewObjectSample_as.h
+include/gnash/ObjectEncoding_as.h
+include/gnash/PixelSnapping_as.h
+include/gnash/Point2d.h
+include/gnash/Point_as.h
+include/gnash/PrintJobOptions_as.h
+include/gnash/PrintJobOrientation_as.h
+include/gnash/PrintJob_as.h
+include/gnash/ProgressEvent_as.h
+include/gnash/PropFlags.h
+include/gnash/Property.h
+include/gnash/PropertyList.h
+include/gnash/Proxy_as.h
+include/gnash/RGBA.h
+include/gnash/Range2d.h
+include/gnash/Rectangle_as.h
+include/gnash/Responder_as.h
+include/gnash/RunResources.h
+include/gnash/SWF.h
+include/gnash/SWFMatrix.h
+include/gnash/SWFVersion_as.h
+include/gnash/SafeStack.h
+include/gnash/Sample_as.h
+include/gnash/Scene_as.h
+include/gnash/ScriptTimeoutError_as.h
+include/gnash/SecurityDomain_as.h
+include/gnash/SecurityErrorEvent_as.h
+include/gnash/SecurityPanel_as.h
+include/gnash/Security_as.h
+include/gnash/ShapeRecord.h
+include/gnash/Shape_as.h
+include/gnash/SharedObjectFlushStatus_as.h
+include/gnash/SharedObject_as.h
+include/gnash/SimpleButton_as.h
+include/gnash/Socket_as.h
+include/gnash/SoundChannel_as.h
+include/gnash/SoundLoaderContext_as.h
+include/gnash/SoundMixer_as.h
+include/gnash/SoundTransform_as.h
+include/gnash/Sound_as.h
+include/gnash/SpreadMethod_as.h
+include/gnash/Sprite_as.h
+include/gnash/StackFrame_as.h
+include/gnash/StackOverflowError_as.h
+include/gnash/StageAlign_as.h
+include/gnash/StageDisplayState_as.h
+include/gnash/StageQuality_as.h
+include/gnash/StageScaleMode_as.h
+include/gnash/Stage_as.h
+include/gnash/StaticText_as.h
+include/gnash/StatusEvent_as.h
+include/gnash/StreamProvider.h
+include/gnash/StringPredicates.h
+include/gnash/StyleSheet_as.h
+include/gnash/SyncEvent_as.h
+include/gnash/System_as.h
+include/gnash/TagLoadersTable.h
+include/gnash/TextColorType_as.h
+include/gnash/TextDisplayMode_as.h
+include/gnash/TextEvent_as.h
+include/gnash/TextFieldAutoSize_as.h
+include/gnash/TextFieldType_as.h
+include/gnash/TextField_as.h
+include/gnash/TextFormatAlign_as.h
+include/gnash/TextFormat_as.h
+include/gnash/TextLineMetrics_as.h
+include/gnash/TextSnapshot_as.h
+include/gnash/TimerEvent_as.h
+include/gnash/Timer_as.h
+include/gnash/Transform_as.h
+include/gnash/URL.h
+include/gnash/URLLoaderDataFormat_as.h
+include/gnash/URLLoader_as.h
+include/gnash/URLRequestHeader_as.h
+include/gnash/URLRequestMethod_as.h
+include/gnash/URLRequest_as.h
+include/gnash/URLStream_as.h
+include/gnash/URLVariables_as.h
+include/gnash/VM.h
+include/gnash/Video.h
+include/gnash/Video_as.h
+include/gnash/XMLDocument_as.h
+include/gnash/XMLNode_as.h
+include/gnash/XMLSocket_as.h
+include/gnash/asClass.h
+include/gnash/asNamespace.h
+include/gnash/as_environment.h
+include/gnash/as_function.h
+include/gnash/as_object.h
+include/gnash/as_value.h
+include/gnash/builtin_function.h
+include/gnash/cxform.h
+include/gnash/display_pkg.h
+include/gnash/drag_state.h
+include/gnash/dsodefs.h
+include/gnash/event_id.h
+include/gnash/external_pkg.h
+include/gnash/fill_style.h
+include/gnash/filters_pkg.h
+include/gnash/fn_call.h
+include/gnash/geom_pkg.h
+include/gnash/gettext.h
+include/gnash/gnash.h
+include/gnash/log.h
+include/gnash/movie_definition.h
+include/gnash/movie_root.h
+include/gnash/namedStrings.h
+include/gnash/net_pkg.h
+include/gnash/rc.h
+include/gnash/rect.h
+include/gnash/ref_counted.h
+include/gnash/smart_ptr.h
+include/gnash/snappingrange.h
+include/gnash/string_table.h
+include/gnash/styles.h
+include/gnash/text_pkg.h
+include/gnash/utility.h
%%KPARTS%%lib/kde3/libklashpart.so
%%KPARTS%%lib/kde3/libklashpart.la
%%KPARTS4%%kde4/share/apps/klash/pluginsinfo
@@ -20,12 +261,17 @@ bin/soldumper
%%KPARTS4%%kde4/share/kde4/services/klash_part.desktop
%%KPARTS4%%kde4/lib/kde4/libklashpart.so
%%KPARTS4%%kde4/lib/kde4/libklashpart.la
+%%CYGNAL%%@unexec if cmp -s %D/etc/cygnalrc.dist %D/etc/cygnalrc; then rm -f %D/etc/cygnalrc; fi
+%%CYGNAL%%etc/cygnalrc.dist
+%%CYGNAL%%@exec if [ ! -f %B/cygnalrc ]; then cp -p %D/%F %B/cygnalrc; fi
@unexec if cmp -s %D/etc/gnashpluginrc.dist %D/etc/gnashpluginrc; then rm -f %D/etc/gnashpluginrc; fi
etc/gnashpluginrc.dist
@exec if [ ! -f %B/gnashpluginrc ]; then cp -p %D/%F %B/gnashpluginrc; fi
@unexec if cmp -s %D/etc/gnashrc.dist %D/etc/gnashrc; then rm -f %D/etc/gnashrc; fi
etc/gnashrc.dist
@exec if [ ! -f %B/gnashrc ]; then cp -p %D/%F %B/gnashrc; fi
+%%CYGNAL%%lib/cygnal/plugins/echo.so
+%%CYGNAL%%lib/cygnal/plugins/oflaDemo.so
lib/gnash/libgnashamf-%%GNASHVER%%.so
lib/gnash/libgnashamf.la
lib/gnash/libgnashamf.so
@@ -47,6 +293,7 @@ lib/gnash/libgnashsound.so
%%NPAPI%%lib/gnash/libmozsdk.la
%%NPAPI%%lib/gnash/libmozsdk.so
%%NPAPI%%lib/gnash/libmozsdk.so.0
+libdata/pkgconfig/gnash.pc
%%DOCSDIR%%/gnashuser.html
%%DOCSDIR%%/images/car_crash.png
%%DOCSDIR%%/images/rtmp.png
@@ -64,7 +311,10 @@ share/locale/ja/LC_MESSAGES/gnash.mo
@dirrm %%DOCSDIR%%/images
@dirrm %%DOCSDIR%%
@dirrm lib/gnash
+%%CYGNAL%%@dirrm lib/cygnal/plugins
+%%CYGNAL%%@dirrm lib/cygnal
+@dirrm include/gnash
@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
-%%KDE%%@dirrm share/apps/klash
+%%KPARTS%%@dirrm share/apps/klash
%%KPARTS4%%@dirrm kde4/share/apps/klash
%%NPAPI%%@dirrmtry %%WEBPLUGINS_DIR%%