summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-02-13 23:16:53 +0100
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-02-13 23:16:53 +0100
commit8bb7615cb8505d854178f8f9090ccfe984085462 (patch)
tree3e5706091021f67ab31d95fc7b36ba7f5b4b7b71
parent40efec60a98d3360c1b6045adce159e3c53ebcca (diff)
downloadfreebsd-ports-8bb7615cb8505d854178f8f9090ccfe984085462.zip
security/lasso: Fix build with new xmlsec1
The newest update to xmlsec1 broke this port as it used a deprecated functin of xmlsec1. PR: 277033 Reported by: dweimer@dweimer.net
-rw-r--r--security/lasso/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 39623543b04f..3f05991bcd70 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -43,5 +43,8 @@ CFLAGS+= -Wno-error=int-conversion
post-patch:
@${REINPLACE_CMD} -E 's,(xmlsec1-openssl >= 1\.2\.6) openssl,\1,' \
${CONFIGURE_WRKSRC}/configure
+# Fix build with new xmlsec1 as this function was deprecated
+ @${REINPLACE_CMD} -e 's|BAD_CAST XMLSEC_CRYPTO|BAD_CAST xmlSecGetDefaultCrypto()|g' \
+ ${WRKSRC}/lasso/lasso.c
.include <bsd.port.mk>