summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-08-09 11:51:58 -0500
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-08-09 11:54:22 -0500
commit8a423b70831006666bab5f760c046c2c3b6058fc (patch)
treeed4e3fe7c6c72909b75924063269b1f0a2d51a65
parent7ba28e1bce89414ef4cb2a28b7e84354692ddb38 (diff)
downloadfreebsd-ports-8a423b70831006666bab5f760c046c2c3b6058fc.zip
deskutils/myitcrm: Mark DEPRECATED
- Upstream abandoned project. Last update was on 2012-02-15 - Set EXPIRATION_DATE to 2022-09-30 - Domain is parked - Pet portclippy/portfmt - Use OPTIONSNG - Mark NO_ARCH
-rw-r--r--deskutils/myitcrm/Makefile46
1 files changed, 27 insertions, 19 deletions
diff --git a/deskutils/myitcrm/Makefile b/deskutils/myitcrm/Makefile
index ce4aaba97e37..8afd6fd0574c 100644
--- a/deskutils/myitcrm/Makefile
+++ b/deskutils/myitcrm/Makefile
@@ -10,34 +10,39 @@ COMMENT= CRM project designed for Computer Servicing and Repairs
LICENSE= GPLv3
+DEPRECATED= Abandoned project as last update was on 2012-01-15
+EXPIRATION_DATE= 2022-09-30
+
USES= dos2unix zip
USE_PHP= mysqli session xml
+
+PATCH_STRIP= -p1
+NO_ARCH= yes
NO_BUILD= yes
+SUB_FILES= pkg-message
+
WRKSRC= ${WRKDIR}/MyITCRM-${PORTVERSION}
-PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
-SUB_FILES= pkg-message
-PATCH_STRIP= -p1
-WRITEABLE= conf.php.sample log/access.log cache
+PLIST_SUB= WWWGRP="${WWWGRP}" \
+ WWWOWN="${WWWOWN}"
+PORTDOCS= README.textile changelog.txt
PORTEXAMPLES= htaccess.txt
-PORTDOCS= changelog.txt README.textile
-OPTIONS_DEFINE= APACHE PHPMOD LIGHTTPD NGINX DOCS EXAMPLES
+OPTIONS_DEFINE= APACHE DOCS EXAMPLES LIGHTTPD NGINX PHPMOD
OPTIONS_DEFAULT= APACHE
-PHPMOD_DESC= Use PHP module for Apache
+
NGINX_DESC= Use Nginx
+PHPMOD_DESC= Use PHP module for Apache
APACHE_USES= apache:run,2.2+
LIGHTTPD_RUN_DEPENDS= lighttpd:www/lighttpd
NGINX_RUN_DEPENDS= nginx:www/nginx
+PHPMOD_USES= php:mod
+PHPMOD_USES_OFF= php:cgi
-.include <bsd.port.options.mk>
+WRITEABLE= conf.php.sample log/access.log cache
-.if ${PORT_OPTIONS:MPHPMOD}
-USES+= php:mod
-.else
-USES+= php:cgi
-.endif
+.include <bsd.port.options.mk>
# Set files to ignore.
.for file in ${PORTEXAMPLES} ${PORTDOCS} LICENSE.txt
@@ -62,17 +67,20 @@ do-install:
.for ent in ${WRITEABLE}
@${CHMOD} u+w ${STAGEDIR}${WWWDIR}/${ent}
.endfor
+.if defined(MAINTAINER_MODE)
+ @${MAKE} -C ${.CURDIR} rm-install
+.endif
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for ex in ${PORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/${ex} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${ex} ${STAGEDIR}${EXAMPLESDIR}
.endfor
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
-.if defined(MAINTAINER_MODE)
- @${MAKE} -C ${.CURDIR} rm-install
-.endif
-
.include <bsd.port.mk>