summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-09-09 23:43:44 -0700
committerYuri Victorovich <yuri@FreeBSD.org>2023-09-10 11:10:45 -0700
commit898b267b94ea782c7c3c20f22af0459e4810e514 (patch)
tree3f7f87fa297c42573a5155633610bd32895149ec
parent8df26e0451357671aa0ecf9ca789d109cc972551 (diff)
downloadfreebsd-ports-898b267b94ea782c7c3c20f22af0459e4810e514.zip
devel/opendht: update 2.5.1 → 2.6.0
Reported by: portscout
-rw-r--r--devel/opendht/Makefile3
-rw-r--r--devel/opendht/distinfo6
-rw-r--r--devel/opendht/files/patch-CMakeLists.txt29
-rw-r--r--devel/opendht/pkg-plist2
4 files changed, 15 insertions, 25 deletions
diff --git a/devel/opendht/Makefile b/devel/opendht/Makefile
index 81cc267de27a..7f99049a59a7 100644
--- a/devel/opendht/Makefile
+++ b/devel/opendht/Makefile
@@ -1,7 +1,6 @@
PORTNAME= opendht
DISTVERSIONPREFIX= v
-DISTVERSION= 2.5.1
-PORTREVISION= 1
+DISTVERSION= 2.6.0
CATEGORIES= devel net
MAINTAINER= yuri@FreeBSD.org
diff --git a/devel/opendht/distinfo b/devel/opendht/distinfo
index ed77b3526a86..32cd9ac08090 100644
--- a/devel/opendht/distinfo
+++ b/devel/opendht/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680928160
-SHA256 (savoirfairelinux-opendht-v2.5.1_GH0.tar.gz) = 519245ad7ceff35f9e45035301b34f8ccafad16c605149b034cc10fd92adb32c
-SIZE (savoirfairelinux-opendht-v2.5.1_GH0.tar.gz) = 480528
+TIMESTAMP = 1694326478
+SHA256 (savoirfairelinux-opendht-v2.6.0_GH0.tar.gz) = 25d67e766e439cc04fd73091f8cd6d3c0fc8bf047427cdc9e8f469b9084add45
+SIZE (savoirfairelinux-opendht-v2.6.0_GH0.tar.gz) = 482044
diff --git a/devel/opendht/files/patch-CMakeLists.txt b/devel/opendht/files/patch-CMakeLists.txt
index 0ebb4df3c0df..a72c690b955e 100644
--- a/devel/opendht/files/patch-CMakeLists.txt
+++ b/devel/opendht/files/patch-CMakeLists.txt
@@ -1,15 +1,6 @@
---- CMakeLists.txt.orig 2023-04-08 04:39:13 UTC
+--- CMakeLists.txt.orig 2023-09-10 06:15:32 UTC
+++ CMakeLists.txt
-@@ -61,7 +61,7 @@ if (NOT MSVC)
- pkg_search_module (Nettle REQUIRED IMPORTED_TARGET nettle)
- check_include_file_cxx(msgpack.hpp HAVE_MSGPACKCXX)
- if (NOT HAVE_MSGPACKCXX)
-- find_package (msgpack REQUIRED CONFIG)
-+ find_package (msgpack-cxx REQUIRED CONFIG)
- endif()
- if (OPENDHT_TOOLS)
- find_package (Readline 6 REQUIRED)
-@@ -94,8 +94,8 @@ if (NOT MSVC)
+@@ -99,8 +99,8 @@ if (NOT MSVC)
endif()
if (OPENDHT_PROXY_OPENSSL)
# https://cmake.org/cmake/help/latest/module/FindOpenSSL.html
@@ -20,12 +11,12 @@
message(STATUS "Found OpenSSL ${OPENSSL_VERSION} ${OPENSSL_INCLUDE_DIRS}")
set(openssl_lib ", openssl")
else ()
-@@ -359,7 +359,7 @@ if (Jsoncpp_FOUND)
- target_link_libraries(opendht PUBLIC PkgConfig::Jsoncpp)
- endif()
- if (OPENDHT_PROXY_OPENSSL)
-- target_link_libraries(opendht PUBLIC PkgConfig::OPENSSL)
-+ target_link_libraries(opendht PRIVATE ssl)
+@@ -370,7 +370,7 @@ else()
+ target_link_libraries(opendht PUBLIC PkgConfig::Jsoncpp)
+ endif()
+ if (OPENDHT_PROXY_OPENSSL)
+- target_link_libraries(opendht PUBLIC PkgConfig::OPENSSL)
++ target_link_libraries(opendht PRIVATE ssl)
+ endif()
endif()
- if (APPLE)
- target_link_libraries(opendht PRIVATE SYSTEM "-framework CoreFoundation" "-framework Security")
+
diff --git a/devel/opendht/pkg-plist b/devel/opendht/pkg-plist
index 390089fa30f9..a5b80a31d9b8 100644
--- a/devel/opendht/pkg-plist
+++ b/devel/opendht/pkg-plist
@@ -15,7 +15,7 @@ include/opendht/http.h
include/opendht/indexation/pht.h
include/opendht/infohash.h
include/opendht/log.h
-include/opendht/log_enable.h
+include/opendht/logger.h
include/opendht/network_engine.h
include/opendht/network_utils.h
include/opendht/node.h