summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Kondratyev <wulf@FreeBSD.org>2019-08-18 22:05:37 +0000
committerVladimir Kondratyev <wulf@FreeBSD.org>2019-08-18 22:05:37 +0000
commit88e1d21229393ef691f205a54bd5a512bbf3e1c6 (patch)
tree0a7ac3ee12e45129265ac1bef6cd0d30fee1157a
parent3643f9c914f5f2c025f9b1da344a667d9f7c5a0a (diff)
downloadfreebsd-ports-88e1d21229393ef691f205a54bd5a512bbf3e1c6.zip
New port: comms/iwmbt-firmware
Firmware for the Intel Wireless 8260/8265 chip based Bluetooth USB devices. To be downloaded with iwmbtfw(8). WWW: https://packages.debian.org/firmware-iwlwifi WWW: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git PR: 237083 Reviewed by: koobs Approved by: koobs
-rw-r--r--comms/Makefile1
-rw-r--r--comms/iwmbt-firmware/Makefile32
-rw-r--r--comms/iwmbt-firmware/distinfo3
-rw-r--r--comms/iwmbt-firmware/pkg-descr5
-rw-r--r--comms/iwmbt-firmware/pkg-plist26
5 files changed, 67 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index b5b9695f161b..062b76b91e96 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -69,6 +69,7 @@
SUBDIR += hylafax
SUBDIR += ibp
SUBDIR += inspectrum
+ SUBDIR += iwmbt-firmware
SUBDIR += java-simple-serial-connector
SUBDIR += jerm
SUBDIR += kb
diff --git a/comms/iwmbt-firmware/Makefile b/comms/iwmbt-firmware/Makefile
new file mode 100644
index 000000000000..32fc88870083
--- /dev/null
+++ b/comms/iwmbt-firmware/Makefile
@@ -0,0 +1,32 @@
+# Created by: Vladimir Kondratyev <wulf@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= iwmbt-firmware
+PORTVERSION= 20190717
+CATEGORIES= comms
+MASTER_SITES= DEBIAN/pool/non-free/f/firmware-nonfree/
+DISTNAME= firmware-iwlwifi_${PORTVERSION}-1_all
+EXTRACT_SUFX= .deb
+
+MAINTAINER= wulf@FreeBSD.org
+COMMENT= Intel Wireless 8260 bluetooth adaptor firmwares used by iwmbtfw(8)
+
+LICENSE= INTEL
+LICENSE_NAME= Intel firmware license
+LICENSE_FILE= ${WRKDIR}/usr/share/doc/firmware-iwlwifi/copyright
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+EXTRACT_CMD= ${AR}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= data.tar.xz | ${TAR} -xf - ${EXTRACT_FILES}
+EXTRACT_FILES= lib/firmware/intel/ibt-*.sfi \
+ lib/firmware/intel/ibt-*.ddc \
+ usr/share/doc/firmware-iwlwifi/copyright
+
+do-install:
+ cd ${WRKDIR}/lib/firmware/intel && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/comms/iwmbt-firmware/distinfo b/comms/iwmbt-firmware/distinfo
new file mode 100644
index 000000000000..45a76c999b6a
--- /dev/null
+++ b/comms/iwmbt-firmware/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565821626
+SHA256 (firmware-iwlwifi_20190717-1_all.deb) = 7ce899a5b09d3bd7d95358b03974aeea41983b395ce2fcf437915fd700330ef7
+SIZE (firmware-iwlwifi_20190717-1_all.deb) = 6788512
diff --git a/comms/iwmbt-firmware/pkg-descr b/comms/iwmbt-firmware/pkg-descr
new file mode 100644
index 000000000000..473d98f0f78c
--- /dev/null
+++ b/comms/iwmbt-firmware/pkg-descr
@@ -0,0 +1,5 @@
+Firmware for the Intel Wireless 8260/8265 chip based Bluetooth USB devices.
+To be downloaded with iwmbtfw(8).
+
+WWW: https://packages.debian.org/firmware-iwlwifi
+WWW: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
diff --git a/comms/iwmbt-firmware/pkg-plist b/comms/iwmbt-firmware/pkg-plist
new file mode 100644
index 000000000000..360dd82def01
--- /dev/null
+++ b/comms/iwmbt-firmware/pkg-plist
@@ -0,0 +1,26 @@
+%%DATADIR%%/ibt-11-5.ddc
+%%DATADIR%%/ibt-11-5.sfi
+%%DATADIR%%/ibt-12-16.ddc
+%%DATADIR%%/ibt-12-16.sfi
+%%DATADIR%%/ibt-17-0-1.ddc
+%%DATADIR%%/ibt-17-0-1.sfi
+%%DATADIR%%/ibt-17-16-1.ddc
+%%DATADIR%%/ibt-17-16-1.sfi
+%%DATADIR%%/ibt-18-0-1.ddc
+%%DATADIR%%/ibt-18-0-1.sfi
+%%DATADIR%%/ibt-18-16-1.ddc
+%%DATADIR%%/ibt-18-16-1.sfi
+%%DATADIR%%/ibt-19-0-0.ddc
+%%DATADIR%%/ibt-19-0-0.sfi
+%%DATADIR%%/ibt-19-0-1.ddc
+%%DATADIR%%/ibt-19-0-1.sfi
+%%DATADIR%%/ibt-19-0-4.ddc
+%%DATADIR%%/ibt-19-0-4.sfi
+%%DATADIR%%/ibt-19-16-4.ddc
+%%DATADIR%%/ibt-19-16-4.sfi
+%%DATADIR%%/ibt-19-32-1.ddc
+%%DATADIR%%/ibt-19-32-1.sfi
+%%DATADIR%%/ibt-20-0-3.ddc
+%%DATADIR%%/ibt-20-0-3.sfi
+%%DATADIR%%/ibt-20-1-3.ddc
+%%DATADIR%%/ibt-20-1-3.sfi