summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-12-18 03:00:41 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-12-18 03:00:41 +0000
commit87715b9d73118bbabe1b57c8036a61f42cd6a35f (patch)
tree1edd52cac39d7d9b0dead2ee04828d9d082681cb
parentc296605f059b98dd5b658268e30ed3e8997f0e01 (diff)
downloadfreebsd-ports-87715b9d73118bbabe1b57c8036a61f42cd6a35f.zip
Mark broken on aarch64. It looks like this Makefile could use some
modernizing. Approved by: portmgr (tier-2 blanket)
-rw-r--r--multimedia/avidemux/Makefile.common8
1 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 4e329f8415d5..75b96752e55b 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -71,7 +71,7 @@ PLIST_SUB+= NLS="@comment " QT_NLS="@comment "
# for libexecinfo: (so that __builtin_frame_address() finds the top
# of the stack)
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CFLAGS+= -fno-omit-frame-pointer
#MAKE_ENV+= ARCH=x86_64
#CONFIGURE_ENV+= ARCH=x86_64
@@ -271,8 +271,10 @@ LDFLAGS+= -lc++
USE_GCC= yes
#.endif
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
+.if ${ARCH} == aarch64
+BROKEN= cmake/admDetermineSystem.cmake:78: CPU not supported
+.elif ${ARCH} == powerpc || ${ARCH} == sparc64
+BROKEN= Does not compile on powerpc or sparc64
.endif
post-patch: