summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-08-17 19:50:24 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-08-17 19:50:24 +0000
commit84b094c440655fc6ea5813c0fc7cef115500ffa2 (patch)
tree328962950dc180e6a3bbe0e27a545f5bc11f1455
parentb7e3ccbc280ebe03f4a60f67a997414d66efc1ca (diff)
downloadfreebsd-ports-84b094c440655fc6ea5813c0fc7cef115500ffa2.zip
databases/pldebugger does not build with PostgreSQL 11
plpgsql_debugger.c:367:10: error: use of undeclared identifier 'PLPGSQL_DTYPE_EXPR'; did you mean 'PLPGSQL_DTYPE_VAR'? case PLPGSQL_DTYPE_EXPR: ^~~~~~~~~~~~~~~~~~ PLPGSQL_DTYPE_VAR /usr/local/include/postgresql/server/plpgsql.h:62:2: note: 'PLPGSQL_DTYPE_VAR' declared here PLPGSQL_DTYPE_VAR, ^ plpgsql_debugger.c:367:10: error: duplicate case value 'PLPGSQL_DTYPE_VAR' case PLPGSQL_DTYPE_EXPR: ^ plpgsql_debugger.c:311:10: note: previous case defined here case PLPGSQL_DTYPE_VAR: ^ plpgsql_debugger.c:550:9: error: use of undeclared identifier 'PLPGSQL_DTYPE_EXPR'; did you mean 'PLPGSQL_DTYPE_VAR'? case PLPGSQL_DTYPE_EXPR: ^~~~~~~~~~~~~~~~~~ PLPGSQL_DTYPE_VAR /usr/local/include/postgresql/server/plpgsql.h:62:2: note: 'PLPGSQL_DTYPE_VAR' declared here PLPGSQL_DTYPE_VAR, ^ etc. http://package18.nyi.freebsd.org/data/120amd64-default-PR239514/2019-07-29_20h41m52s/logs/pldebugger-1.0_2,1.log PR: 239611
-rw-r--r--databases/pldebugger/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/pldebugger/Makefile b/databases/pldebugger/Makefile
index 50be03cabb15..80e9852a1dd7 100644
--- a/databases/pldebugger/Makefile
+++ b/databases/pldebugger/Makefile
@@ -13,7 +13,7 @@ COMMENT= PostgreSQL pl/pgsql Debugger API
LICENSE= ART20
-USES= gmake pgsql
+USES= gmake pgsql:10-
LLD_UNSAFE= yes
WANT_PGSQL= server