summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-12-19 11:12:32 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-12-19 11:12:32 +0000
commit7b5da0fa709e85dba305569418a07c035ea0bb58 (patch)
tree919c88e7ab61ba226d1b5e87f48aba31e570d59f
parente76d4ae958822e8d4a65c69272e9eb3913189eaf (diff)
downloadfreebsd-ports-7b5da0fa709e85dba305569418a07c035ea0bb58.zip
Change the way the pkgconfig-file install path is set for Qt5 ports.
As noticed in x11-toolkits/qt5-charts we never corrected the way in which qmake sets the pkgconfig path for Qt5-modules. Instead there was a sed-call on the generated Makefiles in bsd.qt.mk in the target qt-pre-install. This diff modifies devel/qmake5 to set QMAKE_PKGCONFIG_DESTDIR to ../libdata/pkgconfig from the default pkgconfig. As we split Qt-base into multiple ports, simply patching devel/qmake5 is not enough, as the other base-ports will use the file from inside the tarball. Therefore add it as an extrapatch for the Qt-base ports. As this affects the same file extrapatch-libtool in devel/qt5 touched, rename this one and add a hunk to do this change too. Note: qt4 ports are unaffected, as they never were converted to used the qt-preinstall target, and still contain the sed-call in their Makefiles. Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D8713
-rw-r--r--Mk/bsd.qt.mk14
-rw-r--r--devel/qt5/files/extrapatch-libtool10
-rw-r--r--devel/qt5/files/extrapatch-mkspecs_features_qt__module.prf26
3 files changed, 30 insertions, 20 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 8d09bf03df78..67e7769533fa 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -170,13 +170,14 @@ CONFIGURE_ARGS+=-verbose
. if ${QT_DIST} == "base" || ${_QT_VERSION:M4*}
. if ${_QT_VERSION:M4*}
-_EXTRA_PATCHES_QT4= ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-src-corelib-global-qglobal.h
+_EXTRA_PATCHES_QT4= ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-src-corelib-global-qglobal.h \
+ ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-libtool
. else
-_EXTRA_PATCHES_QT5= ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-src_corelib_global_qcompilerdetection.h
+_EXTRA_PATCHES_QT5= ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-src_corelib_global_qcompilerdetection.h \
+ ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_qt__module.prf
. endif
EXTRA_PATCHES?= ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-configure \
${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-config.tests-unix-compile.test \
- ${.CURDIR:H:H}/devel/${_QT_RELNAME}/files/extrapatch-libtool \
${_EXTRA_PATCHES_QT4} ${_EXTRA_PATCHES_QT5}
. endif
@@ -683,13 +684,6 @@ qt5-pre-configure:
# See QTBUG-40825 and ports bugs 194088, 195105 and 198720.
${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${CONFIGURE_WRKSRC}/lib' >> ${CONFIGURE_WRKSRC}/.qmake.cache
-pre-install: qt-pre-install
-qt-pre-install:
-# Search both in CONFIGURE_WRKSRC and WRKSRC, as the former is not
-# a subdirectory of the latter for out-of-source builds.
- @${FIND} ${WRKSRC} ${CONFIGURE_WRKSRC} -name "Makefile*" -type f | \
- ${XARGS} ${REINPLACE_CMD} -e 's,${PREFIX}/${QT_LIBDIR_REL}/pkgconfig,${PREFIX}/libdata/pkgconfig,g'
-
post-install: qt-post-install
qt-post-install:
. if ${QT_DEFINES:N-*}
diff --git a/devel/qt5/files/extrapatch-libtool b/devel/qt5/files/extrapatch-libtool
deleted file mode 100644
index 8a9328edd73b..000000000000
--- a/devel/qt5/files/extrapatch-libtool
+++ /dev/null
@@ -1,10 +0,0 @@
---- mkspecs/features/qt_module.prf.orig 2016-02-24 21:20:22.414067000 +0100
-+++ mkspecs/features/qt_module.prf 2016-02-24 21:20:35.884538000 +0100
-@@ -267,7 +267,6 @@
- QMAKE_PKGCONFIG_INSTALL_REPLACE += pclib_replace
- }
- !lib_bundle:unix {
-- CONFIG += create_libtool
- host_build: \
- QMAKE_LIBTOOL_LIBDIR = $$[QT_HOST_LIBS]
- else: \
diff --git a/devel/qt5/files/extrapatch-mkspecs_features_qt__module.prf b/devel/qt5/files/extrapatch-mkspecs_features_qt__module.prf
new file mode 100644
index 000000000000..25007cbeb401
--- /dev/null
+++ b/devel/qt5/files/extrapatch-mkspecs_features_qt__module.prf
@@ -0,0 +1,26 @@
+The first hunk fixes the install location of the pkconfig files:
+ FreeBSD installs pkgconfig files to $LOCALBASE/libdata/pkgconfig
+ qmake uses QMAKE_PKGCONFIG_DESTDIR as relative path to $$QT_LIBDIR
+ respectively as absolute path.
+
+The second hunk stops qmake from generating la files.
+
+--- mkspecs/features/qt_module.prf.orig 2016-09-16 05:49:42 UTC
++++ mkspecs/features/qt_module.prf
+@@ -247,7 +247,7 @@ load(qt_targets)
+ # this builds on top of qt_common
+ !internal_module:!lib_bundle:if(unix|mingw) {
+ CONFIG += create_pc
+- QMAKE_PKGCONFIG_DESTDIR = pkgconfig
++ QMAKE_PKGCONFIG_DESTDIR = ../libdata/pkgconfig
+ host_build: \
+ QMAKE_PKGCONFIG_LIBDIR = $$[QT_HOST_LIBS]
+ else: \
+@@ -267,7 +267,6 @@ load(qt_targets)
+ QMAKE_PKGCONFIG_INSTALL_REPLACE += pclib_replace
+ }
+ !lib_bundle:unix {
+- CONFIG += create_libtool
+ host_build: \
+ QMAKE_LIBTOOL_LIBDIR = $$[QT_HOST_LIBS]
+ else: \