summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-29 11:41:37 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-29 11:41:37 +0000
commit7acf83e9cc8fcbee2aaee6b4b3cddf8cdc42b5d1 (patch)
tree32f670ba2f83abae8202baaa5c5d5808c93856cc
parentbcc0be2d8132f59462f7fafbdafc120ffa84b932 (diff)
downloadfreebsd-ports-7acf83e9cc8fcbee2aaee6b4b3cddf8cdc42b5d1.zip
Converting port to new options framework
PR: ports/172433 Submitted by: Michael Gmelin <freebsd@grem.de> Feature safe: yes
-rw-r--r--textproc/xalan-c/Makefile96
-rw-r--r--textproc/xalan-c/pkg-plist204
-rw-r--r--textproc/xalan-c/scripts/check-config-options24
3 files changed, 136 insertions, 188 deletions
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index fcadeb66015b..0bdeff1abf78 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: xalan-c
-# Date created: 26 October 2002
-# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
-#
+# Created by: Bjoern A. Zeeb <bz@FreeBSD.org>
# $FreeBSD$
-#
-# ------------------------------------------------------------------------------
PORTNAME= xalan-c
PORTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML:S/$/:msax,docs/}
MASTER_SITE_SUBDIR= ${PORTNAME}/source/:msax ${PORTNAME}/docs/:docs
@@ -17,25 +13,23 @@ DISTFILES+= Xalan-C_${PORTVERSION:S/./_/g}-src${EXTRACT_SUFX}:msax
MAINTAINER= ports@FreeBSD.org
COMMENT= XSLT processor from the Apache XML Project
-OPTIONS= INMEM "Use inmem locale system." on \
- ICU "Use ICU locale system." off \
- NLS "Use nls locale system." off \
- TRANSCODER_ICU "Use ICU transcoder (if used in xerces-c2)." off \
- SAMPLES "Copy sample binaries and sources." on \
- PORTDOCS "Copy documentation." on \
- DEBUG "Include debugging information, do not strip." off
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES TRANSCODER_ICU
+OPTIONS_SINGLE= LSYS
+OPTIONS_SINGLE_LSYS= INMEMLOC ICULOC NLSLOC
+OPTIONS_DEFAULT= INMEMLOC
+INMEMLOC_DESC= Use inmem locale system
+ICULOC_DESC= Use ICU locale system
+NLSLOC_DESC= Use nls locale system
+TRANSCODER_ICU_DESC= Use ICU transcoder (if used in xerces-c2)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# move this further down though portlint might not like it but without
# this I will not be able to make use of make config in the future.
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
PKGNAMESUFFIX+= -debug
.endif
-.if defined(WITHOUT_PORTDOCS)
-NOPORTDOCS= yes
-.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
DISTFILES+= ${DOCS_TARBALL}:docs
EXTRACT_ONLY= Xalan-C_${PORTVERSION:S/./_/g}-src${EXTRACT_SUFX}
DOCS_TARBALL= Xalan-C_${PORTVERSION:S/./_/g}-docs${EXTRACT_SUFX}
@@ -64,38 +58,26 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -l ${PTHREAD_LIBS} \
-z ${EXTRA_CFLAGS} -I${LOCALBASE}/include -C --prefix=${PREFIX}
-.if defined(WITH_INMEM)
-LOCALSYS= inmem
-.endif
-.if defined(WITH_ICU)
-LOCALSYS= icu
-.endif
-.if defined(WITH_NLS)
-LOCALSYS= nls
+.if ${PORT_OPTIONS:MICULOC}
+CONFIGURE_ARGS+= -m icu
+PLIST_SUB+= LOCALSYS_INMEMLOC=""
+PLIST_SUB+= LOCALSYS_NLSLOC="@comment "
+PORT_OPTIONS+= TRANSCODER_ICU
.endif
-.if !defined(LOCALSYS)
-CONFIGURE_ARGS+= -m inmem
-PLIST_SUB+= LOCALSYS_INMEM=""
-PLIST_SUB+= LOCALSYS_NLS="@comment "
-.else
-.if (${LOCALSYS} == "icu")
-CONFIGURE_ARGS+= -m icu
-PLIST_SUB+= LOCALSYS_INMEM=""
-PLIST_SUB+= LOCALSYS_NLS="@comment "
-WITH_TRANSCODER_ICU= icu
-.elif (${LOCALSYS} == "nls")
+.if ${PORT_OPTIONS:MNLSLOC}
CONFIGURE_ARGS+= -m nls
-PLIST_SUB+= LOCALSYS_INMEM="@comment "
-PLIST_SUB+= LOCALSYS_NLS=""
-.else
-CONFIGURE_ARGS+= -m inmem
-PLIST_SUB+= LOCALSYS_INMEM=""
-PLIST_SUB+= LOCALSYS_NLS="@comment "
+PLIST_SUB+= LOCALSYS_INMEMLOC="@comment "
+PLIST_SUB+= LOCALSYS_NLSLOC=""
.endif
+
+.if ${PORT_OPTIONS:MINMEMLOC}
+CONFIGURE_ARGS+= -m inmem
+PLIST_SUB+= LOCALSYS_INMEMLOC=""
+PLIST_SUB+= LOCALSYS_NLSLOC="@comment "
.endif
-.if defined(WITH_TRANSCODER_ICU)
+.if ${PORT_OPTIONS:MTRANSCODER_ICU}
PKGNAMESUFFIX+= -icu
LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
ICUROOT?= ${LOCALBASE}
@@ -111,7 +93,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -liconv
PLIST_SUB+= ICUDEP="@comment "
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= -d
STRIP=
.endif
@@ -131,29 +113,19 @@ PLIST_SUB+= XALANC_LIB=${XALANC_LIB} \
XALANMSG_LIB=${XALANMSG_LIB} \
XALANC_LIB_VERSION=${XALANC_LIB_VERSION}
-.if !defined(WITHOUT_SAMPLES)
-PLIST_SUB+= NO_SAMPLES=""
+.if ${PORT_OPTIONS:MEXAMPLES}
ALL_TARGET?= all samples
SAMPLE_BINS= CompileStylesheet DocumentBuilder ExternalFunction \
ParsedSourceWrappers SerializeNodeSet SimpleTransform \
SimpleXPathAPI SimpleXPathCAPI StreamTransform \
TraceListen TransformToXercesDOM UseStylesheetParam \
XalanTransform XalanTransformerCallback ThreadSafe
-.else
-PLIST_SUB+= NO_SAMPLES="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
-SCRIPTS_ENV= WITH_INMEM="${WITH_INMEM}" \
- WITH_ICU="${WITH_ICU}" \
- WITH_NLS="${WITH_NLS}"
-
-pre-extract:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/check-config-options
-
post-patch:
${RM} -f ${WRKSRC}/src/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp.orig \
${WRKSRC}/src/xalanc/PlatformSupport/XalanArrayAllocator.hpp.orig \
@@ -166,10 +138,10 @@ post-patch:
${CHMOD} 755 ${WRKSRC}/runConfigure ${WRKSRC}/configure
post-install:
-.if !defined(WITH_DEBUG)
+.if !${PORT_OPTIONS:MDEBUG}
@${STRIP_CMD} ${PREFIX}/lib/${XALANC_LIB}
.endif
-.if !defined(WITHOUT_SAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
.for i in ${SAMPLE_BINS}
@${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin
.endfor
@@ -177,7 +149,7 @@ post-install:
.include "${.CURDIR}/Makefile.inc-sample-src"
.endif
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${DOCSDIR} && \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
@@ -189,4 +161,4 @@ post-install:
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/xalan-c/pkg-plist b/textproc/xalan-c/pkg-plist
index 7c640f9e33fb..e0a854c6d2da 100644
--- a/textproc/xalan-c/pkg-plist
+++ b/textproc/xalan-c/pkg-plist
@@ -476,15 +476,15 @@ include/xalanc/XercesParserLiaison/XercesWrapperTypes.hpp
@dirrm include/xalanc/XercesParserLiaison
@dirrm include/xalanc
bin/Xalan
-%%LOCALSYS_NLS%%lib/nls/msg/en_US/XalanMsg_en_US.cat
-%%LOCALSYS_NLS%%@dirrm lib/nls/msg/en_US
-%%LOCALSYS_NLS%%@dirrm lib/nls/msg
-%%LOCALSYS_NLS%%@dirrm lib/nls
-%%LOCALSYS_INMEM%%lib/%%XALANMSG_LIB%%
-%%LOCALSYS_INMEM%%@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so
-%%LOCALSYS_INMEM%%@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%
-%%LOCALSYS_INMEM%%@unexec if test -L %D/lib/libxalanMsg.so; then rm -f %D/lib/libxalanMsg.so; fi
-%%LOCALSYS_INMEM%%@unexec if test -L %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; then rm -f %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; fi
+%%LOCALSYS_NLSLOC%%lib/nls/msg/en_US/XalanMsg_en_US.cat
+%%LOCALSYS_NLSLOC%%@dirrm lib/nls/msg/en_US
+%%LOCALSYS_NLSLOC%%@dirrm lib/nls/msg
+%%LOCALSYS_NLSLOC%%@dirrm lib/nls
+%%LOCALSYS_INMEMLOC%%lib/%%XALANMSG_LIB%%
+%%LOCALSYS_INMEMLOC%%@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so
+%%LOCALSYS_INMEMLOC%%@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%
+%%LOCALSYS_INMEMLOC%%@unexec if test -L %D/lib/libxalanMsg.so; then rm -f %D/lib/libxalanMsg.so; fi
+%%LOCALSYS_INMEMLOC%%@unexec if test -L %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; then rm -f %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; fi
lib/%%XALANC_LIB%%
@exec ln -fs %%XALANC_LIB%% %D/lib/libxalan-c.so
@exec ln -fs %%XALANC_LIB%% %D/lib/libxalan-c.so.%%XALANC_LIB_VERSION%%
@@ -494,100 +494,100 @@ lib/%%XALANC_LIB%%
@comment
@comment SAMPLES
@comment
-%%NO_SAMPLES%%bin/CompileStylesheet
-%%NO_SAMPLES%%bin/DocumentBuilder
-%%NO_SAMPLES%%bin/ExternalFunction
-%%NO_SAMPLES%%bin/ParsedSourceWrappers
-%%NO_SAMPLES%%bin/SerializeNodeSet
-%%NO_SAMPLES%%bin/SimpleTransform
-%%NO_SAMPLES%%bin/SimpleXPathAPI
-%%NO_SAMPLES%%bin/SimpleXPathCAPI
-%%NO_SAMPLES%%bin/StreamTransform
-%%NO_SAMPLES%%bin/ThreadSafe
-%%NO_SAMPLES%%bin/TraceListen
-%%NO_SAMPLES%%bin/TransformToXercesDOM
-%%NO_SAMPLES%%bin/UseStylesheetParam
-%%NO_SAMPLES%%bin/XalanTransform
-%%NO_SAMPLES%%bin/XalanTransformerCallback
+%%PORTEXAMPLES%%bin/CompileStylesheet
+%%PORTEXAMPLES%%bin/DocumentBuilder
+%%PORTEXAMPLES%%bin/ExternalFunction
+%%PORTEXAMPLES%%bin/ParsedSourceWrappers
+%%PORTEXAMPLES%%bin/SerializeNodeSet
+%%PORTEXAMPLES%%bin/SimpleTransform
+%%PORTEXAMPLES%%bin/SimpleXPathAPI
+%%PORTEXAMPLES%%bin/SimpleXPathCAPI
+%%PORTEXAMPLES%%bin/StreamTransform
+%%PORTEXAMPLES%%bin/ThreadSafe
+%%PORTEXAMPLES%%bin/TraceListen
+%%PORTEXAMPLES%%bin/TransformToXercesDOM
+%%PORTEXAMPLES%%bin/UseStylesheetParam
+%%PORTEXAMPLES%%bin/XalanTransform
+%%PORTEXAMPLES%%bin/XalanTransformerCallback
@comment -----------------------------------------------------------------------
@comment
@comment SAMPLE SRC
@comment
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/foo.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/XalanTransformerCallback.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/XalanTransformerCallback
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/foo.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XalanTransform/XalanTransform.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/XalanTransform
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/TestDriver.cpp
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.cpp
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.hpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/XPathWrapper
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/UseStylesheetParam.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/UseStylesheetParam
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/TransformToXercesDOM.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/TransformToXercesDOM
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/birds.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/birds.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/TraceListen/TraceListen.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/TraceListen
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/birds.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/birds.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/ThreadSafe.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ThreadSafe
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/StreamTransform/StreamTransform.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/StreamTransform
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/SimpleXPathCAPI.c
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleXPathCAPI
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/SimpleXPathAPI.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleXPathAPI
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/foo.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/SimpleTransform.cpp
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/XalanMemoryManagerImpl.hpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleTransform
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/SerializeNodeSet.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/SerializeNodeSet
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/foo.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/ParsedSourceWrappers.cpp
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ParsedSourceWrappers
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/ExternalFunction.cpp
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/foo.xsl
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ExternalFunction
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/DocumentBuilder/DocumentBuilder.cpp
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/DocumentBuilder/foo.xsl
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/DocumentBuilder
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/CompileStylesheet.cpp
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo1.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo10.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo2.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo3.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo4.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo5.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo6.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo7.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo8.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo9.xml
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/CompileStylesheet
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/apachemod.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/apachemod.xsl
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/foo.xml
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/foo.xsl
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ApacheModuleXSLT/xslt
-%%NO_SAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/mod_xslt.c
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%/ApacheModuleXSLT
-%%NO_SAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XalanTransformerCallback/XalanTransformerCallback.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/XalanTransformerCallback
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XalanTransform/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XalanTransform/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XalanTransform/XalanTransform.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/XalanTransform
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/TestDriver.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.hpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/XPathWrapper
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/UseStylesheetParam.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/UseStylesheetParam
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/TransformToXercesDOM.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/TransformToXercesDOM
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TraceListen/birds.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TraceListen/birds.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TraceListen/TraceListen.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/TraceListen
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/birds.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/birds.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ThreadSafe/ThreadSafe.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ThreadSafe
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/StreamTransform/StreamTransform.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/StreamTransform
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleXPathCAPI/SimpleXPathCAPI.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleXPathCAPI
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleXPathAPI/SimpleXPathAPI.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleXPathAPI
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/SimpleTransform.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SimpleTransform/XalanMemoryManagerImpl.hpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/SimpleTransform
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SerializeNodeSet/SerializeNodeSet.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/SerializeNodeSet
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ParsedSourceWrappers/ParsedSourceWrappers.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ParsedSourceWrappers
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/ExternalFunction.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ExternalFunction/foo.xsl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ExternalFunction
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/DocumentBuilder/DocumentBuilder.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/DocumentBuilder/foo.xsl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/DocumentBuilder
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/CompileStylesheet.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo1.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo10.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo2.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo3.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo4.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo5.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo6.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo7.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo8.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CompileStylesheet/foo9.xml
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/CompileStylesheet
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/apachemod.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/apachemod.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/xslt/foo.xsl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ApacheModuleXSLT/xslt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ApacheModuleXSLT/mod_xslt.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ApacheModuleXSLT
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/textproc/xalan-c/scripts/check-config-options b/textproc/xalan-c/scripts/check-config-options
deleted file mode 100644
index ec526e08d334..000000000000
--- a/textproc/xalan-c/scripts/check-config-options
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-rc=0
-
-if test -n "${WITH_NLS}"; then
- rc=$(expr $rc + 1)
-fi
-if test -n "${WITH_ICU}"; then
- rc=$(expr $rc + 1)
-fi
-if test -n "${WITH_INMEM}"; then
- rc=$(expr $rc + 1)
-fi
-
-if test ${rc} -gt 1; then
- echo "ERROR: please re-run make config and" >&2
- echo "only select one of the three locale systems." >&2
- exit 254
-fi
-
-exit 0
-
-# end