summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2005-11-13 08:13:16 +0000
committerColin Percival <cperciva@FreeBSD.org>2005-11-13 08:13:16 +0000
commit77683c01d1d09ac0ff9024c9c52888e22c17f708 (patch)
treefb2ea5674fe66ce29879ec13c127c7e428b1924b
parent7950fb5b4a5368b476ff971d85c3af640587b74c (diff)
downloadfreebsd-ports-77683c01d1d09ac0ff9024c9c52888e22c17f708.zip
Both bsdiff and portsnap have been added to the base system in
FreeBSD 5-STABLE and 6-STABLE. Add conditional IGNORE lines to reflect this. PR: ports/88879 (portsnap) Reminded by: delphij Approved by: linimon
-rw-r--r--misc/bsdiff/Makefile8
-rw-r--r--ports-mgmt/portsnap/Makefile4
-rw-r--r--sysutils/portsnap/Makefile4
3 files changed, 15 insertions, 1 deletions
diff --git a/misc/bsdiff/Makefile b/misc/bsdiff/Makefile
index 89cc1028492b..27b4888a3e9a 100644
--- a/misc/bsdiff/Makefile
+++ b/misc/bsdiff/Makefile
@@ -16,4 +16,10 @@ COMMENT= Generates and applies patches to binary files
MAN1= bsdiff.1 bspatch.1
PLIST_FILES= bin/bsdiff bin/bspatch
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 600033 || ( ${OSVERSION} > 504103 && ${OSVERSION} < 600000 )
+IGNORE= bsdiff now contained in the base system
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ports-mgmt/portsnap/Makefile b/ports-mgmt/portsnap/Makefile
index a114d08920e0..cb8aa6864804 100644
--- a/ports-mgmt/portsnap/Makefile
+++ b/ports-mgmt/portsnap/Makefile
@@ -21,6 +21,10 @@ RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff
RUN_DEPENDS+= sha256:${PORTSDIR}/sysutils/freebsd-sha256
.endif
+.if ${OSVERSION} > 600033 || ( ${OSVERSION} > 504103 && ${OSVERSION} < 600000 )
+IGNORE= portsnap now contained in the base system
+.endif
+
MAN5= portsnap.conf.5
MAN8= portsnap.8
PLIST_FILES= etc/portsnap.conf.sample sbin/portsnap \
diff --git a/sysutils/portsnap/Makefile b/sysutils/portsnap/Makefile
index a114d08920e0..cb8aa6864804 100644
--- a/sysutils/portsnap/Makefile
+++ b/sysutils/portsnap/Makefile
@@ -21,6 +21,10 @@ RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff
RUN_DEPENDS+= sha256:${PORTSDIR}/sysutils/freebsd-sha256
.endif
+.if ${OSVERSION} > 600033 || ( ${OSVERSION} > 504103 && ${OSVERSION} < 600000 )
+IGNORE= portsnap now contained in the base system
+.endif
+
MAN5= portsnap.conf.5
MAN8= portsnap.8
PLIST_FILES= etc/portsnap.conf.sample sbin/portsnap \