summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-08-28 16:19:16 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-08-28 16:19:16 +0000
commit72945b98125fd9fa259f62110dd5c0a7c493dc63 (patch)
tree8a0716192ca7250bc434b8328dbbc7cd831fd1c2
parent1da53cbcac208743aa444b7dae3233462075395c (diff)
downloadfreebsd-ports-72945b98125fd9fa259f62110dd5c0a7c493dc63.zip
- remove options ASM and GMP
-rw-r--r--security/openssl/Makefile33
1 files changed, 10 insertions, 23 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 40f4350febf6..a60bb8280d98 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openssl
PORTVERSION= 1.0.2
DISTVERSIONSUFFIX= h
-PORTREVISION= 14
+PORTREVISION= 15
PORTEPOCH= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
@@ -24,7 +24,7 @@ CONFLICTS= libressl-[0-9]* \
libressl-devel-[0-9]* \
openssl-devel-[0-9]*
-OPTIONS_DEFINE= SHARED THREADS SSE2 ASM PADLOCK ZLIB GMP SCTP SSL2 SSL3 RFC3779 MD2 RC5 EXPCIPHERS DOCS MAN3
+OPTIONS_DEFINE= SHARED THREADS SSE2 PADLOCK ZLIB SCTP SSL2 SSL3 RFC3779 MD2 RC5 EXPCIPHERS DOCS MAN3
OPTIONS_DEFAULT=SHARED THREADS SSE2 SCTP SSL2 SSL3 MD2 MAN3
OPTIONS_DEFINE_i386= I386
.for a in amd64 ia64
@@ -40,11 +40,9 @@ NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
I386_DESC?= Optimize for i386 (instead of i486+)
SSE2_DESC?= runtime SSE2 detection
-ASM_DESC?= optimized Assembler code
PADLOCK_DESC?= VIA Padlock support
SHARED_DESC?= build of shared libs
ZLIB_DESC?= zlib compression support
-GMP_DESC?= gmp support (LGPLv3)
SCTP_DESC?= SCTP protocol support
SSL2_DESC?= SSLv2 protocol support
SSL3_DESC?= SSLv3 protocol support
@@ -55,9 +53,7 @@ EXPCIPHERS_DESC?= Include experimental ciphers
EC_DESC?= Optimize NIST elliptic curves
MAN3_DESC?= Install API manpages (section 3)
-GMP_LIB_DEPENDS= libgmp.so:math/gmp
-
-USES= perl5 cpe
+USES= cpe perl5
USE_PERL5= build
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
MAKE_ENV+= LIBRPATH="${PREFIX}/lib" GREP_OPTIONS=
@@ -75,7 +71,8 @@ PLIST_SUB+= OPENSSLDIR=${OPENSSLDIR:S=^${PREFIX}/==}
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
-OPENSSL_SHLIBVER?= 8
+
+.include "version.mk"
.if ${PORT_OPTIONS:MI386}
.if ${ARCH} == "i386"
@@ -88,12 +85,7 @@ EXTRACONFIGURE+= 386
EXTRACONFIGURE+= no-sse2
.endif
-.if ${PORT_OPTIONS:MASM}
-BROKEN_sparc64= option ASM generates illegal instructions
-EXTRACONFIGURE+= enable-asm
-.else
EXTRACONFIGURE+= no-asm
-.endif
.if ${PORT_OPTIONS:MTHREADS}
EXTRACONFIGURE+= threads
@@ -153,12 +145,7 @@ PATCHFILES+= 1001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch:pad
1004-crypto-engine-autoload-padlock-dynamic-engine.patch:padlock
.endif
-.if ${PORT_OPTIONS:MGMP}
-EXTRACONFIGURE+= enable-gmp -I${LOCALBASE}/include
-IGNORE= can not be linked because GMP is LGPLv3
-.else
EXTRACONFIGURE+= no-gmp
-.endif
.if ${PORT_OPTIONS:MRFC3779}
EXTRACONFIGURE+= enable-rfc3779
@@ -203,23 +190,23 @@ do-configure:
./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \
--install_prefix=${STAGEDIR} \
-L${PREFIX}/lib ${EXTRACONFIGURE}
+
+post-configure:
${REINPLACE_CMD} \
-e 's|^MANDIR=.*$$|MANDIR=$$(PREFIX)/man|' \
-e 's|$$(LIBDIR)/pkgconfig|libdata/pkgconfig|g' \
-e 's|LIBVERSION=[^ ]* |LIBVERSION=${OPENSSL_SHLIBVER} |' \
${WRKSRC}/Makefile
-post-install:
-.if ${PORT_OPTIONS:MSHARED}
+post-install-SHARED-on:
.for i in libcrypto libssl
${INSTALL_DATA} ${WRKSRC}/$i.so.${OPENSSL_SHLIBVER} ${STAGEDIR}${PREFIX}/lib
${LN} -sf $i.so.${OPENSSL_SHLIBVER} ${STAGEDIR}${PREFIX}/lib/$i.so
.endfor
-.endif
-.if empty(PORT_OPTIONS:MMAN3)
+
+post-install-MAN3-off:
${RM} -rf ${STAGEDIR}/${PREFIX}/man/man3
${REINPLACE_CMD} -e 's|^man/man3/.*||' ${TMPPLIST}
-.endif
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}