summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2023-08-19 15:11:27 -0400
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 12:13:02 -0400
commit7219a47f1ab385e6977fb04aba301549d976965d (patch)
treed2069bb6f5dfcd4c705629e5e33c5443bf94623d
parent2fc29ef8de8d7d8fb18f2fba3cf2910c76d5010d (diff)
downloadfreebsd-ports-7219a47f1ab385e6977fb04aba301549d976965d.zip
devel/py-strictyaml: New port: Strict, typed YAML parser
StrictYAML is a type-safe YAML parser that parses and validates a restricted subset of the YAML specification. Priorities: * Beautiful API. * Refusing to parse the ugly, hard to read and insecure features of YAML like the Norway problem. * Strict validation of markup and straightforward type casting. * Clear, readable exceptions with code snippets and line numbers. * Acting as a near-drop in replacement for pyyaml, ruamel.yaml or poyo. * Ability to read in YAML, make changes and write it out again with comments preserved. * Not speed, currently. WWW: https://hitchdev.com/strictyaml PR: 273232
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-strictyaml/Makefile21
-rw-r--r--devel/py-strictyaml/distinfo3
-rw-r--r--devel/py-strictyaml/pkg-descr15
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8a81e97bc150..c4723cb5944a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5618,6 +5618,7 @@
SUBDIR += py-streamparse
SUBDIR += py-strenum
SUBDIR += py-strict-rfc3339
+ SUBDIR += py-strictyaml
SUBDIR += py-stringbrewer
SUBDIR += py-stringcase
SUBDIR += py-structlog
diff --git a/devel/py-strictyaml/Makefile b/devel/py-strictyaml/Makefile
new file mode 100644
index 000000000000..ebd538f214b8
--- /dev/null
+++ b/devel/py-strictyaml/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= strictyaml
+DISTVERSION= 1.7.3
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= DtxdF@disroot.org
+COMMENT= Strict, typed YAML parser
+WWW= https://hitchdev.com/${PORTNAME}
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-strictyaml/distinfo b/devel/py-strictyaml/distinfo
new file mode 100644
index 000000000000..4d258f700fe1
--- /dev/null
+++ b/devel/py-strictyaml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692464120
+SHA256 (strictyaml-1.7.3.tar.gz) = 22f854a5fcab42b5ddba8030a0e4be51ca89af0267961c8d6cfa86395586c407
+SIZE (strictyaml-1.7.3.tar.gz) = 115206
diff --git a/devel/py-strictyaml/pkg-descr b/devel/py-strictyaml/pkg-descr
new file mode 100644
index 000000000000..2103ef0c9868
--- /dev/null
+++ b/devel/py-strictyaml/pkg-descr
@@ -0,0 +1,15 @@
+StrictYAML is a type-safe YAML parser that parses and validates a
+restricted subset of the YAML specification.
+
+Priorities:
+
+* Beautiful API.
+* Refusing to parse the ugly, hard to read and insecure features
+ of YAML like the Norway problem.
+* Strict validation of markup and straightforward type casting.
+* Clear, readable exceptions with code snippets and line numbers.
+* Acting as a near-drop in replacement for pyyaml, ruamel.yaml or
+ poyo.
+* Ability to read in YAML, make changes and write it out again
+ with comments preserved.
+* Not speed, currently.