summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2023-03-15 09:14:16 +0000
committerBernard Spil <brnrd@FreeBSD.org>2023-03-15 09:14:16 +0000
commit70a4cc59a7690c42d12e673c33f79993619a66b7 (patch)
tree38c6eeabddc623e357bc3677ab26b36ee85eec79
parent163600fc0d31d95d97382f06c4456b85f49e783e (diff)
downloadfreebsd-ports-70a4cc59a7690c42d12e673c33f79993619a66b7.zip
security/openssl30: Chase rename in ports CONFLICTS*
Reported by: cperciva, junchoon
-rw-r--r--security/boringssl/Makefile5
-rw-r--r--security/gost-engine/Makefile5
-rw-r--r--security/libressl-devel/Makefile2
-rw-r--r--security/libressl/Makefile2
-rw-r--r--security/openssl-quictls/Makefile2
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl30/Makefile4
-rw-r--r--security/openssl31/Makefile2
8 files changed, 12 insertions, 12 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index 988e05cc462d..c658a764487c 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -11,9 +11,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake:insource cpe go:no_targets localbase perl5
-CONFLICTS_INSTALL= security/libressl security/libressl-devel \
- security/openssl security/openssl-devel \
- security/openssl-quictls
+CONFLICTS_INSTALL= libressl libressl-devel \
+ openssl openssl3[01] openssl-quictls
CPE_VENDOR= google
diff --git a/security/gost-engine/Makefile b/security/gost-engine/Makefile
index 2451650dde4b..e19b4192e256 100644
--- a/security/gost-engine/Makefile
+++ b/security/gost-engine/Makefile
@@ -9,10 +9,11 @@ WWW= https://github.com/gost-engine/engine/blob/master/README.gost
LICENSE= OpenSSL
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= libressl libressl-devel openssl-devel
+BROKEN_SSL= libressl libressl-devel openssl30 openssl31
BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL 1.1.1+
BROKEN_SSL_REASON_libressl-devel= needs features only available in OpenSSL 1.1.1+
-BROKEN_SSL_REASON_openssl-devel= for OpenSSL 1.1.1 only
+BROKEN_SSL_REASON_openssl30= for OpenSSL 1.1.1 only
+BROKEN_SSL_REASON_openssl31= for OpenSSL 1.1.1 only
BUILD_DEPENDS= cmake>=3.18.1:devel/cmake
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index ffed6437b9f6..22f5cc795407 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -27,7 +27,7 @@ NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl \
libretls
-default_CONFLICTS_INSTALL= openssl
+default_CONFLICTS_INSTALL= openssl openssl3[01] openssl-quictls
.if ${FLAVOR:U} == default
OPTIONS_EXCLUDE= LIBTLS
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 574151ad0833..95e636b6d39d 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -27,7 +27,7 @@ NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl-devel
libtls_CONFLICTS_INSTALL= libretls
default_CONFLICTS_INSTALL= openssl \
- openssl-devel
+ openssl3[01]
.if ${FLAVOR:U} == default
OPTIONS_EXCLUDE= LIBTLS
diff --git a/security/openssl-quictls/Makefile b/security/openssl-quictls/Makefile
index 3dacd7fc6f77..2bd01bbbb50c 100644
--- a/security/openssl-quictls/Makefile
+++ b/security/openssl-quictls/Makefile
@@ -10,7 +10,7 @@ WWW= https://www.github.com/quictls/openssl
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl-devel
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl3[01]
BROKEN_i386= ld: error: undefined symbol: __atomic_is_lock_free
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 3c48f10211bb..4d14e1aa8962 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -12,7 +12,7 @@ WWW= https://www.openssl.org/
LICENSE= OpenSSL
LICENSE_FILE= ${WRKSRC}/LICENSE
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl-devel openssl-quictls
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl3[01] openssl-quictls
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
diff --git a/security/openssl30/Makefile b/security/openssl30/Makefile
index 745ac9470caf..4702b186a0f7 100644
--- a/security/openssl30/Makefile
+++ b/security/openssl30/Makefile
@@ -3,7 +3,7 @@ DISTVERSION= 3.0.8
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
-PKGNAMESUFFIX= -devel
+PKGNAMESUFFIX= 30
MAINTAINER= brnrd@FreeBSD.org
COMMENT= TLSv1.3 capable SSL and crypto library
@@ -12,7 +12,7 @@ WWW= https://www.openssl.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl-quictls
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl31 openssl-quictls
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
diff --git a/security/openssl31/Makefile b/security/openssl31/Makefile
index 1009097f0d08..a498df2d4501 100644
--- a/security/openssl31/Makefile
+++ b/security/openssl31/Makefile
@@ -12,7 +12,7 @@ WWW= https://www.openssl.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl-quictls
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl30 openssl-quictls
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config