summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-02-04 11:23:25 +0300
committerDima Panov <fluffy@FreeBSD.org>2023-02-04 11:23:25 +0300
commit645c54e10d3bd939a03d65e87aee074623c333d2 (patch)
treef1ff0fd7273f4356c2942c410813ed2283b969b7
parentc310ec773dd0ae8039c5a0f4161bceb52e0ab3bc (diff)
downloadfreebsd-ports-645c54e10d3bd939a03d65e87aee074623c333d2.zip
security/xmlsec1: update to 1.2.37 release (+)
This is a prerequisite for LibreOffcie 7.5 update News: 1.2.37: Fixed two regressions from 1.2.36 release: issue #437 and issue #449. 1.2.36: Retired the XMLSec mailing list "xmlsec@aleksey.com" and the XMLSec Online Signature Verifier. Several other small fixes (more details). 1.3.25: Migration to OpenSSL 3.0 API (based on PR by @snargit). The OpenSSL before 1.1.0 and LibreSSL before 2.7.0 are now deprecated and will be removed in the future versions of XMLSec Library. Refactored all the integer casts to ensure cast-safety. Fixed all warnings and enabled "-Werror" and "-pedantic" flags on CI builds. Added configure flag to use size_t for xmlSecSize (currently disabled by default for backward compatibility). Several other small fixes (more details). Full Changelog: https://www.aleksey.com/xmlsec/ With hat: office
-rw-r--r--security/xmlsec1/Makefile9
-rw-r--r--security/xmlsec1/distinfo6
-rw-r--r--security/xmlsec1/files/patch-Makefile.in4
-rw-r--r--security/xmlsec1/files/patch-apps-xmlsec.c11
-rw-r--r--security/xmlsec1/files/patch-src-openssl-app.c22
5 files changed, 19 insertions, 33 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index aca23bcc2800..7d44f009d6f3 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -1,11 +1,8 @@
PORTNAME= xmlsec1
-PORTVERSION= 1.2.34
-PORTREVISION= 1
+PORTVERSION= 1.2.37
CATEGORIES= security
-MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
- ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
- ftp://ftp.xmlsoft.org/xmlsec/releases/ \
- ftp://ftp.rpmfind.net/pub/XML/xmlsec/releases/
+MASTER_SITES= https://www.aleksey.com/xmlsec/download/ \
+ https://github.com/lsh123/xmlsec/releases/download/xmlsec-${PORTVERSION:S,.,_,g}/
MAINTAINER= hrs@FreeBSD.org
COMMENT= XML Security Library
diff --git a/security/xmlsec1/distinfo b/security/xmlsec1/distinfo
index baa844e7f7ee..0482e6233802 100644
--- a/security/xmlsec1/distinfo
+++ b/security/xmlsec1/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1651858077
-SHA256 (xmlsec1-1.2.34.tar.gz) = 52ced4943f35bd7d0818a38298c1528ca4ac8a54440fd71134a07d2d1370a262
-SIZE (xmlsec1-1.2.34.tar.gz) = 1991505
+TIMESTAMP = 1670335424
+SHA256 (xmlsec1-1.2.37.tar.gz) = 5f8dfbcb6d1e56bddd0b5ec2e00a3d0ca5342a9f57c24dffde5c796b2be2871c
+SIZE (xmlsec1-1.2.37.tar.gz) = 2009175
diff --git a/security/xmlsec1/files/patch-Makefile.in b/security/xmlsec1/files/patch-Makefile.in
index 250d09d1d46d..be5659c14e62 100644
--- a/security/xmlsec1/files/patch-Makefile.in
+++ b/security/xmlsec1/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2022-05-06 17:33:38 UTC
+--- Makefile.in.orig 2022-12-06 14:04:01 UTC
+++ Makefile.in
-@@ -490,7 +490,7 @@ DEFAULT_CRYPTO = @XMLSEC_DEFAULT_CRYPTO@
+@@ -491,7 +491,7 @@ pkgconfigdir = $(prefix)/libdata/pkgconfig
bin_SCRIPTS = xmlsec1-config
pkgconfig_DATA = xmlsec1.pc @XMLSEC_CRYPTO_PC_FILES_LIST@
pkgconfigdir = $(prefix)/libdata/pkgconfig
diff --git a/security/xmlsec1/files/patch-apps-xmlsec.c b/security/xmlsec1/files/patch-apps-xmlsec.c
deleted file mode 100644
index ce1c62f81e60..000000000000
--- a/security/xmlsec1/files/patch-apps-xmlsec.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- apps/xmlsec.c.orig 2022-05-03 14:36:17 UTC
-+++ apps/xmlsec.c
-@@ -1210,7 +1210,7 @@ int main(int argc, const char **argv) {
- (xmlSecAppCmdLineParamGetInt(&repeatParam, 1) > 0)) {
-
- repeats = xmlSecAppCmdLineParamGetInt(&repeatParam, 1);
-- fprintf(stderr, "Executed %d tests in %ld msec\n", repeats, (1000 * total_time) / CLOCKS_PER_SEC);
-+ fprintf(stderr, "Executed %d tests in %ld msec\n", repeats, (long)(1000 * total_time) / CLOCKS_PER_SEC);
- }
-
- goto success;
diff --git a/security/xmlsec1/files/patch-src-openssl-app.c b/security/xmlsec1/files/patch-src-openssl-app.c
index c723cad64dad..bbb25c3f4030 100644
--- a/security/xmlsec1/files/patch-src-openssl-app.c
+++ b/security/xmlsec1/files/patch-src-openssl-app.c
@@ -1,8 +1,8 @@
---- src/openssl/app.c.orig 2022-05-03 23:36:17.000000000 +0900
-+++ src/openssl/app.c 2022-05-07 05:18:46.065103000 +0900
-@@ -43,6 +43,29 @@
+--- src/openssl/app.c.orig 2022-11-28 21:40:24 UTC
++++ src/openssl/app.c
+@@ -46,6 +46,29 @@
- #include "openssl_compat.h"
+ #include "../cast_helpers.h"
+#if defined(XMLSEC_OPENSSL_API_110) && defined(LIBRESSL_VERSION_NUMBER)
+static UI_METHOD *
@@ -27,10 +27,10 @@
+}
+#endif
+
- static int xmlSecOpenSSLAppLoadRANDFile (const char *filename);
- static int xmlSecOpenSSLAppSaveRANDFile (const char *filename);
static int xmlSecOpenSSLDefaultPasswordCallback (char *buf,
-@@ -415,6 +438,11 @@
+ int bufsiz,
+ int verify,
+@@ -462,6 +485,11 @@ xmlSecOpenSSLAppEngineKeyLoad(const char *engineName,
EVP_PKEY* pKey = NULL;
int engineInit = 0;
int ret;
@@ -40,9 +40,9 @@
+ const UI_METHOD *ui_null = ui_null_create();
+#endif
- #ifndef OPENSSL_NO_ENGINE
xmlSecAssert2(engineName != NULL, NULL);
-@@ -437,7 +465,7 @@
+ xmlSecAssert2(engineKeyId != NULL, NULL);
+@@ -487,7 +515,7 @@ xmlSecOpenSSLAppEngineKeyLoad(const char *engineName,
}
}
@@ -51,7 +51,7 @@
xmlSecOpenSSLError("ENGINE_ctrl_cmd_string(SET_USER_INTERFACE)", NULL);
goto done;
}
-@@ -453,7 +481,7 @@
+@@ -503,7 +531,7 @@ xmlSecOpenSSLAppEngineKeyLoad(const char *engineName,
/* load private key */
pKey = ENGINE_load_private_key(engine, engineKeyId,
@@ -60,7 +60,7 @@
NULL);
if(pKey == NULL) {
xmlSecOpenSSLError("ENGINE_load_private_key", NULL);
-@@ -484,6 +512,7 @@
+@@ -534,6 +562,7 @@ done:
data = NULL;
done: