summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-29 18:23:33 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-31 12:42:07 +0200
commit5d21bb4356964559f010dc2bb253aa47a08864f2 (patch)
tree804148409d1bca5cc47523f0bd7f6f8cd2f1f102
parent107986e7cd561c56392ac628962e29e92340cc9a (diff)
downloadfreebsd-ports-5d21bb4356964559f010dc2bb253aa47a08864f2.zip
net/drive: fix build on riscv64
Bump golang.org/x/sys dependency to a version new enough to support riscv64. Add missing riscv64-specific bits to github.com/boltdb/bolt dependency. Sponsored by: Berliner Linux User Group e.V. Obtained from: go.etcd.io/bbolt Approved by: portmgr (build fix blanket)
-rw-r--r--net/drive/Makefile4
-rw-r--r--net/drive/distinfo6
-rw-r--r--net/drive/files/patch-vendor_github.com_boltdb_bolt_bolt__riscv64.go16
3 files changed, 21 insertions, 5 deletions
diff --git a/net/drive/Makefile b/net/drive/Makefile
index 6262351932d1..df0ef2d53861 100644
--- a/net/drive/Makefile
+++ b/net/drive/Makefile
@@ -1,7 +1,7 @@
PORTNAME= drive
PORTVERSION= 0.4.0
DISTVERSIONPREFIX= v
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= net
MAINTAINER= sunpoet@FreeBSD.org
@@ -27,7 +27,7 @@ GH_TUPLE= boltdb:bolt:v1.3.1:boltdb_bolt/vendor/github.com/boltdb/bolt \
golang:net:c90051b:golang_net/vendor/golang.org/x/net \
golang:oauth2:2104d58:golang_oauth2/vendor/golang.org/x/oauth2 \
golang:protobuf:v1.5.2:golang_protobuf/vendor/github.com/golang/protobuf \
- golang:sys:05e143d:golang_sys/vendor/golang.org/x/sys \
+ golang:sys:v0.6.0:golang_sys/vendor/golang.org/x/sys \
golang:text:b4bca84:golang_text/vendor/golang.org/x/text \
google:go-genproto:590a5ac:google_go_genproto/vendor/google.golang.org/genproto \
google:uuid:v1.3.0:google_uuid/vendor/github.com/google/uuid \
diff --git a/net/drive/distinfo b/net/drive/distinfo
index 5d672aa2fcf8..70f523813065 100644
--- a/net/drive/distinfo
+++ b/net/drive/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1657198923
+TIMESTAMP = 1680113836
SHA256 (odeke-em-drive-v0.4.0_GH0.tar.gz) = 7a6445b54c6c13d0ddd8893ca02264211eeea68c7a0c7e9ccc6473f68af40a00
SIZE (odeke-em-drive-v0.4.0_GH0.tar.gz) = 337088
SHA256 (boltdb-bolt-v1.3.1_GH0.tar.gz) = b5ae498b780f535a5d308c188dee1329b3536275d29ad6758876084c0b8586a8
@@ -17,8 +17,8 @@ SHA256 (golang-oauth2-2104d58_GH0.tar.gz) = ba33dab14b6414be0763733eab0514f26c42
SIZE (golang-oauth2-2104d58_GH0.tar.gz) = 104039
SHA256 (golang-protobuf-v1.5.2_GH0.tar.gz) = 088cc0f3ba18fb8f9d00319568ff0af5a06d8925a6e6cb983bb837b4efb703b3
SIZE (golang-protobuf-v1.5.2_GH0.tar.gz) = 171702
-SHA256 (golang-sys-05e143d_GH0.tar.gz) = ab0ce42ab499557e024b7fa98c21f4eca10de603dcc7b372acc2ee92fb4f9505
-SIZE (golang-sys-05e143d_GH0.tar.gz) = 1303691
+SHA256 (golang-sys-v0.6.0_GH0.tar.gz) = b4f6d17c7a128f76169964b437cb66b3f2dbf9a33361928ec19dfecf7b03fc54
+SIZE (golang-sys-v0.6.0_GH0.tar.gz) = 1434234
SHA256 (golang-text-b4bca84_GH0.tar.gz) = 47bea3550152690832c86c25d1e853325bb10e957adf28b144e50abdbbbfdaf7
SIZE (golang-text-b4bca84_GH0.tar.gz) = 8360504
SHA256 (google-go-genproto-590a5ac_GH0.tar.gz) = 9ca17194373b705718461cf8d4ae973d2e8e4f8d3a81f5713229d13db18d516c
diff --git a/net/drive/files/patch-vendor_github.com_boltdb_bolt_bolt__riscv64.go b/net/drive/files/patch-vendor_github.com_boltdb_bolt_bolt__riscv64.go
new file mode 100644
index 000000000000..8b11be4f4104
--- /dev/null
+++ b/net/drive/files/patch-vendor_github.com_boltdb_bolt_bolt__riscv64.go
@@ -0,0 +1,16 @@
+--- /dev/null 2023-03-29 16:51:35 UTC
++++ vendor/github.com/boltdb/bolt/bolt_riscv64.go
+@@ -0,0 +1,13 @@
++//go:build riscv64
++// +build riscv64
++
++package bolt
++
++// maxMapSize represents the largest mmap size supported by Bolt.
++const maxMapSize = 0xFFFFFFFFFFFF // 256TB
++
++// maxAllocSize is the size used when creating array pointers.
++const maxAllocSize = 0x7FFFFFFF
++
++// are unaligned reads/writes not supported?
++var brokenUnaligned = false