summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-03-26 21:11:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-03-26 21:11:12 +0000
commit54cc705bed38d2eb922277c4714f4fa7ff9f9888 (patch)
treee3406b6980828bb61e71e65fbabb9beb4b060f33
parenta697336cb9b0735313b44352cdaac9c928ac9295 (diff)
downloadfreebsd-ports-54cc705bed38d2eb922277c4714f4fa7ff9f9888.zip
- Stage support
- Use USE_OCAMLFIND_PLIST instead of doing it manually
-rw-r--r--devel/ocaml-ulex/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/devel/ocaml-ulex/Makefile b/devel/ocaml-ulex/Makefile
index 2936ef7a27dd..0e5df92ccc77 100644
--- a/devel/ocaml-ulex/Makefile
+++ b/devel/ocaml-ulex/Makefile
@@ -11,31 +11,27 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= johans@FreeBSD.org
COMMENT= A lexer generator for Unicode and OCaml
+USES= gmake
USE_OCAML= true
USE_OCAML_FINDLIB= true
USE_OCAML_LDCONFIG= true
-OCAMLC_DEPEND= ocaml>=3.10:${OCAMLC_PORT}
+USE_OCAMLFIND_PLIST= yes
ALL_TARGET= all all.opt
-
-USE_GMAKE= yes
-
MAKE_JOBS_UNSAFE= yes
-.if !defined(NOPORTDOCS)
-ALL_TARGET+= doc
PORTDOCS= *
-.endif
-PKGDEINSTALL= ${PKGINSTALL}
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+ALL_TARGET+= doc
-NO_STAGE= yes
post-install:
- @${FIND} ${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/*.css ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/*.css ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>