summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2017-01-02 07:52:13 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2017-01-02 07:52:13 +0000
commit4ea0a12cdfa80718746a24f3025133196c0011d0 (patch)
tree5a01d3ebc923faa71d47b292dcfda99429cab3e8
parentb8d38e705ed68fcfe9766ead56448b4c4194128d (diff)
downloadfreebsd-ports-4ea0a12cdfa80718746a24f3025133196c0011d0.zip
Update to 0.3.1
-rw-r--r--devel/lxqt-build-tools/Makefile2
-rw-r--r--devel/lxqt-build-tools/distinfo6
-rw-r--r--devel/lxqt-build-tools/files/extra-patch-cmake_modules_LXQtCompilerSettings.cmake10
3 files changed, 9 insertions, 9 deletions
diff --git a/devel/lxqt-build-tools/Makefile b/devel/lxqt-build-tools/Makefile
index 26127df558a8..c6e011d5a271 100644
--- a/devel/lxqt-build-tools/Makefile
+++ b/devel/lxqt-build-tools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lxqt-build-tools
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= devel
MASTER_SITES= LXQT/${PORTNAME}
diff --git a/devel/lxqt-build-tools/distinfo b/devel/lxqt-build-tools/distinfo
index de7e1cf736ff..9ee6896c7974 100644
--- a/devel/lxqt-build-tools/distinfo
+++ b/devel/lxqt-build-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481464588
-SHA256 (lxqt/lxqt-build-tools-0.3.0.tar.xz) = 850124c0b76be38859745542fa45cb65191034d32b4fbc9f3399c867db69c008
-SIZE (lxqt/lxqt-build-tools-0.3.0.tar.xz) = 19024
+TIMESTAMP = 1483342466
+SHA256 (lxqt/lxqt-build-tools-0.3.1.tar.xz) = 6c16bed977d78eea85f43ac1c82aa00065c739268a12c721d1bf3089933ff840
+SIZE (lxqt/lxqt-build-tools-0.3.1.tar.xz) = 19320
diff --git a/devel/lxqt-build-tools/files/extra-patch-cmake_modules_LXQtCompilerSettings.cmake b/devel/lxqt-build-tools/files/extra-patch-cmake_modules_LXQtCompilerSettings.cmake
index 747b0140bd91..324f31c4fdc9 100644
--- a/devel/lxqt-build-tools/files/extra-patch-cmake_modules_LXQtCompilerSettings.cmake
+++ b/devel/lxqt-build-tools/files/extra-patch-cmake_modules_LXQtCompilerSettings.cmake
@@ -1,4 +1,4 @@
---- cmake/modules/LXQtCompilerSettings.cmake.orig 2016-12-06 20:31:16 UTC
+--- cmake/modules/LXQtCompilerSettings.cmake.orig 2017-01-01 21:46:43 UTC
+++ cmake/modules/LXQtCompilerSettings.cmake
@@ -144,7 +144,9 @@ endif()
if (CMAKE_COMPILER_IS_GNUCXX OR LXQT_COMPILER_IS_CLANGCXX)
@@ -7,7 +7,7 @@
- set(LTO_FLAGS "-flto -fuse-linker-plugin")
+ if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ set(LTO_FLAGS "-flto -fuse-linker-plugin")
-+ endif ()
- elseif (LXQT_COMPILER_IS_CLANGCXX)
- # The link-time optimization of clang++/llvm seems to be too aggrassive.
- # After testing, it breaks the signal/slots of QObject sometimes.
++ endif()
+ # When building static libraries with LTO in gcc >= 4.9,
+ # "gcc-ar" and "gcc-ranlib" should be used instead of "ar" and "ranlib".
+ # references: