summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Certner <olce.freebsd@certner.fr>2023-09-08 22:41:44 +0200
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 12:13:06 -0400
commit48a52b7c645234ad0b6ac4f5a1c3b0f3d5281ca9 (patch)
treef721d59c00e0fc82eaae1eb716baf89624b1e687
parent8cb208f78e42efe2bb83ed034c4ec7da8956f33b (diff)
downloadfreebsd-ports-48a52b7c645234ad0b6ac4f5a1c3b0f3d5281ca9.zip
devel/libkiwix: Update to 12.1.0
Notably, a new /nojs endpoint (still leaves much to be desired), and lots of bug fixes, including our local patch for meson that was integrated upstream. More details here: https://github.com/kiwix/libkiwix/releases/tag/12.1.0 PR: 273644
-rw-r--r--devel/libkiwix/Makefile3
-rw-r--r--devel/libkiwix/distinfo6
-rw-r--r--devel/libkiwix/files/patch-meson.build26
3 files changed, 17 insertions, 18 deletions
diff --git a/devel/libkiwix/Makefile b/devel/libkiwix/Makefile
index 1c5a5ccd4a6b..e33da8db2a4b 100644
--- a/devel/libkiwix/Makefile
+++ b/devel/libkiwix/Makefile
@@ -1,6 +1,5 @@
PORTNAME= libkiwix
-DISTVERSION= 12.0.0
-PORTREVISION= 1
+DISTVERSION= 12.1.0
CATEGORIES= devel
MAINTAINER= olce.freebsd.ports@certner.fr
diff --git a/devel/libkiwix/distinfo b/devel/libkiwix/distinfo
index 3526ae0576cf..39023c5f8af9 100644
--- a/devel/libkiwix/distinfo
+++ b/devel/libkiwix/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1686582304
-SHA256 (kiwix-libkiwix-12.0.0_GH0.tar.gz) = 8608ef73fdaa34c28144eb5ad732a74ca94dd99710d08d7a1ddb1277d1985b02
-SIZE (kiwix-libkiwix-12.0.0_GH0.tar.gz) = 1114076
+TIMESTAMP = 1692892288
+SHA256 (kiwix-libkiwix-12.1.0_GH0.tar.gz) = 42e8f9f973054e11f17381c988790c8f8267898b5a611741f0aa03cc4ccf3f75
+SIZE (kiwix-libkiwix-12.1.0_GH0.tar.gz) = 1098820
SHA256 (kainjow-Mustache-v4.1_GH0.tar.gz) = acd66359feb4318b421f9574cfc5a511133a77d916d0b13c7caa3783c0bfe167
SIZE (kainjow-Mustache-v4.1_GH0.tar.gz) = 98905
diff --git a/devel/libkiwix/files/patch-meson.build b/devel/libkiwix/files/patch-meson.build
index f5aa75063095..eb9c07cc45fe 100644
--- a/devel/libkiwix/files/patch-meson.build
+++ b/devel/libkiwix/files/patch-meson.build
@@ -1,16 +1,16 @@
---- meson.build.orig 2022-11-30 17:10:19 UTC
+--- meson.build.orig 2023-09-09 03:15:43 UTC
+++ meson.build
-@@ -36,7 +36,7 @@ else
- endif
+@@ -7,12 +7,7 @@ compiler = meson.get_compiler('cpp')
- libzim_dep = dependency('libzim', version : '>=8.1.0', static:static_deps)
--if not compiler.has_header_symbol('zim/zim.h', 'LIBZIM_WITH_XAPIAN')
-+if not compiler.has_header_symbol('zim/zim.h', 'LIBZIM_WITH_XAPIAN', dependencies: libzim_dep)
- error('Libzim seems to be compiled without xapian. Xapian support is mandatory.')
- endif
+ static_deps = get_option('static-linkage') or get_option('default_library') == 'static'
-@@ -86,4 +86,3 @@ configure_file(output : 'kiwix.pc',
- input : 'kiwix.pc.in',
- install_dir: get_option('libdir')+'/pkgconfig'
- )
--
+-# See https://github.com/kiwix/libkiwix/issues/371
+-if ['arm', 'mips', 'm68k', 'ppc', 'sh4'].contains(host_machine.cpu_family())
+- extra_libs = ['-latomic']
+-else
+- extra_libs = []
+-endif
++extra_libs = []
+
+ if (compiler.get_id() == 'gcc' and build_machine.system() == 'linux') or host_machine.system() == 'freebsd'
+ # C++ std::thread is implemented using pthread on linux by gcc