summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoshio MITA <mita@FreeBSD.org>2005-03-04 08:12:42 +0000
committerYoshio MITA <mita@FreeBSD.org>2005-03-04 08:12:42 +0000
commit422afa46e7692efea28d3399f16f79856bf75c08 (patch)
tree06bd38cdb80c27164783efef4d5c300b94160d91
parent015687d5d881e31b60affbaba144f50de462e085 (diff)
downloadfreebsd-ports-422afa46e7692efea28d3399f16f79856bf75c08.zip
unbreak magicpoint and update to 1.11b
PR: ports/78300 ports/78395 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de>
-rw-r--r--japanese/magicpoint/Makefile6
-rw-r--r--misc/magicpoint/Makefile50
-rw-r--r--misc/magicpoint/distinfo4
-rw-r--r--misc/magicpoint/pkg-plist1
4 files changed, 48 insertions, 13 deletions
diff --git a/japanese/magicpoint/Makefile b/japanese/magicpoint/Makefile
index 23d5149655a8..08eaf8367a31 100644
--- a/japanese/magicpoint/Makefile
+++ b/japanese/magicpoint/Makefile
@@ -8,14 +8,10 @@
MASTERDIR= ${.CURDIR}/../../misc/magicpoint
COMMENT= An X11-based presentation tool, configured with vflib support
-LIB_DEPENDS= VFlib2.24:${PORTSDIR}/japanese/vflib
-
CATEGORIES= japanese
MAINTAINER= mita@jp.FreeBSD.org
-# dirty, but this is required for version independent-ness
-CONFIGURE_ARGS= --with-vfontcap=`${LS} -1 ${LOCALBASE}/share/VFlib/*/vfontcap | tail -1`
-CONFIGURE_ARGS+= --enable-freetype-charset16
+WITH_JAPANESE=yes
.include "${MASTERDIR}/Makefile"
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index b640c3750ae0..38209faef27b 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -7,9 +7,9 @@
# "?=" and "+=" are for localized (i.e. Japanese) version
PORTNAME= magicpoint
-PORTVERSION= 1.11a
+PORTVERSION= 1.11b
CATEGORIES+= misc
-MASTER_SITES= ftp://ftp.mew.org/pub/mgp/
+MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
MAINTAINER?= mita@FreeBSD.org
COMMENT?= An X11-based presentation tool
@@ -18,13 +18,14 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
mng:${PORTSDIR}/graphics/libmng
RUN_DEPENDS+= pnmscale:${PORTSDIR}/graphics/netpbm
-BROKEN= Incomplete pkg-plist
-
USE_IMAKE= yes
USE_REINPLACE= yes
-USE_FREETYPE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS?=--disable-vflib
+
+OPTIONS+= FREETYPE "With FreeType support" on \
+ XFT "With Xft2 support" on \
+ GIF "With gif image support" off \
+ IMLIB "With Imlib exclusive image processing" off
MAN1= mgp.1 mgp2ps.1 mgpembed.1 mgpnet.1 xwintoppm.1 xmindpath.1
@@ -43,6 +44,43 @@ SAMPLE_SCRIPTS= eqn2eps.sh tex2eps.sh mgp2html.pl mgp2latex.pl
.include <bsd.port.pre.mk>
+.if defined(WITH_FREETYPE)
+USE_FREETYPE= yes
+CONFIGURE_ARGS+= --enable-freetype
+.else
+CONFIGURE_ARGS+= --disable-freetype
+.endif
+
+.if defined(WITH_XFT)
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --enable-xft2
+.else
+CONFIGURE_ARGS+= --disable-xft2
+.endif
+
+.if defined(WITH_GIF)
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+CONFIGURE_ARGS+= --enable-gif
+.else
+CONFIGURE_ARGS+= --disable-gif
+.endif
+
+.if defined(WITH_IMLIB)
+LIB_DEPENDS+= Imlib.5:${PORTSDIR}/graphics/imlib
+CONFIGURE_ARGS+= --enable-imlib
+.else
+CONFIGURE_ARGS+= --disable-imlib
+.endif
+
+.if defined(WITH_JAPANESE)
+LIB_DEPENDS+= VFlib2.24:${PORTSDIR}/japanese/vflib
+CONFIGURE_ARGS+= --enable-vflib \
+ --with-vfontcap=`${LS} -1 ${LOCALBASE}/share/VFlib/*/vfontcap | tail -1` \
+ --enable-freetype-charset16
+.else
+CONFIGURE_ARGS+= --disable-vflib
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|varargs.h|stdarg.h|' \
${WRKSRC}/image/rlelib.c
diff --git a/misc/magicpoint/distinfo b/misc/magicpoint/distinfo
index 3da0cf58be0d..7636825de3b5 100644
--- a/misc/magicpoint/distinfo
+++ b/misc/magicpoint/distinfo
@@ -1,2 +1,2 @@
-MD5 (magicpoint-1.11a.tar.gz) = 9e55166a7793de371803b0c20f965971
-SIZE (magicpoint-1.11a.tar.gz) = 871606
+MD5 (magicpoint-1.11b.tar.gz) = 2b627f17443842eb5009304864577a4c
+SIZE (magicpoint-1.11b.tar.gz) = 871618
diff --git a/misc/magicpoint/pkg-plist b/misc/magicpoint/pkg-plist
index bfff8de4cf5b..af0d54fad48c 100644
--- a/misc/magicpoint/pkg-plist
+++ b/misc/magicpoint/pkg-plist
@@ -4,6 +4,7 @@ bin/mgpembed
bin/mgpnet
bin/xwintoppm
bin/xmindpath
+lib/X11/doc/html/xmindpath.1.html
lib/X11/mgp/default.mgp
lib/X11/mgp/mgp1.jpg
lib/X11/mgp/mgp2.jpg