summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-22 01:31:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-22 02:15:17 +0000
commit3ecb156887d96971d0d25fda5498fc318800ba03 (patch)
tree22ffa1f918173836c732465693fa9d7c24e5a5be
parent9bd17b2866278d7537e2da877c5a1fd671d152b5 (diff)
downloadfreebsd-ports-3ecb156887d96971d0d25fda5498fc318800ba03.zip
audio/shortwave: add dependency for saving recent songs
$ GST_DEBUG=2 shortwave [...] WARN GST_ELEMENT_FACTORY gstelementfactory.c:462:GstElement *gst_element_factory_make(const gchar *, const gchar *): no such element factory "vorbisenc"! ERROR GST_PIPELINE grammar.y:816:int priv_gst_parse_yyparse(void *, graph_t *): no element "vorbisenc" ERROR GST_PIPELINE grammar.y:901:int priv_gst_parse_yyparse(void *, graph_t *): link has no sink [source=@0x808b72a40] WARN GST_ELEMENT_FACTORY gstelementfactory.c:462:GstElement *gst_element_factory_make(const gchar *, const gchar *): no such element factory "oggmux"! ERROR GST_PIPELINE grammar.y:816:int priv_gst_parse_yyparse(void *, graph_t *): no element "oggmux" ERROR GST_PIPELINE grammar.y:901:int priv_gst_parse_yyparse(void *, graph_t *): link has no source [sink=@0x0] ERROR GST_PIPELINE grammar.y:901:int priv_gst_parse_yyparse(void *, graph_t *): link has no source [sink=@0x815386af0] thread 'main' panicked at 'Unable to create recorderbin: Error { domain: gst_parse_error, code: 1, message: "no element \"vorbisenc\"" }', src/audio/backend/gstreamer_backend.rs:301:84
-rw-r--r--audio/shortwave/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/shortwave/Makefile b/audio/shortwave/Makefile
index 590c7211ff74..eb72be386730 100644
--- a/audio/shortwave/Makefile
+++ b/audio/shortwave/Makefile
@@ -13,7 +13,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus
USES= cargo gettext gnome meson pkgconfig python:build shebangfix sqlite ssl
USE_GITHUB= nodefault
USE_GITLAB= yes
-USE_GSTREAMER1= good libav soup
+USE_GSTREAMER1= good libav soup vorbis
USE_GNOME= gdkpixbuf2 gtk40 libadwaita
GH_TUPLE= gtk-rs:gtk3-rs:1ca4fbcc30ec882f6079f26018c30ef1ceb8a2e2:gtk3 \
gtk-rs:gtk4-rs:534f63e66a2a3883770fe110a8a556a4b40f84b3:gtk4