summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2018-10-07 17:16:23 +0000
committerDimitry Andric <dim@FreeBSD.org>2018-10-07 17:16:23 +0000
commit3decb07d0fd91cf81605228bf8fba25855a459fc (patch)
tree708689cdb955b71017ce401e5e6fdf85ccb78f6d
parenta30f96e1c951bad31499756cbb98e3dbe7961553 (diff)
downloadfreebsd-ports-3decb07d0fd91cf81605228bf8fba25855a459fc.zip
Fix builds of net/samba46 and net/samba47 when using lld 7.0.0.
With lld 7.0.0, the following error is emitted: ld: error: duplicate symbol 'pdb_search_init' in version script This is because the symbol version scripts generated by wscript_build contain both "pdb_search_init" in the global section, and "pdb_*_init" in the local section. Fix it by removing "pdb_*_init" from the local section. For net/samba48, this already got fixed, as a side effect of r478825. Approved by: portmgr (antoine) PR: 230602 MFH: 2018Q4
-rw-r--r--net/samba46/Makefile2
-rw-r--r--net/samba46/files/patch-source3__wscript_build12
-rw-r--r--net/samba47/Makefile2
-rw-r--r--net/samba47/files/patch-source3__wscript_build18
4 files changed, 25 insertions, 9 deletions
diff --git a/net/samba46/Makefile b/net/samba46/Makefile
index c619a4ac2f0c..bb372be17908 100644
--- a/net/samba46/Makefile
+++ b/net/samba46/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}46
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
diff --git a/net/samba46/files/patch-source3__wscript_build b/net/samba46/files/patch-source3__wscript_build
index 61831292bfb4..1e51d37da3b6 100644
--- a/net/samba46/files/patch-source3__wscript_build
+++ b/net/samba46/files/patch-source3__wscript_build
@@ -1,6 +1,14 @@
--- source3/wscript_build.orig 2017-05-23 08:19:23 UTC
+++ source3/wscript_build
-@@ -741,6 +741,7 @@ bld.SAMBA3_LIBRARY('smbd_base',
+@@ -151,7 +151,6 @@ ldapsam_pdb_match = ['!priv2ld', '!smbldap_search_doma
+ '!get_attr_list']
+ private_pdb_match.append('!pdb_nds_*')
+ private_pdb_match.append('!pdb_ldapsam_init*')
+-private_pdb_match.append('!pdb_*_init')
+ private_pdb_match = private_pdb_match + ldapsam_pdb_match
+
+ bld.SAMBA3_LIBRARY('samba-passdb',
+@@ -741,6 +740,7 @@ bld.SAMBA3_LIBRARY('smbd_base',
smbd_conn
param_service
AVAHI
@@ -8,7 +16,7 @@
PRINTBASE
PROFILE
LOCKING
-@@ -1129,6 +1130,7 @@ bld.SAMBA3_BINARY('client/smbclient',
+@@ -1129,6 +1129,7 @@ bld.SAMBA3_BINARY('client/smbclient',
msrpc3
RPC_NDR_SRVSVC
cli_smb_common
diff --git a/net/samba47/Makefile b/net/samba47/Makefile
index 5ca2e0daa67b..ebeb385842d5 100644
--- a/net/samba47/Makefile
+++ b/net/samba47/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ${SAMBA4_BASENAME}47
PORTVERSION= ${SAMBA4_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
diff --git a/net/samba47/files/patch-source3__wscript_build b/net/samba47/files/patch-source3__wscript_build
index 66817d31791e..e81cd49bb223 100644
--- a/net/samba47/files/patch-source3__wscript_build
+++ b/net/samba47/files/patch-source3__wscript_build
@@ -1,6 +1,14 @@
---- source3/wscript_build.orig 2017-07-25 13:09:58 UTC
+--- source3/wscript_build.orig 2018-08-11 19:50:02 UTC
+++ source3/wscript_build
-@@ -240,11 +240,9 @@ bld.SAMBA3_SUBSYSTEM('SMBREGISTRY',
+@@ -143,7 +143,6 @@ ldapsam_pdb_match = ['!priv2ld', '!smbldap_search_doma
+ '!get_attr_list']
+ private_pdb_match.append('!pdb_nds_*')
+ private_pdb_match.append('!pdb_ldapsam_init*')
+-private_pdb_match.append('!pdb_*_init')
+ private_pdb_match = private_pdb_match + ldapsam_pdb_match
+
+ bld.SAMBA3_LIBRARY('samba-passdb',
+@@ -240,11 +239,9 @@ bld.SAMBA3_SUBSYSTEM('SMBREGISTRY',
talloc
replace
util_reg
@@ -13,7 +21,7 @@
''')
# Do not link against this use 'smbconf'
-@@ -509,7 +507,7 @@ bld.SAMBA3_LIBRARY('secrets3',
+@@ -510,7 +507,7 @@ bld.SAMBA3_LIBRARY('secrets3',
bld.SAMBA3_LIBRARY('smbldap',
source='lib/smbldap.c',
@@ -22,7 +30,7 @@
enabled=bld.CONFIG_SET("HAVE_LDAP"),
private_library=False,
abi_directory='lib/ABI',
-@@ -733,6 +731,7 @@ bld.SAMBA3_LIBRARY('smbd_base',
+@@ -734,6 +731,7 @@ bld.SAMBA3_LIBRARY('smbd_base',
smbd_conn
param_service
AVAHI
@@ -30,7 +38,7 @@
PRINTBASE
PROFILE
LOCKING
-@@ -1121,6 +1120,7 @@ bld.SAMBA3_BINARY('client/smbclient',
+@@ -1122,6 +1120,7 @@ bld.SAMBA3_BINARY('client/smbclient',
msrpc3
RPC_NDR_SRVSVC
cli_smb_common