summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-07 13:25:27 +0200
committerFelix Palmen <zirias@FreeBSD.org>2022-09-07 14:14:49 +0200
commit307502b652770970002161d98461d023ecae6df9 (patch)
treedf7491eaad1bb2a68ffabe9006b4e022fbed37bc
parentecd1841331d14ef3fad22458ccb17204a0d7a476 (diff)
downloadfreebsd-ports-307502b652770970002161d98461d023ecae6df9.zip
graphics/drm-kmod: Fix dependency on firmwares
Don't overwrite RUN_DEPENDS, add to it. Also allow all architectures supported by the concrete drm port, and IGNORE otherwise instead of only depending on firmwares. While here, indent .if/.elif/.endif correctly. Approved by: x11 (manu), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36479
-rw-r--r--graphics/drm-kmod/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
index 15a8d9fc0ee1..4ebbc802906a 100644
--- a/graphics/drm-kmod/Makefile
+++ b/graphics/drm-kmod/Makefile
@@ -1,5 +1,6 @@
PORTNAME= drm-kmod
PORTVERSION= 20220907
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= x11@FreeBSD.org
@@ -14,15 +15,18 @@ RUN_DEPENDS= gpu-firmware-kmod>=20220511:graphics/gpu-firmware-kmod
.if ${OPSYS} != FreeBSD
IGNORE= not supported on anything but FreeBSD (missing linuxkpi functionality)
.else
-.if ${ARCH} == "amd64"
-.if ${OSVERSION} < 1300000
-RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-fbsd12.0-kmod
-.elif ${OSVERSION} >= 1301000
-RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-510-kmod
-.else
+. if ${OSVERSION} < 1300000
+RUN_DEPENDS+= ${KMODDIR}/drm.ko:graphics/drm-fbsd12.0-kmod
+_DRM_ARCHS= amd64 i386
+. elif ${OSVERSION} >= 1301000
+RUN_DEPENDS+= ${KMODDIR}/drm.ko:graphics/drm-510-kmod
+_DRM_ARCHS= aarch64 amd64 i386 powerpc64 powerpc64le
+. else
+_DRM_ARCHS=
+. endif
+. if ! ${_DRM_ARCHS:M${ARCH}}
IGNORE= not supported for this configuration
-.endif
-.endif
+. endif
.endif
.include <bsd.port.mk>