summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2010-12-14 16:26:27 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2010-12-14 16:26:27 +0000
commit2d76d7517b67f09a5291124c0ce6f8b5effaa7a6 (patch)
treeaa622c9cba1c72ae0eec73b3c720196b76aac13d
parente3603ffbc3fee7bfae161a6f94b9facf3e1d7e53 (diff)
downloadfreebsd-ports-2d76d7517b67f09a5291124c0ce6f8b5effaa7a6.zip
Fix rc script with _tss USER/GROUP.
[NOTE] In this time, I don't bump PORTREVISION. Because I'll re-setup working directory under $PREFIX (/var/lib/tpm -> $PREFIX/var/lib/tpm). So I'll finish these working, and bump PORTREVISION.
-rw-r--r--emulators/tpm-emulator/Makefile5
-rw-r--r--emulators/tpm-emulator/files/tpmd.in4
2 files changed, 7 insertions, 2 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 59d58bd6c55c..56ffc4161823 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -34,6 +34,11 @@ CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib"
+SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
+
+USERS= _tss
+GROUPS= _tss
+
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/README
diff --git a/emulators/tpm-emulator/files/tpmd.in b/emulators/tpm-emulator/files/tpmd.in
index f497e38757b6..0af8eaeac3e6 100644
--- a/emulators/tpm-emulator/files/tpmd.in
+++ b/emulators/tpm-emulator/files/tpmd.in
@@ -22,8 +22,8 @@ command="%%PREFIX%%/bin/${name}"
load_rc_config $name
tpmd_enable=${tpmd_enable-"NO"}
-tpmd_user=${tpmd_user-"_tss"}
-tpmd_group=${tpmd_group-"_tss"}
+tpmd_user=${tpmd_user-"%%USERS%%"}
+tpmd_group=${tpmd_group-"%%GROUPS%%"}
command_args="-o ${tpmd_user} -g ${tpmd_group}"
unset tpmd_user tpmd_group