summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-22 02:39:51 +0800
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-22 03:20:05 +0800
commit2b049358043d2d2ff93ad5f6ed10cb7d5cbe7172 (patch)
treee0ec5c3c1ca48c564064a714b161eae04afad097
parent83932077cb9012b87adc49410b788d3b57ed2b54 (diff)
downloadfreebsd-ports-2b049358043d2d2ff93ad5f6ed10cb7d5cbe7172.zip
devel/pytype: Update to 2023.2.17
Changes: https://github.com/google/pytype/blob/main/CHANGELOG
-rw-r--r--devel/pytype/Makefile12
-rw-r--r--devel/pytype/distinfo6
-rw-r--r--devel/pytype/files/patch-setup.cfg18
3 files changed, 21 insertions, 15 deletions
diff --git a/devel/pytype/Makefile b/devel/pytype/Makefile
index b5e3153ed1e5..96cf74462fd8 100644
--- a/devel/pytype/Makefile
+++ b/devel/pytype/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pytype
-PORTVERSION= 2022.6.30
+PORTVERSION= 2023.2.17
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
@@ -14,12 +14,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>=0:devel/py-pybind11@${PY_FLAVOR}
RUN_DEPENDS= ninja>=1.10.2:devel/ninja \
${PYTHON_PKGNAMEPREFIX}attrs>=21.4.0:devel/py-attrs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}importlab>=0.7:devel/py-importlab@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}libcst03>=0:devel/py-libcst03@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}importlab>=0.8:devel/py-importlab@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=3.1.2:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libcst>=0.4.9:devel/py-libcst@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>=2.8.5:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydot>=1.4.2:graphics/py-pydot@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tabulate>=0:devel/py-tabulate@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tabulate>=0.8.9:devel/py-tabulate@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0.10.2:textproc/py-toml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.3.0:devel/py-typing-extensions@${PY_FLAVOR}
USES= compiler:c++11-lang python:3.7+
USE_PYTHON= autoplist concurrent distutils
diff --git a/devel/pytype/distinfo b/devel/pytype/distinfo
index 0c01be2d6355..6909de01c625 100644
--- a/devel/pytype/distinfo
+++ b/devel/pytype/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1675190933
-SHA256 (pytype-2022.6.30.tar.gz) = 1c8c425e8bb40117322be06476080d132466fab72e7d199af2de5c55285b6d4f
-SIZE (pytype-2022.6.30.tar.gz) = 2037650
+TIMESTAMP = 1677771015
+SHA256 (pytype-2023.2.17.tar.gz) = 18b61a630c9eba9d8716fce21f280666ac28a0909af7a796c9b2c1dc97337ce6
+SIZE (pytype-2023.2.17.tar.gz) = 2237000
diff --git a/devel/pytype/files/patch-setup.cfg b/devel/pytype/files/patch-setup.cfg
index 22499509e8ab..b6c46cfed910 100644
--- a/devel/pytype/files/patch-setup.cfg
+++ b/devel/pytype/files/patch-setup.cfg
@@ -1,11 +1,15 @@
---- setup.cfg.orig 2022-06-30 19:54:29 UTC
+--- setup.cfg.orig 2023-02-17 23:14:02 UTC
+++ setup.cfg
-@@ -33,7 +33,7 @@ install_requires =
- attrs>=21.4.0
- importlab>=0.7
- libcst
+@@ -34,10 +34,10 @@ install_requires =
+ importlab>=0.8
+ jinja2>=3.1.2
+ libcst>=0.4.9
- networkx<2.8.4
+ networkx>=2.8.5
ninja>=1.10.0.post2
- pydot
- tabulate
+ pydot>=1.4.2
+- tabulate>=0.8.10
++ tabulate>=0.8.9
+ toml>=0.10.2
+ typed_ast>=1.5.0; python_version < '3.8'
+ typing-extensions>=4.3.0