summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-12 00:05:19 +0800
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-12 00:05:36 +0800
commit2920ddff74980fdebe12c0ff4d48b067c2e5ebe9 (patch)
tree369cc2ba03872268133329cf192af6801ec35ba1
parent04b9c4ec8c5540556725fcdbc2adf280a1eaa4f1 (diff)
downloadfreebsd-ports-2920ddff74980fdebe12c0ff4d48b067c2e5ebe9.zip
mail/py-pyspf: Fix runtime on IPv6
- Bump PORTREVISION for package change % spf.py 2610:1c1:1:606c::50:15 FreeBSD.org localhost /usr/local/bin/spf.py:131: DeprecationWarning: please use dns.resolver.resolve() instead answers = dns.resolver.query(name, qtype, lifetime=timeout) result: ('softfail', 250, 'domain owner discourages use of this host') ~all PR: 268030 Submitted by: <takefu@airport.fm>
-rw-r--r--mail/py-pyspf/Makefile1
-rw-r--r--mail/py-pyspf/files/patch-spf.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/py-pyspf/Makefile b/mail/py-pyspf/Makefile
index cdf8ca429d45..48fb26625686 100644
--- a/mail/py-pyspf/Makefile
+++ b/mail/py-pyspf/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pyspf
PORTVERSION= 2.0.14
+PORTREVISION= 1
CATEGORIES= mail python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/mail/py-pyspf/files/patch-spf.py b/mail/py-pyspf/files/patch-spf.py
new file mode 100644
index 000000000000..2ce960adfed7
--- /dev/null
+++ b/mail/py-pyspf/files/patch-spf.py
@@ -0,0 +1,11 @@
+--- spf.py.orig 2020-01-01 21:02:26 UTC
++++ spf.py
+@@ -128,7 +128,7 @@ def DNSLookup_dnspython(name, qtype, tcpfallback=True,
+ retVal = []
+ try:
+ # FIXME: how to disable TCP fallback in dnspython if not tcpfallback?
+- answers = dns.resolver.query(name, qtype, lifetime=timeout)
++ answers = dns.resolver.resolve(name, qtype)
+ for rdata in answers:
+ if qtype == 'A' or qtype == 'AAAA':
+ retVal.append(((name, qtype), rdata.address))