summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-11-01 19:43:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-11-01 19:43:41 +0000
commit213ffde6a0419970866e2c9134d42569e284795f (patch)
tree6102ea9fdf4b1d9187f3bd5d0d86948566fccbe9
parentdc71fc46401dc817d426f81436b95d9ddcd7befd (diff)
downloadfreebsd-ports-213ffde6a0419970866e2c9134d42569e284795f.zip
Library providing a source-level compatibility layer to aid porting
programs that use OpenSSL to use the NSS instead. WWW: http://rcritten.fedorapeople.org/nss_compat_ossl.html
-rw-r--r--security/Makefile1
-rw-r--r--security/nss_compat_ossl/Makefile19
-rw-r--r--security/nss_compat_ossl/distinfo2
-rw-r--r--security/nss_compat_ossl/files/patch-src_ssl.c23
-rw-r--r--security/nss_compat_ossl/pkg-descr4
-rw-r--r--security/nss_compat_ossl/pkg-plist5
6 files changed, 54 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 646abedd06eb..4e73c2fa9831 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -347,6 +347,7 @@
SUBDIR += nmap
SUBDIR += nmapsi4
SUBDIR += nss
+ SUBDIR += nss_compat_ossl
SUBDIR += oath-toolkit
SUBDIR += obfsclient
SUBDIR += obfsproxy
diff --git a/security/nss_compat_ossl/Makefile b/security/nss_compat_ossl/Makefile
new file mode 100644
index 000000000000..597254b120fc
--- /dev/null
+++ b/security/nss_compat_ossl/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+PORTNAME= nss_compat_ossl
+PORTVERSION= 0.9.6
+MASTER_SITES= http://rcritten.fedorapeople.org/
+CATEGORIES= security devel
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Source-level compatibility library for OpenSSL to NSS porting
+
+GNU_CONFIGURE= yes
+USES= pkgconfig libtool
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/nss/libssl3.so:${PORTSDIR}/security/nss
+RUN_DEPENDS= ${LOCALBASE}/lib/nss/libssl3.so:${PORTSDIR}/security/nss
+LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
+
+.include <bsd.port.mk>
diff --git a/security/nss_compat_ossl/distinfo b/security/nss_compat_ossl/distinfo
new file mode 100644
index 000000000000..6efa9252b30e
--- /dev/null
+++ b/security/nss_compat_ossl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nss_compat_ossl-0.9.6.tar.gz) = f2528e9f4f9444503d046408f4b9bc4cf7ea3296644016fff6387a79b5e19af9
+SIZE (nss_compat_ossl-0.9.6.tar.gz) = 340628
diff --git a/security/nss_compat_ossl/files/patch-src_ssl.c b/security/nss_compat_ossl/files/patch-src_ssl.c
new file mode 100644
index 000000000000..155f55ccff99
--- /dev/null
+++ b/security/nss_compat_ossl/files/patch-src_ssl.c
@@ -0,0 +1,23 @@
+Index: src/ssl.c
+===================================================================
+--- src/ssl.c (revision 76)
++++ src/ssl.c (working copy)
+@@ -1754,12 +1754,13 @@
+ if (SSL_OptionSet(s, SSL_HANDSHAKE_AS_SERVER, server) != SECSuccess)
+ goto error;
+
+- if (SSL_OptionSet(s, SSL_ENABLE_SSL2, ssl2) != SECSuccess)
+- goto error;
++ /* Don't fail if enabling SSL2 options doesn't succeed as it may
++ * be disabled in NSS. So just ignore the return value from
++ * SSL_OptionSet().
++ */
++ SSL_OptionSet(s, SSL_ENABLE_SSL2, ssl2);
++ SSL_OptionSet(s, SSL_V2_COMPATIBLE_HELLO, ssl2);
+
+- if (SSL_OptionSet(s, SSL_V2_COMPATIBLE_HELLO, ssl2) != SECSuccess)
+- goto error;
+-
+ if (SSL_OptionSet(s, SSL_ENABLE_SSL3, ssl3) != SECSuccess)
+ goto error;
+
diff --git a/security/nss_compat_ossl/pkg-descr b/security/nss_compat_ossl/pkg-descr
new file mode 100644
index 000000000000..be872b3510f8
--- /dev/null
+++ b/security/nss_compat_ossl/pkg-descr
@@ -0,0 +1,4 @@
+Library providing a source-level compatibility layer to aid porting
+programs that use OpenSSL to use the NSS instead.
+
+WWW: http://rcritten.fedorapeople.org/nss_compat_ossl.html
diff --git a/security/nss_compat_ossl/pkg-plist b/security/nss_compat_ossl/pkg-plist
new file mode 100644
index 000000000000..a40005b88824
--- /dev/null
+++ b/security/nss_compat_ossl/pkg-plist
@@ -0,0 +1,5 @@
+include/nss_compat_ossl/nss_compat_ossl.h
+lib/libnss_compat_ossl.a
+lib/libnss_compat_ossl.so
+lib/libnss_compat_ossl.so.0
+lib/libnss_compat_ossl.so.0.0.0