summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-10 13:37:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-10 13:37:46 +0000
commit1684df65a7f4271a0ebde980f486ef2a7c51d0eb (patch)
tree442f09a620cb8c446112c78c33e704e8dc010445
parentc13257163e8eb33677f798beccba13178179aa33 (diff)
downloadfreebsd-ports-1684df65a7f4271a0ebde980f486ef2a7c51d0eb.zip
Improve bitness detection in the configure script (use the fact that all
64-bit architectures supported by FreeBSD have that ``64'' suffix in the machine processor architecture reported by ``uname -p'') and tentatively unbreak the port, well, everywhere. While here, remove outdated and now useless, no-op fixups for the configure script. Tested on: i386, amd64, powerpc, sparc64
-rw-r--r--lang/rexx-regina/Makefile17
-rw-r--r--lang/rexx-regina/files/patch-configure27
2 files changed, 19 insertions, 25 deletions
diff --git a/lang/rexx-regina/Makefile b/lang/rexx-regina/Makefile
index 1652788df86d..2e04f0fad04f 100644
--- a/lang/rexx-regina/Makefile
+++ b/lang/rexx-regina/Makefile
@@ -18,14 +18,6 @@ COMMENT= Rexx interpreter
LICENSE= LGPL21+
-BROKEN_aarch64= Does not build: error: expected expression
-BROKEN_armv6= Does not build: error: expected expression
-BROKEN_armv7= Does not build: error: expected expression
-BROKEN_mips= Does not build: error: expected expression
-BROKEN_mips64= Does not build: error: expected expression
-BROKEN_powerpc64= Does not build: error: expected expression
-BROKEN_sparc64= Does not build: error: expected expression
-
USES= gmake iconv ncurses
USE_RC_SUBR= rxstack
GNU_CONFIGURE= yes
@@ -44,21 +36,12 @@ OPTIONS_DEFINE= DOCS EXAMPLES
DOCS_DISTFILES= regina.pdf:docs \
regutil.pdf:docs
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == i386 || ${ARCH} == powerpc
-CONFIGURE_ARGS+= --enable-32bit
-.endif
-
post-extract-DOCS-on:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/regina.pdf ${WRKDIR}
@${CP} ${DISTDIR}/${DIST_SUBDIR}/regutil.pdf ${WRKDIR}
post-patch:
@${REINPLACE_CMD} -e \
- '/$${CFLAGS}/s|^|#| ; \
- s|"-lpthread"|"-pthread"|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
'/^examplesdir/s|=.*|= $$(datadir)/examples/$$(PACKAGE)| ; \
/$$(sysconfdir)/s|^|#|' ${WRKSRC}/Makefile.in
diff --git a/lang/rexx-regina/files/patch-configure b/lang/rexx-regina/files/patch-configure
index e251c3fd5bed..363900831575 100644
--- a/lang/rexx-regina/files/patch-configure
+++ b/lang/rexx-regina/files/patch-configure
@@ -1,20 +1,31 @@
--- configure.orig 2015-01-18 20:33:40 UTC
+++ configure
-@@ -3490,6 +3490,13 @@ case "$target" in
+@@ -3490,13 +3490,22 @@ case "$target" in
osis64bit=yes
fi
;;
+- *-freebsd* | *-openbsd*)
+ *-dragonfly*)
-+ mach="`uname -m`"
+ mach="`uname -m`"
+- if test "$mach" = "amd64"; then
+ if test "$mach" = "x86_64"; then
+ bitflag="64"
+ osis64bit=yes
+ fi
+ ;;
++ *-freebsd* | *-openbsd*)
++ mach="`uname -p`"
++ if test "${mach%64}" = "$mach"; then
++ bitflag="32"
++ else
+ bitflag="64"
+ osis64bit=yes
+ fi
+ ;;
- *-freebsd* | *-openbsd*)
- mach="`uname -m`"
- if test "$mach" = "amd64"; then
-@@ -6256,6 +6263,10 @@ rm -f core conftest.err conftest.$ac_obj
+ *nto-qnx*)
+ ;;
+ *qnx*)
+@@ -6256,6 +6265,10 @@ rm -f core conftest.err conftest.$ac_objext \
;;
*linux*)
;;
@@ -25,7 +36,7 @@
*freebsd*)
THREADING_COMPILE="-pthread -D_REENTRANT -DPOSIX -DREGINA_REENTRANT"
THREADING_LINK="-pthread"
-@@ -8679,7 +8690,14 @@ case "$target" in
+@@ -8679,7 +8692,14 @@ case "$target" in
SHLPRE="lib"
SHL_LD="ld -assert pure-text -o ${SHLPRE}${SHLFILE}${SHLPST} "'$('SHOFILES')'
;;
@@ -41,7 +52,7 @@
if test "$ac_cv_prog_CC" = "gcc" -o "$ac_cv_prog_CC" = "g++" -o "$ac_cv_prog_CC" = "clang"; then
LD_RXLIB_A1="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
LD_RXLIB_A2="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
-@@ -9429,7 +9447,7 @@ $as_echo_n "checking OS distribution nam
+@@ -9429,7 +9449,7 @@ $as_echo_n "checking OS distribution name... " >&6; }
$as_echo "$MYDISTRO" >&6; }
else
case "$target" in