summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:03:34 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:03:34 +0000
commit07e8e1c13cabb968ffd985d9af1a2ddc2c02498c (patch)
tree54e77937cbaf0fed5fc185aca36b2d9a346a79b5
parentd9df28a9ce4a22ff2fea480fbf9fbd24276897dd (diff)
downloadfreebsd-ports-07e8e1c13cabb968ffd985d9af1a2ddc2c02498c.zip
Add USES=xorg USES=gl, ports categories j
Add USES=xorg and USES=gl to ports in categories starting with 'j' While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
-rw-r--r--japanese/kdrill/Makefile2
-rw-r--r--japanese/kinput2/Makefile2
-rw-r--r--japanese/kterm/Makefile2
-rw-r--r--japanese/mozc-server/Makefile2
-rw-r--r--japanese/nethack34/Makefile1
-rw-r--r--japanese/skkinput/Makefile2
-rw-r--r--japanese/skkinput3/Makefile2
-rw-r--r--japanese/tgif/Makefile1
-rw-r--r--java/icedtea-web/Makefile4
-rw-r--r--java/java3d/Makefile2
-rw-r--r--java/openjdk11/Makefile2
-rw-r--r--java/openjdk12/Makefile2
-rw-r--r--java/openjdk13/Makefile2
-rw-r--r--java/sablevm-classpath/Makefile3
14 files changed, 16 insertions, 13 deletions
diff --git a/japanese/kdrill/Makefile b/japanese/kdrill/Makefile
index cf11878cee87..fcbdb95466b7 100644
--- a/japanese/kdrill/Makefile
+++ b/japanese/kdrill/Makefile
@@ -12,7 +12,7 @@ COMMENT= Program to quiz you on the meanings of Kanji
RUN_DEPENDS= xjdic:japanese/edict
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt
DATADIR= ${PREFIX}/share/dict/kdrill
diff --git a/japanese/kinput2/Makefile b/japanese/kinput2/Makefile
index 336766b07200..993fc70b5ecb 100644
--- a/japanese/kinput2/Makefile
+++ b/japanese/kinput2/Makefile
@@ -13,7 +13,7 @@ COMMENT= Japanese text input server for X11 applications
MAKE_JOBS_UNSAFE= yes
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt
SUB_FILES= Kinput2.conf
PLIST_FILES= bin/kinput2 lib/X11/app-defaults/Kinput2 man/man1/kinput2.1.gz
diff --git a/japanese/kterm/Makefile b/japanese/kterm/Makefile
index 36ded19331ef..0715a00527db 100644
--- a/japanese/kterm/Makefile
+++ b/japanese/kterm/Makefile
@@ -17,7 +17,7 @@ LICENSE= MIT
BUILD_DEPENDS= nkf:japanese/nkf
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt
USE_GITHUB= yes
GH_ACCOUNT= hrs-allbsd
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 1c323f7f8888..ca106d14d016 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -49,7 +49,7 @@ USES+= qt:5 gnome
USE_GNOME= glib20 gtk20
USE_QT= buildtools core gui widgets
.elif ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc"
-USES+= gettext-runtime gnome
+USES+= gettext-runtime gnome xorg
USE_XORG= xcb
USE_GNOME= cairo gdkpixbuf2 glib20 gtk20
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
diff --git a/japanese/nethack34/Makefile b/japanese/nethack34/Makefile
index 9f85a6684c2e..edc99e7f10c5 100644
--- a/japanese/nethack34/Makefile
+++ b/japanese/nethack34/Makefile
@@ -40,6 +40,7 @@ SHELL_DESC= Shell support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
+USES+= xorg
USE_XORG= xaw xpm
GRAPHICS= X11_GRAPHICS
.endif
diff --git a/japanese/skkinput/Makefile b/japanese/skkinput/Makefile
index 1dd3fe8e932d..d2347c46fbbf 100644
--- a/japanese/skkinput/Makefile
+++ b/japanese/skkinput/Makefile
@@ -12,7 +12,7 @@ COMMENT= SKK-like Japanese input method for X11
LICENSE= GPLv2
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xext xt xmu
PLIST_FILES= bin/skkinput lib/X11/app-defaults/Skkinput \
diff --git a/japanese/skkinput3/Makefile b/japanese/skkinput3/Makefile
index f7ae1f741449..220a50ab00d0 100644
--- a/japanese/skkinput3/Makefile
+++ b/japanese/skkinput3/Makefile
@@ -11,7 +11,7 @@ DISTNAME= skkinput-${PORTVERSION}
MAINTAINER= koma2@lovepeers.org
COMMENT= SKK-like Japanese input method for X11
-USES= imake
+USES= imake xorg
USE_GCC= any
USE_CSTD= gnu89
USE_XORG= ice sm x11 xext xmu xt
diff --git a/japanese/tgif/Makefile b/japanese/tgif/Makefile
index 6a3ce1d7aa0d..38c41dce1979 100644
--- a/japanese/tgif/Makefile
+++ b/japanese/tgif/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= tgif:graphics/tgif \
NO_BUILD= yes
NO_WRKSUBDIR= yes
+USES= xorg
USE_XORG= x11
PLIST_SUB= XAPPLRESDIR=${XAPPLRESDIR}
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 9e7fb7b74d69..d1ae06a64787 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -26,7 +26,7 @@ JAVA_OS= native
JAVA_VENDOR= openjdk
USE_PERL5= build
USE_XORG= x11
-USES= desktop-file-utils gmake perl5 pkgconfig shebangfix
+USES= desktop-file-utils gmake perl5 pkgconfig shebangfix xorg
SHEBANG_FILES= jrunscript.in launcher/launchers.in
CONFIGURE_ARGS= --with-hamcrest="${HAMCREST_JAR}"
@@ -72,7 +72,7 @@ PLUGIN_MASTER_SITES= LOCAL/tobik:npapi
PLUGIN_PORTDOCS= plugin
PLUGIN_TEST_TARGET= plugin-tests
PLUGIN_USE= GNOME=glib20
-PLUGIN_USES= webplugin:native
+PLUGIN_USES= webplugin:native gnome
PLUGIN_VARS= WEBPLUGIN_DIR=${PREFIX}/lib \
WEBPLUGIN_FILES=IcedTeaPlugin.so
diff --git a/java/java3d/Makefile b/java/java3d/Makefile
index 33035fab57c5..54245cab2607 100644
--- a/java/java3d/Makefile
+++ b/java/java3d/Makefile
@@ -17,7 +17,7 @@ BROKEN_aarch64= fails to compile: GVector.java:168: bad use of '>'
BROKEN_armv6= fails to compile: build.xml: Compile failed; see the compiler error output for details
BROKEN_armv7= fails to compile: build.xml: Compile failed; see the compiler error output for details
-USES= gl tar:bzip2
+USES= gl tar:bzip2 xorg
USE_JAVA= yes
USE_GL= gl
USE_XORG= xt
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index 4cc0d996d91b..676578ba1a72 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpng.so:graphics/png
RUN_DEPENDS= javavm:java/javavmwrapper
-USES= compiler:features gmake iconv jpeg pkgconfig
+USES= compiler:features gmake iconv jpeg pkgconfig xorg
USE_XORG= x11 xext xi xrandr xrender xt xtst
USE_GITHUB= yes
diff --git a/java/openjdk12/Makefile b/java/openjdk12/Makefile
index a6795d2eb15b..8b87e603b25c 100644
--- a/java/openjdk12/Makefile
+++ b/java/openjdk12/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpng.so:graphics/png
RUN_DEPENDS= javavm:java/javavmwrapper
-USES= compiler:features gmake iconv jpeg pkgconfig
+USES= compiler:features gmake iconv jpeg pkgconfig xorg
USE_XORG= x11 xext xi xrandr xrender xt xtst
USE_GITHUB= yes
diff --git a/java/openjdk13/Makefile b/java/openjdk13/Makefile
index ffb6ff77c87c..999af1e9fff9 100644
--- a/java/openjdk13/Makefile
+++ b/java/openjdk13/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpng.so:graphics/png
RUN_DEPENDS= javavm:java/javavmwrapper
-USES= compiler:features gmake iconv jpeg pkgconfig
+USES= compiler:features gmake iconv jpeg pkgconfig xorg
USE_XORG= x11 xext xi xrandr xrender xt xtst
USE_GITHUB= yes
diff --git a/java/sablevm-classpath/Makefile b/java/sablevm-classpath/Makefile
index ec14f9a8fa17..adfd86485e90 100644
--- a/java/sablevm-classpath/Makefile
+++ b/java/sablevm-classpath/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= jikes:java/jikes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pkgconfig
+USES= gmake libtool pkgconfig xorg
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
USE_XORG= x11 ice xtst sm
@@ -35,6 +35,7 @@ ZIP_DESC= Compress class library
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
+USES+= gnome
USE_GNOME+= gtk20
PLIST_SUB+= GTK2=""
.if ${PORT_OPTIONS:MCAIRO}