summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-10-12 19:04:20 -0700
committerCy Schubert <cy@FreeBSD.org>2023-10-13 06:21:05 -0700
commit05c229e187e0dd8d812db2ebb10f74ca1c423efc (patch)
tree2bac1c48169a44b27d01fb4854e7a3ff6c316c05
parenta475e0d213f97fa5efab602e7e5680801be04411 (diff)
downloadfreebsd-ports-05c229e187e0dd8d812db2ebb10f74ca1c423efc.zip
dns/unbound: Fix loop when ENOBUFS is returned
- Fix send of udp retries when ENOBUFS is returned. It stops looping and also waits for the condition to go away. Reported to upstream by Florian Obser. PR: 274352, 274446 Approved by: jaap@NLnetLabs.nl (maintainer) MFH: 2023Q4
-rw-r--r--dns/unbound/Makefile1
-rw-r--r--dns/unbound/files/patch-netevent.c159
2 files changed, 160 insertions, 0 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 7697561bdef2..b3ba87493a1e 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -1,5 +1,6 @@
PORTNAME= unbound
DISTVERSION= 1.18.0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= https://www.nlnetlabs.nl/downloads/unbound/
diff --git a/dns/unbound/files/patch-netevent.c b/dns/unbound/files/patch-netevent.c
new file mode 100644
index 000000000000..e94ab49defa1
--- /dev/null
+++ b/dns/unbound/files/patch-netevent.c
@@ -0,0 +1,159 @@
+--- util/netevent.c.orig 2023-08-30 01:01:13.000000000 -0700
++++ util/netevent.c 2023-10-12 19:00:53.157995000 -0700
+@@ -116,6 +116,8 @@
+
+ /** timeout in millisec to wait for write to unblock, packets dropped after.*/
+ #define SEND_BLOCKED_WAIT_TIMEOUT 200
++/** max number of times to wait for write to unblock, packets dropped after.*/
++#define SEND_BLOCKED_MAX_RETRY 5
+
+ /** Let's make timestamping code cleaner and redefine SO_TIMESTAMP* */
+ #ifndef SO_TIMESTAMP
+@@ -402,9 +404,10 @@
+ WSAGetLastError() == WSAENOBUFS ||
+ WSAGetLastError() == WSAEWOULDBLOCK) {
+ #endif
++ int retries = 0;
+ /* if we set the fd blocking, other threads suddenly
+ * have a blocking fd that they operate on */
+- while(sent == -1 && (
++ while(sent == -1 && retries < SEND_BLOCKED_MAX_RETRY && (
+ #ifndef USE_WINSOCK
+ errno == EAGAIN || errno == EINTR ||
+ # ifdef EWOULDBLOCK
+@@ -419,6 +422,13 @@
+ #endif
+ )) {
+ #if defined(HAVE_POLL) || defined(USE_WINSOCK)
++ int send_nobufs = (
++#ifndef USE_WINSOCK
++ errno == ENOBUFS
++#else
++ WSAGetLastError() == WSAENOBUFS
++#endif
++ );
+ struct pollfd p;
+ int pret;
+ memset(&p, 0, sizeof(p));
+@@ -457,8 +467,48 @@
+ log_err("poll udp out failed: %s",
+ sock_strerror(errno));
+ return 0;
++ } else if((pret < 0 &&
++#ifndef USE_WINSOCK
++ errno == ENOBUFS
++#else
++ WSAGetLastError() == WSAENOBUFS
++#endif
++ ) || (send_nobufs && retries > 0)) {
++ /* ENOBUFS, and poll returned without
++ * a timeout. Or the retried send call
++ * returned ENOBUFS. It is good to
++ * wait a bit for the error to clear. */
++ /* The timeout is 20*(2^(retries+1)),
++ * it increases exponentially, starting
++ * at 40 msec. After 5 tries, 1240 msec
++ * have passed in total, when poll
++ * returned the error, and 1200 msec
++ * when send returned the errors. */
++#ifndef USE_WINSOCK
++ pret = poll(NULL, 0, (SEND_BLOCKED_WAIT_TIMEOUT/10)<<(retries+1));
++#else
++ pret = WSAPoll(NULL, 0, (SEND_BLOCKED_WAIT_TIMEOUT/10)<<(retries+1));
++#endif
++ if(pret < 0 &&
++#ifndef USE_WINSOCK
++ errno != EAGAIN && errno != EINTR &&
++# ifdef EWOULDBLOCK
++ errno != EWOULDBLOCK &&
++# endif
++ errno != ENOBUFS
++#else
++ WSAGetLastError() != WSAEINPROGRESS &&
++ WSAGetLastError() != WSAEINTR &&
++ WSAGetLastError() != WSAENOBUFS &&
++ WSAGetLastError() != WSAEWOULDBLOCK
++#endif
++ ) {
++ log_err("poll udp out timer failed: %s",
++ sock_strerror(errno));
++ }
+ }
+ #endif /* defined(HAVE_POLL) || defined(USE_WINSOCK) */
++ retries++;
+ if (!is_connected) {
+ sent = sendto(c->fd, (void*)sldns_buffer_begin(packet),
+ sldns_buffer_remaining(packet), 0,
+@@ -665,7 +715,8 @@
+ WSAGetLastError() == WSAENOBUFS ||
+ WSAGetLastError() == WSAEWOULDBLOCK) {
+ #endif
+- while(sent == -1 && (
++ int retries = 0;
++ while(sent == -1 && retries < SEND_BLOCKED_MAX_RETRY && (
+ #ifndef USE_WINSOCK
+ errno == EAGAIN || errno == EINTR ||
+ # ifdef EWOULDBLOCK
+@@ -680,6 +731,13 @@
+ #endif
+ )) {
+ #if defined(HAVE_POLL) || defined(USE_WINSOCK)
++ int send_nobufs = (
++#ifndef USE_WINSOCK
++ errno == ENOBUFS
++#else
++ WSAGetLastError() == WSAENOBUFS
++#endif
++ );
+ struct pollfd p;
+ int pret;
+ memset(&p, 0, sizeof(p));
+@@ -718,8 +776,48 @@
+ log_err("poll udp out failed: %s",
+ sock_strerror(errno));
+ return 0;
++ } else if((pret < 0 &&
++#ifndef USE_WINSOCK
++ errno == ENOBUFS
++#else
++ WSAGetLastError() == WSAENOBUFS
++#endif
++ ) || (send_nobufs && retries > 0)) {
++ /* ENOBUFS, and poll returned without
++ * a timeout. Or the retried send call
++ * returned ENOBUFS. It is good to
++ * wait a bit for the error to clear. */
++ /* The timeout is 20*(2^(retries+1)),
++ * it increases exponentially, starting
++ * at 40 msec. After 5 tries, 1240 msec
++ * have passed in total, when poll
++ * returned the error, and 1200 msec
++ * when send returned the errors. */
++#ifndef USE_WINSOCK
++ pret = poll(NULL, 0, (SEND_BLOCKED_WAIT_TIMEOUT/10)<<(retries+1));
++#else
++ pret = WSAPoll(NULL, 0, (SEND_BLOCKED_WAIT_TIMEOUT/10)<<(retries+1));
++#endif
++ if(pret < 0 &&
++#ifndef USE_WINSOCK
++ errno != EAGAIN && errno != EINTR &&
++# ifdef EWOULDBLOCK
++ errno != EWOULDBLOCK &&
++# endif
++ errno != ENOBUFS
++#else
++ WSAGetLastError() != WSAEINPROGRESS &&
++ WSAGetLastError() != WSAEINTR &&
++ WSAGetLastError() != WSAENOBUFS &&
++ WSAGetLastError() != WSAEWOULDBLOCK
++#endif
++ ) {
++ log_err("poll udp out timer failed: %s",
++ sock_strerror(errno));
++ }
+ }
+ #endif /* defined(HAVE_POLL) || defined(USE_WINSOCK) */
++ retries++;
+ sent = sendmsg(c->fd, &msg, 0);
+ }
+ }