summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTobias Brox <tobixen@gmail.com>2014-03-10 20:25:35 +0100
committerTobias Brox <tobixen@gmail.com>2014-03-10 20:25:35 +0100
commite4d3a2f5682fb61198959749fb096cccc8087c46 (patch)
treef9320e7430b03b24a808dd927c347838a281783a /setup.py
parentc81d99fb5b2c59f07894817953ac4b9f43d75c7b (diff)
downloadcalendar-cli-e4d3a2f5682fb61198959749fb096cccc8087c46.zip
dependencies
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 3 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 9fecdd9..659e859 100644
--- a/setup.py
+++ b/setup.py
@@ -31,22 +31,10 @@ setup(
"Topic :: Software Development :: Libraries :: Python Modules",
],
scripts=['calendar-cli.py'],
- dependency_links = [
- # The package doesn't seem to be on pypi.
- # We assume a low version number in case it gets uploaded
- # so that the higher version is chosen over the git version
- #
- # There is a mirror here:
- 'https://github.com/skarra/CalDAVClientLibrary/tarball/master#egg=caldavclientlibrary-0.0.1',
- 'git+https://github.com/skarra/CalDAVClientLibrary.git#egg=caldavclientlibrary-0.0.1',
- # We should prefer the official SVN
- 'svn+http://svn.calendarserver.org/repository/calendarserver/CalDAVClientLibrary/trunk#egg=caldavclientlibrary-0.0.2',
- # But there is an issue with the upstream setup.py, it does not have a name=''
- # So we load the patched version
- 'git+https://github.com/muelli/CalDAVClientLibrary.git#egg=caldavclientlibrary-0.0.3',
- ],
install_requires=[
'icalendar',
- 'caldavclientlibrary',
+ 'caldav>=0.2',
+ 'pytz',
+ 'tzlocal'
],
)