summaryrefslogtreecommitdiff
path: root/libssh2-sys/Cargo.toml
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2020-08-18 15:55:14 -0700
committerGitHub <noreply@github.com>2020-08-18 17:55:14 -0500
commitd2ef03fe63ba44b0a64e2469ca20c99d6e4ed71d (patch)
tree34983ee3033fc7c7f243ff1ce78cb340e58bcf8a /libssh2-sys/Cargo.toml
parent5fe0a8cd26aa001209e1fbc99e1ecc48a9b18d61 (diff)
downloadssh2-rs-d2ef03fe63ba44b0a64e2469ca20c99d6e4ed71d.zip
libssh2-sys: Add support for zlib-ng (#197)
Update to libz-sys 1.1.0, which supports zlib-ng. Provide a feature zlib-ng-compat to allow building with zlib-ng. Since doing so statically links zlib-ng, ensure that this feature prevents using a system libssh2.
Diffstat (limited to 'libssh2-sys/Cargo.toml')
-rw-r--r--libssh2-sys/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/libssh2-sys/Cargo.toml b/libssh2-sys/Cargo.toml
index 2bffdba..408d6b0 100644
--- a/libssh2-sys/Cargo.toml
+++ b/libssh2-sys/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "libssh2-sys"
-version = "0.2.18"
+version = "0.2.19"
authors = ["Alex Crichton <alex@alexcrichton.com>", "Wez Furlong <wez@wezfurlong.org>"]
links = "ssh2"
build = "build.rs"
@@ -15,10 +15,11 @@ path = "lib.rs"
[features]
vendored-openssl = ["openssl-sys/vendored"]
+zlib-ng-compat = ["libz-sys/zlib-ng"]
[dependencies]
-libz-sys = "1.0.21"
libc = "0.2"
+libz-sys = { version = "1.1.0", default-features = false, features = ["libc"] }
[target."cfg(unix)".dependencies]
openssl-sys = "0.9.35"