summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2023-02-24 20:21:53 +0200
committerJelle Raaijmakers <jelle@gmta.nl>2023-06-04 21:32:34 +0200
commit8f21420a1ded33cd305ce110b2a2fe819e06f620 (patch)
treee2400c8e1037cad9950bba7a5cad8680f2f547b5 /Kernel/CMakeLists.txt
parentc9a34cae663251b6ca7e311478ea46789985439f (diff)
downloadserenity-8f21420a1ded33cd305ce110b2a2fe819e06f620.zip
Kernel: Move all boot-related code to the new Boot subdirectory
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 4c57831f21..a8c6c691bd 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -19,6 +19,7 @@ set(KERNEL_SOURCES
Arch/init.cpp
Arch/PageFault.cpp
Arch/DeferredCallPool.cpp
+ Boot/CommandLine.cpp
Bus/PCI/Controller/HostController.cpp
Bus/PCI/Controller/MemoryBackedHostBridge.cpp
Bus/PCI/Controller/VolumeManagementDevice.cpp
@@ -40,7 +41,6 @@ set(KERNEL_SOURCES
Bus/VirtIO/Device.cpp
Bus/VirtIO/Queue.cpp
Bus/VirtIO/RNG.cpp
- CommandLine.cpp
Devices/AsyncDeviceRequest.cpp
Devices/Audio/AC97.cpp
Devices/Audio/Channel.cpp