summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <akaster@serenityos.org>2022-01-03 02:50:55 -0700
committerBrian Gianforcaro <b.gianfo@gmail.com>2022-01-04 07:51:31 +0000
commitd809637023296924c197bb869497cedf9da8db0e (patch)
tree8ad6103fa61a2ed32ff65e9cb03f43d759653aa1 /CMakeLists.txt
parenta103a85ae6fc9a6296da22fcda4685fa5db700d7 (diff)
downloadserenity-d809637023296924c197bb869497cedf9da8db0e.zip
Userland: Resolve tautological-constant-out-of-range-compare warnings
Stop comparing platform-specific sized integer types to max() values of other interger types. Enable the warning everywhere.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c13259290..99464d9f4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,7 +199,6 @@ elseif (CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
add_compile_options(-Wno-atomic-alignment)
add_compile_options(-Wno-implicit-const-int-float-conversion)
add_compile_options(-Wno-null-pointer-subtraction)
- add_compile_options(-Wno-tautological-constant-out-of-range-compare)
add_compile_options(-Wno-unneeded-internal-declaration)
add_compile_options(-Wno-unused-but-set-variable)
add_compile_options(-Wno-unused-const-variable)