summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <akaster@serenityos.org>2022-01-03 01:34:29 -0700
committerBrian Gianforcaro <b.gianfo@gmail.com>2022-01-04 07:51:31 +0000
commitc8cfd6661adbf37e34f1b629e2baf641ec7cb8ee (patch)
tree4be9bb52ed2fc71010106996a4211b4570a2d272 /CMakeLists.txt
parented3cb888985d95be8967f41f9e604f280fcc9496 (diff)
downloadserenity-c8cfd6661adbf37e34f1b629e2baf641ec7cb8ee.zip
Userland: Resolve -Woverloaded-virtual in LibGUI and SoundPlayer
Enable the warning project-wide. It catches when a non-virtual method creates an overload set with a virtual method. This might cause surprising overload resolution depending on how the method is invoked.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 751ef11105..69d9bd7559 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,7 +195,6 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
add_compile_options(-Wcast-align)
add_compile_options(-Wdouble-promotion)
elseif (CMAKE_CXX_COMPILER_ID MATCHES "Clang$")
- add_compile_options(-Wno-overloaded-virtual)
add_compile_options(-Wno-user-defined-literals)
add_compile_options(-Wno-atomic-alignment)
add_compile_options(-Wno-c99-designator)