summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorItamar <itamar8910@gmail.com>2022-03-19 17:15:08 +0200
committerAndreas Kling <kling@serenityos.org>2022-03-19 22:02:44 +0100
commitb6f358689cb3ece58e3cfef0ee7177b66405fe76 (patch)
tree6df58bc5c23b89082d6d38bb5b450bbce48b364e /CMakeLists.txt
parentfe7d28e8701258640b1d485394f4fff7b14099a1 (diff)
downloadserenity-b6f358689cb3ece58e3cfef0ee7177b66405fe76.zip
CMake: Modify include path when building from Hack Studio
With regular builds, the generated IPC headers exist inside the Build directory. The path Userland/Services under the build directory is added to the include path. For in-system builds the IPC headers are installed at /usr/include/. To support this, we add /usr/include/Userland/Services to the build path when building from Hack Studio. Co-Authored-By: Andrew Kaster <akaster@serenityos.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71546875af..4d1caa6db3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,6 +269,7 @@ serenity_component(
)
if (HACKSTUDIO_BUILD)
+ include_directories(/usr/include/Userland/Services)
include(${HACKSTUDIO_BUILD_CMAKE_FILE})
return()
endif()