summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2022-10-12 22:00:21 +0200
committerLinus Groh <mail@linusgroh.de>2022-10-14 13:01:13 +0200
commita650c74b27cae619eac102b8bdcbae642af1eaf1 (patch)
treeaa93b04866c0c188ff182ee5b43d3a6c1283cb3c /CMakeLists.txt
parent31bd5b1a023124d960d79d5ace7e29b6d0a696d2 (diff)
downloadserenity-a650c74b27cae619eac102b8bdcbae642af1eaf1.zip
AK+Toolchain: Make char and wchar_t behave on AARCH64
By default char and wchar_t are unsigned on AARCH64. This fixes a bunch of related compiler errors.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0344af4abe..8df01f31d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,6 +182,11 @@ if (ENABLE_COMPILETIME_FORMAT_CHECK)
add_compile_definitions(ENABLE_COMPILETIME_FORMAT_CHECK)
endif()
+if("${SERENITY_ARCH}" STREQUAL "aarch64")
+ # FIXME: re-enable this warning
+ add_compile_options(-Wno-type-limits)
+endif()
+
add_link_options(-Wno-unused-command-line-argument)
include_directories(.)