summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Bertalan <dani@danielbertalan.dev>2022-05-07 17:50:41 +0200
committerAndreas Kling <kling@serenityos.org>2022-05-12 13:12:37 +0200
commit6cf260c7af8dd40a25104c8aafb22050c14545ea (patch)
tree55b91a49aad79119051b617d60cd50eab5bc40d5 /CMakeLists.txt
parentfd3e3d5e28f729c05427d1c3cfe95e1ae3f62e39 (diff)
downloadserenity-6cf260c7af8dd40a25104c8aafb22050c14545ea.zip
Toolchain: Upgrade to GCC 12.1.0
This release brings support for various C++23 constructs like `if consteval` and multidimensional subscript operators. Vectorization is now enabled for O2 too, and `-ftrivial-auto-var-init` has been added which can help us find and prevent security issues coming from uninitialized variables. Toolchain/Patches/gcc.patch is now significanly smaller as some unused, autoconf-generated code has been removed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66c3b7f965..0eb5c7f723 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,7 +17,7 @@ if(NOT CMAKE_SYSTEM_NAME STREQUAL "SerenityOS")
endif()
# Check for toolchain mismatch, user might need to rebuild toolchain
-set(GCC_VERSION "11.2.0")
+set(GCC_VERSION "12.1.0")
set(LLVM_VERSION "14.0.1")
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
set(EXPECTED_COMPILER_VERSION "${GCC_VERSION}")