summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNico Weber <thakis@chromium.org>2023-03-11 20:12:37 -0500
committerLinus Groh <mail@linusgroh.de>2023-03-12 01:48:56 +0000
commit3cff36b7ab427e040c9cac80a41cde9cfa0ac75d (patch)
tree132381acdfe4a70456f34079f74a0d2b22eb2b2d /CMakeLists.txt
parent952222ec4d82f4ac2d553d92449dba52f96c50b3 (diff)
downloadserenity-3cff36b7ab427e040c9cac80a41cde9cfa0ac75d.zip
Meta+CMake: Remove "image" ninja target in favor of "qemu-image"
"image" was an alias for "qemu-image". I want to add an `image` userland utility, which clashes with that shortname. So remove the existing "image" target. It was just an alias for "qemu-image". If you use serenity.sh to build, nothing changes. This only affects you if you run ninja manually -- you now have to say `ninja qemu-image` to build the disk image.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d316febfda..f2543506e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,15 +73,11 @@ add_custom_target(run
# out forcing re-builds when they might not want them.
add_custom_target(setup-and-run
COMMAND ${CMAKE_MAKE_PROGRAM} install
- COMMAND ${CMAKE_MAKE_PROGRAM} image
+ COMMAND ${CMAKE_MAKE_PROGRAM} qemu-image
COMMAND ${CMAKE_MAKE_PROGRAM} run
USES_TERMINAL
)
-add_custom_target(image
- DEPENDS qemu-image
-)
-
add_custom_target(qemu-image
COMMAND "${CMAKE_COMMAND}" -E env "SERENITY_SOURCE_DIR=${SerenityOS_SOURCE_DIR}" "SERENITY_ARCH=${SERENITY_ARCH}" "SERENITY_TOOLCHAIN=${CMAKE_CXX_COMPILER_ID}" "LLVM_VERSION=${CMAKE_CXX_COMPILER_VERSION}" "${SerenityOS_SOURCE_DIR}/Meta/build-image-qemu.sh"
BYPRODUCTS "${CMAKE_BINARY_DIR}/_disk_image"