summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGunnar Beutner <gbeutner@serenityos.org>2022-10-12 22:19:51 +0200
committerLinus Groh <mail@linusgroh.de>2022-10-14 13:01:13 +0200
commit3065577b540e31fb57dc618e9ebc142aba7f2fa8 (patch)
tree9494e65db5b568d5bd3bb1cfc941287fae7248e0 /CMakeLists.txt
parenta7a71be1131554700f0ff6f9b4a4ca200dd40649 (diff)
downloadserenity-3065577b540e31fb57dc618e9ebc142aba7f2fa8.zip
Everywhere: Enable building userspace and test binaries on AARCH64
Surely this will just work once the kernel boots, right?
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8df01f31d6..c252d42dd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,20 +228,22 @@ endif()
add_subdirectory(AK)
add_subdirectory(Kernel)
-if(NOT "${SERENITY_ARCH}" STREQUAL "aarch64")
- if (ENABLE_MOLD_LINKER)
- add_link_options(-fuse-ld=mold)
- endif()
+if (ENABLE_MOLD_LINKER)
+ add_link_options(-fuse-ld=mold)
+endif()
+
+if(NOT "${SERENITY_ARCH}" STREQUAL "aarch64")
if (CMAKE_CXX_COMPILER_ID MATCHES "Clang$" OR ENABLE_MOLD_LINKER)
add_link_options(LINKER:--pack-dyn-relocs=relr)
else()
add_link_options(LINKER:-z,pack-relative-relocs)
endif()
-
- add_subdirectory(Userland)
- add_subdirectory(Tests)
endif()
+
+add_subdirectory(Userland)
+add_subdirectory(Tests)
+
if (ENABLE_COMPILETIME_HEADER_CHECK)
add_subdirectory(Meta/HeaderCheck)
endif()